unrtf.scm 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
  4. ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages unrtf)
  21. #:use-module (guix licenses)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (guix gexp)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages autotools)
  28. #:use-module (gnu packages m4)
  29. #:use-module (gnu packages base))
  30. (define-public unrtf
  31. (package
  32. (name "unrtf")
  33. (version "0.21.10")
  34. (source (origin
  35. (method url-fetch)
  36. (uri (string-append "mirror://gnu/unrtf/unrtf-"
  37. version ".tar.gz"))
  38. (sha256
  39. (base32
  40. "1bil6z4niydz9gqm2j861dkxmqnpc8m7hvidsjbzz7x63whj17xl"))))
  41. (build-system gnu-build-system)
  42. (home-page "https://www.gnu.org/software/unrtf/")
  43. (synopsis "Convert Rich Text Format documents to other formats")
  44. (description
  45. "GNU UnRTF converts text documents from RTF to HTML, LaTeX, or troff.
  46. It supports changes in font characteristics, underlines and strikethroughs,
  47. superscripts and subscripts, and more.")
  48. (license gpl3+)))