syndication.scm 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016, 2017, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
  3. ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
  5. ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages syndication)
  22. #:use-module ((guix licenses) #:prefix license:)
  23. #:use-module (guix download)
  24. #:use-module (guix git-download)
  25. #:use-module (guix packages)
  26. #:use-module (guix utils)
  27. #:use-module (guix build-system cargo)
  28. #:use-module (guix build-system glib-or-gtk)
  29. #:use-module (guix build-system gnu)
  30. #:use-module (guix build-system meson)
  31. #:use-module (guix build-system python)
  32. #:use-module (guix build-system qt)
  33. #:use-module (gnu packages)
  34. #:use-module (gnu packages autotools)
  35. #:use-module (gnu packages base)
  36. #:use-module (gnu packages check)
  37. #:use-module (gnu packages crates-io)
  38. #:use-module (gnu packages curl)
  39. #:use-module (gnu packages documentation)
  40. #:use-module (gnu packages freedesktop)
  41. #:use-module (gnu packages gettext)
  42. #:use-module (gnu packages glib)
  43. #:use-module (gnu packages gnome)
  44. #:use-module (gnu packages gstreamer)
  45. #:use-module (gnu packages gtk)
  46. #:use-module (gnu packages kde-frameworks)
  47. #:use-module (gnu packages ncurses)
  48. #:use-module (gnu packages pkg-config)
  49. #:use-module (gnu packages python)
  50. #:use-module (gnu packages python-check)
  51. #:use-module (gnu packages python-xyz)
  52. #:use-module (gnu packages python-web)
  53. #:use-module (gnu packages qt)
  54. #:use-module (gnu packages ruby)
  55. #:use-module (gnu packages rust)
  56. #:use-module (gnu packages sqlite)
  57. #:use-module (gnu packages time)
  58. #:use-module (gnu packages tls)
  59. #:use-module (gnu packages video)
  60. #:use-module (gnu packages web)
  61. #:use-module (gnu packages webkit)
  62. #:use-module (gnu packages xml)
  63. #:use-module (gnu packages xorg)
  64. #:use-module (srfi srfi-1))
  65. (define-public cawbird
  66. (package
  67. (name "cawbird")
  68. (version "1.4.1")
  69. (source
  70. (origin
  71. (method git-fetch)
  72. (uri (git-reference
  73. (url "https://github.com/IBBoard/cawbird")
  74. (commit (string-append "v"version))))
  75. (file-name (git-file-name name version))
  76. (sha256
  77. (base32 "0lmrgcj1ky1vhzynl36k6ba3ws089x4qdrnkjk3lbr334kicx9na"))))
  78. (build-system meson-build-system)
  79. (arguments
  80. `(#:glib-or-gtk? #t
  81. #:configure-flags
  82. ;; Cawbirds's default key and secret for OAuth process with twitter.
  83. (list
  84. "-Dconsumer_key_base64=VmY5dG9yRFcyWk93MzJEZmhVdEk5Y3NMOA=="
  85. "-Dconsumer_secret_base64=MThCRXIxbWRESDQ2Y0podzVtVU13SGUyVGlCRXhPb3BFRHhGYlB6ZkpybG5GdXZaSjI=")
  86. #:phases
  87. (modify-phases %standard-phases
  88. (add-after 'unpack 'disable-failing-tests
  89. (lambda _
  90. ;; These tests require networking.
  91. (substitute* "tests/meson.build"
  92. (("[ \t]*.*avatardownload.*$") "")
  93. (("[ \t]*.*filters.*$") "")
  94. (("[ \t]*.*friends.*$") "")
  95. (("[ \t]*.*inlinemediadownloader.*$") "")
  96. (("[ \t]*.*tweetparsing.*$") "")
  97. (("[ \t]*.*usercounter.*$") ""))))
  98. (delete 'check)
  99. (add-after 'install 'custom-check
  100. (lambda* (#:key outputs tests? #:allow-other-keys)
  101. (when tests?
  102. ;; Tests require a running X server.
  103. (system "Xvfb :1 +extension GLX &")
  104. (setenv "DISPLAY" ":1")
  105. ;; Tests write to $HOME.
  106. (setenv "HOME" (getcwd))
  107. ;; Tests look for gsettings-schemas installed by the package.
  108. (setenv "XDG_DATA_DIRS"
  109. (string-append (getenv "XDG_DATA_DIRS")
  110. ":" (assoc-ref outputs "out") "/share"))
  111. (invoke "meson" "test"))
  112. #t))
  113. (add-after 'glib-or-gtk-wrap 'wrap-paths
  114. (lambda* (#:key outputs #:allow-other-keys)
  115. (let* ((out (assoc-ref outputs "out"))
  116. (bin (string-append out "/bin/"))
  117. (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
  118. (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
  119. (wrap-program (string-append bin "cawbird")
  120. `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
  121. `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
  122. #t)))))
  123. (native-inputs
  124. `(("gettext" ,gettext-minimal)
  125. ("glib:bin" ,glib "bin")
  126. ("gobject-introspection" ,gobject-introspection)
  127. ("gtk+:bin" ,gtk+ "bin")
  128. ("pkg-config" ,pkg-config)
  129. ("vala" ,vala)
  130. ("xmllint" ,libxml2)
  131. ("xorg-server" ,xorg-server-for-tests)))
  132. (inputs
  133. `(("glib" ,glib)
  134. ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
  135. ("gspell" ,gspell)
  136. ("gstreamer" ,gstreamer)
  137. ("gst-libav" ,gst-libav)
  138. ("gst-plugins-bad" ,gst-plugins-bad)
  139. ("gst-plugins-base" ,gst-plugins-base)
  140. ("gst-plugins-good" ,gst-plugins-good)
  141. ("gtk+" ,gtk+)
  142. ("json-glib" ,json-glib)
  143. ("liboauth" ,liboauth)
  144. ("libsoup" ,libsoup)
  145. ("rest" ,rest)
  146. ("sqlite" ,sqlite)
  147. ("x11" ,libx11)))
  148. (propagated-inputs
  149. `(("dconf" ,dconf)))
  150. (synopsis "Client for Twitter")
  151. (description "Cawbird is a Twitter client built with GTK and Vala.
  152. It supports all features except non-mention notifications, polls, threads and
  153. cards.")
  154. (home-page "https://ibboard.co.uk/cawbird/")
  155. (license license:gpl3+)))
  156. (define-public giara
  157. (package
  158. (name "giara")
  159. (version "0.3")
  160. (source
  161. (origin
  162. (method git-fetch)
  163. (uri (git-reference
  164. (url "https://gitlab.gnome.org/World/giara")
  165. (commit version)))
  166. (file-name (git-file-name name version))
  167. ;; To fix authentication while adding accounts.
  168. (patches (search-patches "giara-fix-login.patch"))
  169. (sha256
  170. (base32 "004qmkfrgd37axv0b6hfh6v7nx4pvy987k5yv4bmlmkj9sbqm6f9"))))
  171. (build-system meson-build-system)
  172. (arguments
  173. `(#:glib-or-gtk? #t
  174. #:phases
  175. (modify-phases %standard-phases
  176. (add-after 'glib-or-gtk-wrap 'wrap-paths
  177. (lambda* (#:key outputs #:allow-other-keys)
  178. (let* ((out (assoc-ref outputs "out"))
  179. (bin (string-append out "/bin/"))
  180. (lib (string-append out "/lib/python"
  181. ,(version-major+minor
  182. (package-version python))
  183. "/site-packages")))
  184. (wrap-program (string-append bin "giara")
  185. `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH") ,lib))
  186. `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))))
  187. #t)))))
  188. (native-inputs
  189. `(("gettext" ,gettext-minimal)
  190. ("glib:bin" ,glib "bin")
  191. ("gobject-introspection" ,gobject-introspection)
  192. ("gtk+:bin" ,gtk+ "bin")
  193. ("pkg-config" ,pkg-config)
  194. ("xmllint" ,libxml2)))
  195. (inputs
  196. `(("glib" ,glib)
  197. ("gtk+" ,gtk+)
  198. ("gtksourceview" ,gtksourceview)
  199. ("libhandy" ,libhandy)
  200. ("python" ,python)
  201. ("python-beautifulsoup" ,python-beautifulsoup4)
  202. ("python-dateutil" ,python-dateutil)
  203. ("python-mistune" ,python-mistune)
  204. ("python-pillow" ,python-pillow)
  205. ("python-praw" ,python-praw)
  206. ("python-pycairo" ,python-pycairo)
  207. ("python-pygobject" ,python-pygobject)
  208. ("python-requests" ,python-requests)
  209. ("webkitgtk" ,webkitgtk)))
  210. (propagated-inputs
  211. `(("dconf" ,dconf)))
  212. (synopsis "Client for Reddit")
  213. (description "Giara is a reddit app, built with Python, GTK and Handy.")
  214. (home-page "https://giara.gabmus.org/")
  215. (license license:gpl3+)))
  216. (define-public newsboat
  217. (package
  218. (name "newsboat")
  219. (version "2.24")
  220. (source
  221. (origin
  222. (method url-fetch)
  223. (uri (string-append "https://newsboat.org/releases/" version
  224. "/newsboat-" version ".tar.xz"))
  225. (sha256
  226. (base32 "1yvggkb29qykxlvrysb6yyf5piwsvzv0zla8jn2ihmm2rj40chk2"))))
  227. (build-system cargo-build-system)
  228. (native-inputs
  229. `(("gettext" ,gettext-minimal)
  230. ("openssl" ,openssl)
  231. ("pkg-config" ,pkg-config)
  232. ;; For building documentation.
  233. ("asciidoctor" ,ruby-asciidoctor)))
  234. (inputs
  235. `(("curl" ,curl)
  236. ("json-c" ,json-c)
  237. ("libxml2" ,libxml2)
  238. ("ncurses" ,ncurses)
  239. ("stfl" ,stfl)
  240. ("sqlite" ,sqlite)))
  241. (arguments
  242. `(#:modules ((guix build cargo-build-system)
  243. (guix build utils)
  244. ((guix build gnu-build-system) #:prefix gnu:))
  245. #:vendor-dir "vendor"
  246. #:install-source? #f
  247. #:cargo-inputs
  248. (("rust-backtrace" ,rust-backtrace-0.3)
  249. ("rust-bitflags" ,rust-bitflags-1)
  250. ("rust-chrono" ,rust-chrono-0.4)
  251. ("rust-clap" ,rust-clap-2)
  252. ("rust-curl-sys" ,rust-curl-sys-0.4)
  253. ("rust-cxx" ,rust-cxx-1)
  254. ("rust-gettext-rs" ,rust-gettext-rs-0.7)
  255. ("rust-libc" ,rust-libc-0.2)
  256. ("rust-natord" ,rust-natord-1)
  257. ("rust-nom" ,rust-nom-6)
  258. ("rust-once-cell" ,rust-once-cell-1)
  259. ("rust-percent-encoding" ,rust-percent-encoding-2)
  260. ("rust-rand" ,rust-rand-0.8)
  261. ("rust-url" ,rust-url-2)
  262. ("rust-unicode-width" ,rust-unicode-width-0.1)
  263. ("rust-xdg" ,rust-xdg-2))
  264. #:cargo-development-inputs
  265. (("rust-cxx-build" ,rust-cxx-build-1)
  266. ("rust-tempfile" ,rust-tempfile-3)
  267. ("rust-proptest" ,rust-proptest-0.9)
  268. ("rust-section-testing" ,rust-section-testing-0.0))
  269. #:phases
  270. (modify-phases %standard-phases
  271. (add-after 'configure 'dont-vendor-self
  272. (lambda* (#:key vendor-dir #:allow-other-keys)
  273. ;; Don't keep the whole tarball in the vendor directory
  274. (delete-file-recursively
  275. (string-append vendor-dir "/" ,name "-" ,version ".tar.xz"))))
  276. (add-after 'unpack 'patch-source
  277. (lambda* (#:key outputs #:allow-other-keys)
  278. (substitute* "Makefile"
  279. (("Cargo.lock") "")
  280. ;; Replace the prefix in the Makefile.
  281. (("/usr/local") (assoc-ref outputs "out")))))
  282. (replace 'build
  283. (assoc-ref gnu:%standard-phases 'build))
  284. (replace 'check
  285. (lambda args
  286. ((assoc-ref gnu:%standard-phases 'check)
  287. #:test-target "test")))
  288. (replace 'install
  289. (assoc-ref gnu:%standard-phases 'install)))))
  290. (native-search-paths
  291. ;; Newsboat respects CURL_CA_BUNDLE.
  292. (package-native-search-paths curl))
  293. (home-page "https://newsboat.org/")
  294. (synopsis "Text-mode RSS and Atom feed reader with podcast support")
  295. (description "Newsboat is a feed reader for @dfn{RSS} and @dfn{Atom}, XML
  296. formats widely used to transmit, publish, and syndicate news or blog articles.
  297. It's designed for use on text terminals, and to have a coherent and easy-to-use
  298. interface that might look familiar to @command{mutt} or @command{slrn} users.
  299. Newsboat supports OPML import/exports, HTML rendering, podcasts (with
  300. @command{podboat}), off-line reading, searching and storing articles to your
  301. file system, and many more features.")
  302. (license (list license:gpl2+ ; filter/*
  303. license:expat)))) ; everything else
  304. (define-public newsboat-2.13
  305. (package
  306. (inherit newsboat)
  307. (version "2.13")
  308. (source
  309. (origin
  310. (method url-fetch)
  311. (uri (string-append "https://newsboat.org/releases/" version
  312. "/newsboat-" version ".tar.xz"))
  313. (sha256
  314. (base32
  315. "0pik1d98ydzqi6055vdbkjg5krwifbk2hy2f5jp5p1wcy2s16dn7"))))
  316. (build-system gnu-build-system)
  317. (native-inputs
  318. `(,@(fold alist-delete (package-native-inputs newsboat)
  319. '("asciidoctor" "openssl"))
  320. ;; For building documentation.
  321. ("asciidoc" ,asciidoc)))
  322. (inputs
  323. `(("json-c" ,json-c-0.13)
  324. ,@(alist-delete "json-c" (package-inputs newsboat))))
  325. (arguments
  326. '(#:phases
  327. (modify-phases %standard-phases
  328. (delete 'configure) ; no configure script
  329. (add-after 'build 'build-documentation
  330. (lambda _
  331. (invoke "make" "doc"))))
  332. #:make-flags
  333. (list (string-append "prefix=" (assoc-ref %outputs "out")))
  334. #:test-target "test"))))
  335. (define-public liferea
  336. (package
  337. (name "liferea")
  338. (version "1.13.4")
  339. (source
  340. (origin
  341. (method git-fetch)
  342. (uri (git-reference
  343. (url "https://github.com/lwindolf/liferea/")
  344. (commit (string-append "v" version))))
  345. (file-name (git-file-name name version))
  346. (sha256
  347. (base32 "1g9463bvswsm899j6dfhslcg6np70m5wq143mjicr24zy8d17bm7"))))
  348. (build-system glib-or-gtk-build-system)
  349. (arguments
  350. `(#:configure-flags
  351. (list
  352. "--disable-static")
  353. #:phases
  354. (modify-phases %standard-phases
  355. (add-before 'configure 'prepare-build-environment
  356. (lambda* (#:key inputs #:allow-other-keys)
  357. ;; Workaround for https://github.com/lwindolf/liferea/issues/767.
  358. (setenv "WEBKIT_DISABLE_COMPOSITING_MODE" "1")))
  359. (add-after 'install 'wrap-gi-python
  360. (lambda* (#:key inputs outputs #:allow-other-keys)
  361. (let ((out (assoc-ref outputs "out"))
  362. (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
  363. (python-path (getenv "GUIX_PYTHONPATH")))
  364. (wrap-program (string-append out "/bin/liferea")
  365. `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
  366. `("GUIX_PYTHONPATH" ":" prefix (,python-path))))
  367. #t)))))
  368. (native-inputs
  369. `(("autoconf" ,autoconf)
  370. ("automake" ,automake)
  371. ("gettext" ,gettext-minimal)
  372. ("glib:bin" ,glib "bin")
  373. ("gobject-introspection" ,gobject-introspection)
  374. ("intltool" ,intltool)
  375. ("libtool" ,libtool)
  376. ("pkg-config" ,pkg-config)
  377. ("which" ,which)))
  378. (inputs
  379. `(("glib" ,glib)
  380. ("glib-networking" ,glib-networking)
  381. ("gnome-keyring" ,gnome-keyring)
  382. ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
  383. ("gstreamer" ,gstreamer)
  384. ("json-glib" ,json-glib)
  385. ("libnotify" ,libnotify)
  386. ("libpeas" ,libpeas)
  387. ("libsecret" ,libsecret)
  388. ("libsoup" ,libsoup)
  389. ("libxml2" ,libxml2)
  390. ("libxslt" ,libxslt)
  391. ("pango" ,pango)
  392. ("python" ,python)
  393. ("python-pycairo" ,python-pycairo)
  394. ("python-pygobject" ,python-pygobject)
  395. ("sqlite" ,sqlite)
  396. ("webkitgtk" ,webkitgtk)))
  397. (home-page "https://lzone.de/liferea/")
  398. (synopsis "News reader for GTK/GNOME")
  399. (description "Liferea is a desktop feed reader/news aggregator that
  400. brings together all of the content from your favorite subscriptions into
  401. a simple interface that makes it easy to organize and browse feeds.")
  402. (license license:gpl2+)))
  403. (define-public rtv
  404. (package
  405. (name "rtv")
  406. (version "1.27.0")
  407. (source
  408. (origin
  409. (method url-fetch)
  410. (uri (pypi-uri "rtv" version))
  411. (sha256
  412. (base32 "0hvw426y09l3yzwv2zkb9hifpfbg9wd1gg0y3z3pxcli6n3ii2wl"))))
  413. (build-system python-build-system)
  414. (arguments
  415. '(#:phases
  416. (modify-phases %standard-phases
  417. (add-before 'check 'set-environment-variables
  418. (lambda* (#:key inputs #:allow-other-keys)
  419. (setenv "HOME" (getcwd))
  420. (setenv "TERM" "linux")
  421. (setenv "TERMINFO"
  422. (search-input-directory inputs "share/terminfo")))))
  423. #:tests? #f)) ; tests fail: _curses.error: nocbreak() returned ERR
  424. (propagated-inputs
  425. `(("python-beautifulsoup4" ,python-beautifulsoup4)
  426. ("python-decorator" ,python-decorator)
  427. ("python-kitchen" ,python-kitchen)
  428. ("python-requests" ,python-requests)
  429. ("python-six" ,python-six)))
  430. (native-inputs
  431. `(("ncurses" ,ncurses)
  432. ("python-coveralls" ,python-coveralls)
  433. ("python-coverage" ,python-coverage)
  434. ("python-mock" ,python-mock)
  435. ("python-pylint" ,python-pylint)
  436. ("python-pytest" ,python-pytest)
  437. ("python-vcrpy" ,python-vcrpy)))
  438. (home-page "https://github.com/michael-lazar/rtv")
  439. (synopsis "Terminal viewer for Reddit (Reddit Terminal Viewer)")
  440. (description
  441. "RTV provides a text-based interface to view and interact with Reddit.")
  442. (license (list license:expat
  443. license:gpl3+)))) ; rtv/packages/praw
  444. (define-public tuir
  445. (package
  446. (name "tuir")
  447. (version "1.29.0")
  448. (source
  449. (origin
  450. (method url-fetch)
  451. (uri (pypi-uri "tuir" version))
  452. (sha256
  453. (base32
  454. "06xb030ibphbrz4nsxm8mh3g60ld8xfp6kc3j6vi1k4ls5s4h79i"))))
  455. (build-system python-build-system)
  456. (arguments
  457. `(#:phases
  458. (modify-phases %standard-phases
  459. (replace 'check
  460. (lambda* (#:key tests? inputs outputs #:allow-other-keys)
  461. (add-installed-pythonpath inputs outputs)
  462. (when tests?
  463. (invoke "pytest")))))))
  464. (inputs
  465. `(("python-beautifulsoup4" ,python-beautifulsoup4)
  466. ("python-decorator" ,python-decorator)
  467. ("python-kitchen" ,python-kitchen)
  468. ("python-requests" ,python-requests)
  469. ("python-six" ,python-six)))
  470. (native-inputs
  471. `(("python-coverage" ,python-coverage)
  472. ("python-coveralls" ,python-coveralls)
  473. ("python-mock" ,python-mock)
  474. ("python-pylint" ,python-pylint)
  475. ("python-pytest" ,python-pytest)
  476. ("python-vcrpy" ,python-vcrpy)))
  477. (home-page "https://gitlab.com/ajak/tuir")
  478. (synopsis "Terminal viewer for Reddit (Terminal UI for Reddit)")
  479. (description
  480. "Tuir provides a simple terminal viewer for Reddit (Terminal UI for Reddit).")
  481. (license (list license:expat
  482. license:gpl3+)))) ; tuir/packages/praw
  483. (define-public rawdog
  484. (package
  485. (name "rawdog")
  486. (version "2.23")
  487. (source
  488. (origin
  489. (method url-fetch)
  490. (uri (string-append "https://offog.org/files/rawdog-"
  491. version ".tar.gz"))
  492. (sha256
  493. (base32
  494. "18nyg19mwxyqdnykplkqmzb4n27vvrhvp639zai8f81gg9vdbsjp"))))
  495. (build-system python-build-system)
  496. (arguments
  497. `(#:python ,python-2.7))
  498. (inputs
  499. `(("python2-feedparser" ,python2-feedparser)
  500. ("python2-pytidylib" ,python2-pytidylib)))
  501. (home-page "https://offog.org/code/rawdog/")
  502. (synopsis "RSS Aggregator Without Delusions Of Grandeur")
  503. (description
  504. "@command{rawdog} is a feed aggregator, capable of producing a personal
  505. \"river of news\" or a public \"planet\" page. It supports all common feed
  506. formats, including all versions of RSS and Atom.")
  507. (license license:gpl2+)))
  508. (define-public quiterss
  509. (package
  510. (name "quiterss")
  511. (version "0.19.4")
  512. (source (origin
  513. (method git-fetch)
  514. (uri (git-reference
  515. (url "https://github.com/QuiteRSS/quiterss")
  516. (commit version)))
  517. (file-name (git-file-name name version))
  518. (sha256
  519. (base32
  520. "1cgvl67vhn5y7bj5gbjbgk26bhb0196bgrgsp3r5fmrislarj8s6"))
  521. (modules '((guix build utils)))
  522. (snippet
  523. '(begin
  524. (substitute* (find-files "." "\\.cpp$")
  525. ;; Disable Google Analytics spyware by default,
  526. ;; removing completely is not trivial.
  527. (("settings\\.value\\(\"Settings/statisticsEnabled2\", true\\)")
  528. "settings.value(\"Settings/statisticsEnabled2\", false)")
  529. ;; Disable update check spyware by default, otherwise runs
  530. ;; at every startup, nasty. Not needed on GNU Guix as a
  531. ;; feature either way.
  532. (("settings\\.value\\(\"Settings/updateCheckEnabled\", true\\)")
  533. "settings.value(\"Settings/updateCheckEnabled\", false)"))
  534. #t))))
  535. (build-system qt-build-system)
  536. (arguments
  537. `(#:tests? #f ;; no test suite
  538. #:phases
  539. (modify-phases %standard-phases
  540. (replace 'configure
  541. (lambda* (#:key inputs outputs #:allow-other-keys)
  542. (invoke "qmake" "CONFIG+=release"
  543. (string-append "PREFIX="
  544. (assoc-ref outputs "out"))
  545. (string-append "QMAKE_LRELEASE="
  546. (assoc-ref inputs "qttools")
  547. "/bin/lrelease")))))))
  548. (native-inputs
  549. `(("pkg-config" ,pkg-config)
  550. ("qttools" ,qttools)))
  551. (inputs
  552. `(("qtwebkit" ,qtwebkit)
  553. ("qtbase" ,qtbase-5)
  554. ("qtmultimedia" ,qtmultimedia)
  555. ("phonon" ,phonon)
  556. ("sqlite" ,sqlite)))
  557. (home-page "https://quiterss.org/")
  558. (synopsis "RSS/Atom news feeds reader written on Qt/C++")
  559. (description "QuiteRSS is an RSS/Atom news feeds reader written on Qt/C++
  560. that aims to be quite fast and comfortable to its user.")
  561. (license license:gpl3+)))
  562. (define-public gfeeds
  563. (package
  564. (name "gfeeds")
  565. (version "0.16.2")
  566. (source (origin
  567. (method url-fetch)
  568. (uri
  569. (string-append
  570. "https://gitlab.gnome.org/World/gfeeds/-/archive/" version
  571. "/gfeeds-" version ".tar.bz2"))
  572. (sha256
  573. (base32
  574. "05gwwzqfz29m477imd5vh84jfla1wnklwpc2sdxnqli72wg08fli"))))
  575. (build-system meson-build-system)
  576. (arguments
  577. `(#:phases
  578. (modify-phases %standard-phases
  579. (add-after 'unpack 'patch-mpv-path
  580. (lambda* (#:key inputs #:allow-other-keys)
  581. (substitute* "gfeeds/confManager.py"
  582. (("mpv") (search-input-file inputs "/bin/mpv")))
  583. #t))
  584. (add-after 'install 'wrap-gfeeds
  585. (lambda* (#:key outputs #:allow-other-keys)
  586. (wrap-program (string-append
  587. (assoc-ref outputs "out") "/bin/gfeeds")
  588. `("PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
  589. `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))
  590. `("XDG_DATA_DIRS" ":" prefix (,(getenv "XDG_DATA_DIRS"))))
  591. #t)))))
  592. (native-inputs
  593. `(("glib:bin" ,glib "bin")
  594. ("gobject-introspection" ,gobject-introspection)
  595. ("gtk+:bin" ,gtk+ "bin")
  596. ("pkg-config" ,pkg-config)))
  597. (inputs
  598. `(("glib" ,glib)
  599. ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
  600. ("gtk+" ,gtk+)
  601. ("hicolor-icon-theme" ,hicolor-icon-theme)
  602. ("libhandy" ,libhandy)
  603. ("mpv" ,mpv)
  604. ("python" ,python)
  605. ("python-beautifulsoup4" ,python-beautifulsoup4)
  606. ("python-dateutil" ,python-dateutil)
  607. ("python-feedparser" ,python-feedparser)
  608. ("python-html5lib" ,python-html5lib)
  609. ("python-listparser" ,python-listparser)
  610. ("python-lxml" ,python-lxml)
  611. ("python-pillow" ,python-pillow)
  612. ("python-pygments" ,python-pygments)
  613. ("python-pytz" ,python-pytz)
  614. ("python-readability" ,python-readability)
  615. ("python-requests" ,python-requests)
  616. ("webkitgtk" ,webkitgtk)
  617. ("python-pygobject" ,python-pygobject)))
  618. (home-page "https://gfeeds.gabmus.org/")
  619. (synopsis "Easy-to-use GTK+ RSS/Atom feed reader")
  620. (description "Feeds is an RSS/Atom feed reader made with GTK+
  621. and it has an easy-to-use graphical user interface.")
  622. (license license:gpl3+)))