swig.scm 2.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2018, 2021 Marius Bakke <marius@gnu.org>
  5. ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
  6. ;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
  7. ;;;
  8. ;;; This file is part of GNU Guix.
  9. ;;;
  10. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  11. ;;; under the terms of the GNU General Public License as published by
  12. ;;; the Free Software Foundation; either version 3 of the License, or (at
  13. ;;; your option) any later version.
  14. ;;;
  15. ;;; GNU Guix is distributed in the hope that it will be useful, but
  16. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  17. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. ;;; GNU General Public License for more details.
  19. ;;;
  20. ;;; You should have received a copy of the GNU General Public License
  21. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  22. (define-module (gnu packages swig)
  23. #:use-module (guix packages)
  24. #:use-module (guix download)
  25. #:use-module (guix licenses)
  26. #:use-module (guix build-system gnu)
  27. #:use-module (gnu packages)
  28. #:use-module (gnu packages boost)
  29. #:use-module (gnu packages guile)
  30. #:use-module (gnu packages pcre)
  31. #:use-module (gnu packages perl)
  32. #:use-module (gnu packages python))
  33. (define-public swig
  34. (package
  35. (name "swig")
  36. (version "4.0.2")
  37. (source (origin
  38. (method url-fetch)
  39. (uri (string-append "mirror://sourceforge/" name "/" name "/"
  40. name "-" version "/"
  41. name "-" version ".tar.gz"))
  42. (sha256
  43. (base32
  44. "1z06m5zv87mha6hvys1iay810ghc1jngilfby1ms2n4d1mryjfym"))))
  45. (build-system gnu-build-system)
  46. (native-inputs `(("boost" ,boost)
  47. ("pcre" ,pcre "bin") ;for 'pcre-config'
  48. ;; The following are for tests and examples:
  49. ("guile" ,guile-3.0)
  50. ("perl" ,perl)))
  51. ;;("python" ,python-wrapper)
  52. (inputs `(("pcre" ,pcre)))
  53. (home-page "http://swig.org/")
  54. (synopsis
  55. "Interface compiler that connects C/C++ code to higher-level languages")
  56. (description
  57. "SWIG is an interface compiler that connects programs written in C and
  58. C++ with languages such as Perl, Python, Ruby, Scheme, and Tcl. It works by
  59. taking the declarations found in C/C++ header files and using them to generate
  60. the wrapper code that scripting languages need to access the underlying C/C++
  61. code. In addition, SWIG provides a variety of customization features that let
  62. you tailor the wrapping process to suit your application.")
  63. ;; See http://www.swig.org/Release/LICENSE for details.
  64. (license gpl3+)))