lighting.scm 3.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
  3. ;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages lighting)
  20. #:use-module (guix build-system gnu)
  21. #:use-module (guix git-download)
  22. #:use-module ((guix licenses) #:prefix license:)
  23. #:use-module (guix packages)
  24. #:use-module (gnu packages)
  25. #:use-module (gnu packages autotools)
  26. #:use-module (gnu packages bison)
  27. #:use-module (gnu packages check)
  28. #:use-module (gnu packages compression)
  29. #:use-module (gnu packages gnunet)
  30. #:use-module (gnu packages flex)
  31. #:use-module (gnu packages libftdi)
  32. #:use-module (gnu packages libusb)
  33. #:use-module (gnu packages linux)
  34. #:use-module (gnu packages pkg-config)
  35. #:use-module (gnu packages protobuf))
  36. (define-public ola
  37. ;; Use a commit that allows building with libmicrohttpd 0.9.71.
  38. ;; https://github.com/OpenLightingProject/ola/pull/1651
  39. (let ((commit "5d882936436240b312b3836afd199587beaca840")
  40. (revision "0"))
  41. (package
  42. (name "ola")
  43. (version (git-version "0.10.7" revision commit))
  44. (source
  45. (origin
  46. (method git-fetch)
  47. (uri (git-reference
  48. (url "https://github.com/OpenLightingProject/ola")
  49. (commit commit)))
  50. (sha256
  51. (base32 "1bhl3gvmvmnyrygfj13cibf2xirm285m8abjkaxq22hrqbsvab2m"))
  52. (file-name (git-file-name name version))))
  53. (build-system gnu-build-system)
  54. (native-inputs
  55. `(("bison" ,bison)
  56. ("cppunit" ,cppunit)
  57. ("flex" ,flex)
  58. ("pkg-config" ,pkg-config)
  59. ;; For git repository bootstrapping.
  60. ("autoconf" ,autoconf)
  61. ("automake" ,automake)
  62. ("libtool" ,libtool)))
  63. (inputs
  64. `(("libftdi" ,libftdi)
  65. ("libmicrohttpd" ,libmicrohttpd)
  66. ("libusb" ,libusb)
  67. ("libuuid" ,util-linux "lib")
  68. ("zlib" ,zlib)))
  69. (propagated-inputs
  70. `(("protobuf" ,protobuf))) ; for pkg-config --libs libola
  71. (arguments
  72. `( ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
  73. ;; build to fail on low memory systems. We disable that with the
  74. ;; following configure flags.
  75. #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
  76. (synopsis "Framework for controlling entertainment lighting equipment")
  77. (description "The Open Lighting Architecture is a framework for lighting
  78. control information. It supports a range of protocols and over a dozen USB
  79. devices. It can run as a standalone service, which is useful for converting
  80. signals between protocols, or alternatively using the OLA API, it can be used
  81. as the backend for lighting control software. OLA runs on many different
  82. platforms including ARM, which makes it a perfect fit for low cost Ethernet to
  83. DMX gateways.")
  84. (home-page "https://www.openlighting.org/ola")
  85. (license license:lgpl2.1+))))