libphidget.scm 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages libphidget)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (guix licenses)
  25. #:use-module (gnu packages libusb))
  26. (define-public libphidget
  27. (package
  28. (name "libphidget")
  29. (version "2.1.9.20190409")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append
  33. "https://www.phidgets.com/downloads/phidget21/libraries/"
  34. "linux/libphidget/libphidget_"
  35. version ".tar.gz"))
  36. (sha256
  37. (base32 "07w54dmr75vq2imngfy66nk1sxlvkzhl2p6g362q0a02f099jy0f"))))
  38. (build-system gnu-build-system)
  39. (inputs `(("libusb" ,libusb)))
  40. (outputs '("out" "debug"))
  41. (home-page "https://www.phidgets.com/")
  42. (license lgpl3+)
  43. (synopsis "C library to manipulate Phidgets")
  44. (description synopsis)))