libidn.scm 3.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
  3. ;;; Copyright © 2016, 2017, 2021 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
  5. ;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
  6. ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
  7. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  8. ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
  9. ;;;
  10. ;;; This file is part of GNU Guix.
  11. ;;;
  12. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  13. ;;; under the terms of the GNU General Public License as published by
  14. ;;; the Free Software Foundation; either version 3 of the License, or (at
  15. ;;; your option) any later version.
  16. ;;;
  17. ;;; GNU Guix is distributed in the hope that it will be useful, but
  18. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  19. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  20. ;;; GNU General Public License for more details.
  21. ;;;
  22. ;;; You should have received a copy of the GNU General Public License
  23. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  24. (define-module (gnu packages libidn)
  25. #:use-module (gnu packages)
  26. #:use-module (gnu packages compression)
  27. #:use-module (gnu packages libunistring)
  28. #:use-module (guix licenses)
  29. #:use-module (guix packages)
  30. #:use-module (guix download)
  31. #:use-module (guix build-system gnu))
  32. (define-public libidn
  33. (package
  34. (name "libidn")
  35. (version "1.37")
  36. (source (origin
  37. (method url-fetch)
  38. (uri (string-append "mirror://gnu/libidn/libidn-" version
  39. ".tar.gz"))
  40. (sha256
  41. (base32
  42. "1hljls9rkilh04dwiwg388wk8djkac8idijrdysqq2nqbh6rg3iw"))))
  43. (build-system gnu-build-system)
  44. ;; FIXME: No Java and C# libraries are currently built.
  45. (arguments
  46. `(#:configure-flags '("--disable-static")))
  47. (synopsis "Internationalized string processing library")
  48. (description
  49. "libidn is a library implementing of the Stringprep, Punycode and IDNA
  50. specifications. These are used to encode and decode internationalized domain
  51. names according to the IDNA2003 specifications. It includes native C, C# and
  52. Java libraries.")
  53. ;; The C code is dual-licensed gpl2+ lgpl3+, the manual is fdl1.3+,
  54. ;; the command line tool is gpl3+.
  55. (license (list gpl2+ gpl3+ lgpl3+ fdl1.3+))
  56. (home-page "https://www.gnu.org/software/libidn/")))
  57. (define-public libidn2
  58. (package
  59. (name "libidn2")
  60. (version "2.3.1")
  61. (source (origin
  62. (method url-fetch)
  63. (uri (string-append "mirror://gnu/libidn/" name "-" version
  64. ".tar.gz"))
  65. (sha256
  66. (base32
  67. "0b8gsksj2g9f4iywwdma3v4jcg7i9rqvdxfmclwvbf1n72a89xla"))))
  68. (inputs
  69. `(("libunistring" ,libunistring)))
  70. (build-system gnu-build-system)
  71. (arguments
  72. `(#:configure-flags '("--disable-static")))
  73. (synopsis "Internationalized domain name library for IDNA2008")
  74. (description "Libidn2 is an internationalized domain library implementing
  75. the IDNA2008 specifications. Libidn2 is believed to be a complete IDNA2008
  76. implementation, but has yet to be as extensively used as the original Libidn
  77. library.")
  78. (home-page "https://www.gnu.org/software/libidn/#libidn2")
  79. (properties '((ftp-directory . "/gnu/libidn")))
  80. ;; The command-line tool 'idn2' is GPL3+, while the library is dual-licensed
  81. ;; GPL2+ or LGPL3+.
  82. (license (list gpl2+ gpl3+ lgpl3+))))