123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
- ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
- ;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages kde-internet)
- #:use-module (guix build-system qt)
- #:use-module (guix download)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix utils)
- #:use-module (gnu packages)
- #:use-module (gnu packages boost)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages glib)
- #:use-module (gnu packages gnupg)
- #:use-module (gnu packages image)
- #:use-module (gnu packages kde)
- #:use-module (gnu packages kde-frameworks)
- #:use-module (gnu packages kde-pim)
- #:use-module (gnu packages libidn)
- #:use-module (gnu packages linphone)
- #:use-module (gnu packages linux)
- #:use-module (gnu packages messaging)
- #:use-module (gnu packages mp3)
- #:use-module (gnu packages multiprecision)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages qt)
- #:use-module (gnu packages rdesktop)
- #:use-module (gnu packages serialization)
- #:use-module (gnu packages ssh)
- #:use-module (gnu packages telephony)
- #:use-module (gnu packages linphone)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages video)
- #:use-module (gnu packages web)
- #:use-module (gnu packages xiph)
- #:use-module (gnu packages xml))
- (define-public choqok
- (package
- (name "choqok")
- (version "1.7.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/choqok/"
- (version-major+minor version)
- "/src/choqok-" version ".tar.xz"))
- (sha256
- (base32 "0zm4nkpmvd181xlkis7ydzx54p3vn0zgpdzgh54f1hsjy6ahsq16"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("attica" ,attica)
- ("breeze-icons" ,breeze-icons) ; default icon set
- ("kcmutils" ,kcmutils)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kdewebkit" ,kdewebkit)
- ("kemoticons" ,kemoticons)
- ("kglobalaccel" ,kglobalaccel)
- ("kguiaddons" ,kguiaddons)
- ("ki18n" ,ki18n)
- ("kio" ,kio)
- ("knotifications" ,knotifications)
- ("knotifyconfig" ,knotifyconfig)
- ("kparts" ,kparts)
- ("ktextwidgets" ,ktextwidgets)
- ("kwallet" ,kwallet)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ;; TODO: telepathy
- ("purpose" ,purpose)
- ("qca" ,qca)
- ("qoauth" ,qoauth)
- ("qtbase" ,qtbase-5)
- ("qtnetworkauth" ,qtnetworkauth)
- ("qtwebkit" ,qtwebkit)
- ("sonnet" ,sonnet)))
- (home-page "https://apps.kde.org/choqok/")
- (synopsis "Micro-Blogging Client")
- (description "Choqok is a fast, efficient and simple to use micro-blogging
- client for KDE. It currently supports the twitter.com and identi.ca
- microblogging services.
- Other notable features include:
- @itemize
- @item Support for user + friends time-lines.
- @item Support for @@Reply time-lines.
- @item Support for sending and receiving direct messages.
- @item Twitpic.com integration.
- @item The ability to use multiple accounts simultaneously.
- @item Support for search APIs for all services.
- @item KWallet integration.
- @item Support for automatic shortening urls with more than 30 characters.
- @item Support for configuring status lists appearance.
- @end itemize")
- (license license:gpl3+)))
- (define-public kget
- (package
- (name "kget")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/kget-" version ".tar.xz"))
- (sha256
- (base32 "06lng1sr1l5a7qcbld7xn97vlaxnq4f98sai2llmjkyna3awzi6r"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("boost" ,boost)
- ("breeze-icons" ,breeze-icons) ; default icon set
- ("gmp" ,gmp)
- ("gpgme" ,gpgme)
- ("kcmutils" ,kcmutils)
- ("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("kdelibs4support" ,kdelibs4support) ;; KLocale
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kio" ,kio)
- ("kitemviews" ,kitemviews)
- ("knotifications" ,knotifications)
- ("knotifyconfig" ,knotifyconfig)
- ("kparts" ,kparts)
- ("kservice" ,kservice)
- ("ktextwidgets" ,ktextwidgets)
- ("kwallet" ,kwallet)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kwindowsystem" ,kwindowsystem)
- ("kxmlgui" ,kxmlgui)
- ("libgcrypt" ,libgcrypt)
- ("libktorrent" ,libktorrent)
- ;; TODO: libmms
- ;; TODO: LibKWorkspace - plasma-workspace?
- ("qca" ,qca)
- ("qgpgme" ,qgpgme)
- ("qtbase" ,qtbase-5)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests? ;; FIXME: One test fails.
- (invoke "ctest" "-E" "schedulertest"))
- #t)))))
- (home-page "http://www.kde.org/")
- (synopsis "Versatile and user-friendly download manager")
- (description "KGet is an advanced download manager with support for
- Metalink and Bittorrent. Downloads are added to the list, where they can be
- paused, queued, or scheduled for later. KGet supports download via FTP anf
- HTTP(S) as well as pausing downloads.
- This package is part of the KDE networking module.")
- (license ;; GPL for programs, LGPL for libraries, FDL for documentation
- (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
- (define-public konversation
- (package
- (name "konversation")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/konversation-" version ".tar.xz"))
- (sha256
- (base32 "0v3nvyjc13jav8x9krg9sd9p533j7ndan0fqb5p0virwk1dznvfy"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("breeze-icons" ,breeze-icons) ; default icon set
- ("karchive" ,karchive)
- ("kbookmarks" ,kbookmarks)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("kemoticons" ,kemoticons)
- ("kglobalaccel" ,kglobalaccel)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kidletime" ,kidletime)
- ("kio" ,kio)
- ("kitemviews" ,kitemviews)
- ("knewstuff" ,knewstuff)
- ("knotifications" ,knotifications)
- ("knotifyconfig" ,knotifyconfig)
- ("kparts" ,kparts)
- ("kwallet" ,kwallet)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kwindowsystem" ,kwindowsystem)
- ("phonon" ,phonon)
- ("qtbase" ,qtbase-5)
- ("qca" ,qca)
- ("solid" ,solid)
- ("sonnet" ,sonnet)))
- (home-page "https://konversation.kde.org/")
- (synopsis "Graphical Internet Relay Chat (IRC) client for KDE")
- (description "Konversation is a graphical Internet Relay Chat client (IRC)
- with KDE support.
- Features are:
- @itemize
- @item Standard IRC features
- @item SSL server support
- @item Bookmarking support
- @item Easy to use graphical user interface
- @item Multiple servers and channels in one single window
- @item DCC file transfer with resume support
- @item Multiple identities for different servers
- @item Text decorations and colors
- @item Pattern-based message highlighting and OnScreen Display notifications
- @item Automatic UTF-8 detection
- @item Per channel encoding support
- @item Theme support for nick icons
- @item Highly configurable
- @item Multi-language scripting support (with DCOP)
- @item Customizable command aliases
- @item NickServ-aware log-on (for registered nicknames)
- @item Smart logging
- @item Traditional or enhanced-shell-style nick completion
- @end itemize")
- (license ;; GPL for programs, FDL for documentation
- (list license:gpl2+ license:fdl1.2+))))
- (define-public kopete
- (package
- (name "kopete")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/kopete-" version ".tar.xz"))
- (sha256
- (base32 "131nic6w1bzc0l94b8jkzac2dckaz64y2fgplyiqjidicm0cyrd1"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("alsa-lib" ,alsa-lib)
- ("boost" ,boost)
- ("expat" ,expat)
- ("glib" ,glib)
- ("gpgme" ,gpgme)
- ("jsoncpp" ,jsoncpp)
- ("kcmutils" ,kcmutils)
- ("kconfig" ,kconfig)
- ("kcontacts" ,kcontacts)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("kdelibs4support" ,kdelibs4support)
- ("kdnssd" ,kdnssd)
- ("kemoticons" ,kemoticons)
- ("khtml" ,khtml)
- ("ki18n" ,ki18n)
- ("kidentitymanagement" ,kidentitymanagement)
- ("kjs" ,kjs)
- ;; TODO? kleopatra (additionally to libkleo)
- ("knotifyconfig" ,knotifyconfig)
- ("kparts" ,kparts)
- ("kpimtextedit" ,kpimtextedit)
- ("ksyntaxhighlighting" ,ksyntaxhighlighting)
- ("ktexteditor" ,ktexteditor)
- ("kwallet" ,kwallet)
- ;; TODO: Libgadu
- ("libidn" ,libidn)
- ("libkleo" ,libkleo)
- ;; TODO: LibMeanwhile
- ("libotr" ,libotr)
- ("libsrtp" ,libsrtp)
- ("libxml2" ,libxml2)
- ("libxstl" ,libxslt)
- ("mediastreamer2" ,mediastreamer2)
- ("openssl" ,openssl)
- ("ortp" ,ortp)
- ("phonon" ,phonon)
- ("qca" ,qca)
- ("qgpgme" ,qgpgme)
- ("qtbase" ,qtbase-5)
- ("speex" ,speex)
- ("v4l-utils" ,v4l-utils)
- ;; TODO: Xmms
- ("zlib" ,zlib)))
- ;; TODO: enable video support
- (home-page "https://apps.kde.org/kopete/")
- (synopsis "Instant messaging and chat application")
- (description "Kopete is an instant messenger supporting Jabber/XMPP ,AIM,
- ICQ, Gadu-Gadu, Novell GroupWise Messenger, and more. It is designed to be a
- flexible and extensible multi-protocol system suitable for personal and
- enterprise use.
- The goal of Kopete is to provide users with a single easy-to-use way to access
- all of their instant messaging systems. The interface puts people first, and
- is integrated with the system address book to let you access your contacts
- from other KDE applications.
- This package is part of the KDE networking module.")
- (license ;; GPL for programs, LGPL for libraries, FDL for documentation
- (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
- (define-public krdc
- (package
- (name "krdc")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/krdc-" version ".tar.xz"))
- (sha256
- (base32 "038m7wgpg33sqqqq7iy4rvficsi7x2012rimxb1gn2azg5kcwk6v"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("breeze-icons" ,breeze-icons) ; default icon set
- ("freerdp" ,freerdp)
- ("kbookmarks" ,kbookmarks)
- ("kcmutils" ,kcmutils)
- ("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kdnssd" ,kdnssd)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("knotifications" ,knotifications)
- ("knotifyconfig" ,knotifyconfig)
- ("knotifyconfig" ,knotifyconfig)
- ("kwallet" ,kwallet)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kwindowsystem" ,kwindowsystem)
- ("kxmlgui" ,kxmlgui)
- ("libssh2" ,libssh)
- ;; TODO: libvnc{server,client} - is not tigervnc-{server,client}
- ("qtbase" ,qtbase-5)))
- (home-page "https://apps.kde.org/krdc/")
- (synopsis "Remote desktop client")
- (description "KRDC is a client application that allows you to view or even
- control the desktop session on another machine that is running a compatible
- server. VNC and RDP are supported.
- This package is part of the KDE networking module.")
- (license ;; GPL for programs, LGPL for libraries, FDL for documentation
- (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
- (define-public ktorrent
- (package
- (name "ktorrent")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/ktorrent-" version ".tar.xz"))
- (sha256
- (base32 "1r7w43ns4zy94y82dbghrjgqv1sbdj01rni0iijirzjjikr5av9m"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("boost" ,boost)
- ("breeze-icons" ,breeze-icons) ; default icon set
- ("gmp" ,gmp)
- ("karchive" ,karchive)
- ("kcmutils" ,kcmutils)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("kdewebkit" ,kdewebkit)
- ("kdnssd" ,kdnssd)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kio" ,kio)
- ("knotifications" ,knotifications)
- ("knotifyconfig" ,knotifyconfig)
- ("kparts" ,kparts)
- ("kplotting" ,kplotting)
- ("kross" ,kross)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kwindowsystem" ,kwindowsystem)
- ("kxmlgui" ,kxmlgui)
- ("libgcrypt" ,libgcrypt)
- ("libktorrent" ,libktorrent)
- ;; TODO: LibKWorkspace -> plasma-workspace?
- ("phonon" ,phonon)
- ("qtbase" ,qtbase-5)
- ("qtscript" ,qtscript)
- ("qtwebengine" ,qtwebengine)
- ("qtwebkit" ,qtwebkit)
- ("solid" ,solid)
- ("syndication" ,syndication)
- ("taglib" ,taglib)))
- (home-page "https://apps.kde.org/ktorrent/")
- (synopsis "BitTorrent client")
- (description "KTorrent is a BitTorrent application by KDE which allows you
- to download files using the BitTorrent protocol. It enables you to run
- multiple torrents at the same time and comes with extended features to make it
- a full-featured client for BitTorrent.")
- (license license:gpl2+)))
- (define-public libgravatar
- (package
- (name "libgravatar")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/libgravatar-" version ".tar.xz"))
- (sha256
- (base32 "08xl8nb0bn6zf9sh7sn4v7aa86ffqb16hixci4ymixyxy5c4gwbv"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)))
- (inputs
- `(("kconfig" ,kconfig)
- ("ki18n" ,ki18n)
- ("kio" ,kio)
- ("kpimcommon" ,kpimcommon)
- ("ktextwidgets" ,ktextwidgets)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("qtbase" ,qtbase-5)))
- (arguments
- `(#:tests? #f)) ;; 2/7 tests fail (due to network issues?)
- (home-page "https://invent.kde.org/pim/libgravatar")
- (synopsis "Online avatar lookup library")
- (description "This library retrieves avatar images based on a
- hash from a person's email address, as well as local caching to avoid
- unnecessary network operations.")
- (license ;; GPL for programs, LGPL for libraries
- (list license:gpl2+ license:lgpl2.0+))))
- (define-public libktorrent
- (package
- (name "libktorrent")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/libktorrent-" version ".tar.xz"))
- (sha256
- (base32 "0y5881v0g49rr8dspzaq4l1c62rchgfq4mjx64sn0ng2jjpnhv1x"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)))
- (inputs
- `(("boost" ,boost)
- ("gmp" ,gmp)
- ("karchive" ,karchive)
- ("kcrash" ,kcrash)
- ("ki18n" ,ki18n)
- ("kio" ,kio)
- ("libgcrypt" ,libgcrypt)
- ("qca" ,qca)
- ("qtbase" ,qtbase-5)
- ("solid" ,solid)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests? ;; FIXME: test fails inconsistently.
- (invoke "ctest" "-E" "superseedtest"))
- #t)))))
- (home-page "https://invent.kde.org/network/libktorrent")
- (synopsis "BitTorrent protocol library for C++ / Qt 5 / KDE Frameworks")
- (description "The KTorrent library supports connectivity to HTTP and UDP
- trackers, mainline DHT and the new generation Micro Transport
- Protocol (uTP). In addition, it provides many powerful BitTorrent network
- features including but not limited to torrent downloading and seeding, torrent
- creation and downloaded data verification, magnet links, advanced peer
- management, IP blocking lists.")
- (license license:gpl2+)))
|