jose.scm 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2018 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
  3. ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages jose)
  20. #:use-module ((guix licenses) #:prefix license:)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix utils)
  24. #:use-module (guix build-system meson)
  25. #:use-module (gnu packages pkg-config)
  26. #:use-module (gnu packages web)
  27. #:use-module (gnu packages compression)
  28. #:use-module (gnu packages tls))
  29. (define-public jose
  30. (package
  31. (name "jose")
  32. (version "11")
  33. (source (origin
  34. (method url-fetch)
  35. (uri
  36. (string-append "https://github.com/latchset/jose/releases/"
  37. "download/v" version "/jose-" version ".tar.xz"))
  38. (sha256
  39. (base32
  40. "09c2kn9cjqkgx4g0rf6c2k3ng9970r468c9z7067j8kyf7ksywp2"))))
  41. (build-system meson-build-system)
  42. (native-inputs `(("pkg-config" ,pkg-config)))
  43. (inputs `(("jansson" ,jansson)
  44. ("zlib" ,zlib)
  45. ("libcrypto" ,openssl)))
  46. (home-page "https://github.com/latchset/jose")
  47. (synopsis "Object Signing and Encryption")
  48. (description "C-language implementation of Javascript Object Signing and
  49. Encryption")
  50. (license license:asl2.0)))