inklingreader.scm 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages inklingreader)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu)
  23. #:use-module (gnu packages)
  24. #:use-module (gnu packages autotools)
  25. #:use-module (gnu packages glib)
  26. #:use-module (gnu packages gnome)
  27. #:use-module (gnu packages gtk)
  28. #:use-module (gnu packages libusb)
  29. #:use-module (gnu packages pkg-config))
  30. (define-public inklingreader
  31. (package
  32. (name "inklingreader")
  33. (version "0.8")
  34. (source (origin
  35. (method url-fetch)
  36. (uri (string-append
  37. "ftp://alpha.gnu.org/gnu/inklingreader/inklingreader-"
  38. version ".tar.gz"))
  39. (sha256
  40. (base32
  41. "0ikg95mgwfqh0bq4dzvkfmdiycacqvv27g91hl6adwk5y3gzl96g"))))
  42. (build-system gnu-build-system)
  43. (inputs
  44. `(("glib" ,glib)
  45. ("cairo" ,cairo)
  46. ("gtk+" ,gtk+)
  47. ("librsvg" ,librsvg)
  48. ("libusb" ,libusb)))
  49. (native-inputs
  50. `(("pkg-config" ,pkg-config)))
  51. (home-page "https://www.gnu.org/software/inklingreader/")
  52. (synopsis "Wacom Inkling sketch format conversion and manipulation")
  53. (description
  54. "GNU InklingReader is a package to support the Wacom Inkling device,
  55. including data conversion to various free formats, basic editing features,
  56. and an Inkscape plugin.")
  57. (license license:gpl3+)))