gnu-doc.scm 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
  3. ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages gnu-doc)
  20. #:use-module (gnu packages base)
  21. #:use-module (gnu packages compression)
  22. #:use-module (gnu packages texinfo)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (guix build-system trivial)
  25. #:use-module (guix cvs-download)
  26. #:use-module (guix download)
  27. #:use-module (guix licenses)
  28. #:use-module (guix packages))
  29. (define-public miscfiles
  30. (package
  31. (name "miscfiles")
  32. (version "1.5")
  33. (source
  34. (origin
  35. (method url-fetch)
  36. (uri (string-append "mirror://gnu/" name "/" name "-"
  37. version ".tar.gz"))
  38. (sha256
  39. (base32
  40. "005588vfrwx8ghsdv9p7zczj9lbc9a3r4m5aphcaqv8gif4siaka"))))
  41. (build-system gnu-build-system)
  42. (home-page "https://www.gnu.org/software/miscfiles/")
  43. (synopsis
  44. "Data files for airport codes, zip codes, a dictionary, and more")
  45. (description
  46. "GNU Miscfiles is a collection of common data files. They include, for
  47. example, country abbreviations, names and capital cities; currency
  48. abbreviations and names; a Best Current Practices index; a map of the ASCII
  49. character set; a list of three-letter airport codes; and an English word
  50. list.")
  51. (license gpl2+)))
  52. (define-public gnu-standards
  53. (package
  54. (name "gnu-standards")
  55. (version "2020-11-25")
  56. (source
  57. (origin
  58. (method cvs-fetch)
  59. (uri (cvs-reference
  60. (root-directory
  61. ":pserver:anonymous@cvs.savannah.gnu.org:/sources/gnustandards")
  62. (module "gnustandards")
  63. (revision version)))
  64. (sha256
  65. (base32
  66. "1xlwmgcnvp81ipgfir4ckpgl922mbckvxy1x758r0lksq5vrpglj"))
  67. (file-name (string-append name "-" version "-checkout"))))
  68. (build-system trivial-build-system)
  69. (native-inputs `(("gzip" ,gzip)
  70. ("source" ,source)
  71. ("texinfo" ,texinfo)))
  72. (arguments
  73. `(#:modules ((guix build utils))
  74. #:builder
  75. (begin
  76. (use-modules (guix build utils))
  77. (let ((gzip (assoc-ref %build-inputs "gzip"))
  78. (source (assoc-ref %build-inputs "source"))
  79. (texinfo (assoc-ref %build-inputs "texinfo"))
  80. (info-dir (string-append %output "/share/info")))
  81. (setenv "PATH" (string-append gzip "/bin"
  82. ":" texinfo "/bin"))
  83. (mkdir-p info-dir)
  84. (invoke "makeinfo" "--output" info-dir
  85. (string-append source "/maintain.texi"))
  86. (invoke "makeinfo" "--output" info-dir
  87. (string-append source "/standards.texi"))
  88. (invoke "gzip" (string-append info-dir "/maintain.info"))
  89. (invoke "gzip" (string-append info-dir "/standards.info"))))))
  90. (home-page "https://www.gnu.org/prep/standards/")
  91. (synopsis "GNU coding standards and maintainer information")
  92. (description "The GNU Coding Standards were written by Richard Stallman
  93. and other GNU Project volunteers. Their purpose is to make the GNU system
  94. clean, consistent, and easy to install.
  95. The information for maintainers of GNU software has guidelines and advice for
  96. someone who is the maintainer of a GNU program on behalf of the GNU Project.")
  97. (license fdl1.3+)))