figlet.scm 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages figlet)
  19. #:use-module ((guix licenses) #:prefix license:)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu))
  23. (define-public figlet
  24. (package
  25. (name "figlet")
  26. (version "2.2.5")
  27. (source
  28. (origin
  29. (method url-fetch)
  30. (uri (string-append "ftp://ftp.figlet.org/pub/figlet/program"
  31. "/unix/figlet-" version ".tar.gz"))
  32. (sha256
  33. (base32 "0za1ax15x7myjl8jz271ybly8ln9kb9zhm1gf6rdlxzhs07w925z"))))
  34. (build-system gnu-build-system)
  35. (arguments
  36. `(#:phases
  37. (modify-phases %standard-phases (delete 'configure))
  38. #:make-flags
  39. (list (string-append "prefix=" %output))))
  40. (home-page "http://www.figlet.org/")
  41. (synopsis "Make large letterforms out of ordinary screen characters")
  42. (description "FIGlet is a program for making large ASCII art letterforms
  43. out of ordinary screen characters.")
  44. (license license:bsd-3)))