dico.scm 3.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages dico)
  22. #:use-module (guix packages)
  23. #:use-module ((guix licenses) #:select (gpl3+))
  24. #:use-module (guix download)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages readline)
  28. #:use-module (gnu packages m4)
  29. #:use-module (gnu packages groff)
  30. #:use-module (gnu packages guile)
  31. #:use-module (gnu packages python)
  32. #:use-module (gnu packages pcre)
  33. #:use-module (gnu packages gsasl)
  34. #:use-module (gnu packages autotools)
  35. #:use-module (gnu packages compression)
  36. #:use-module (gnu packages wordnet))
  37. (define-public dico
  38. (package
  39. (name "dico")
  40. (version "2.11")
  41. (source (origin
  42. (method url-fetch)
  43. (uri (string-append "mirror://gnu/dico/dico-"
  44. version ".tar.xz"))
  45. (sha256
  46. (base32
  47. "0nic4mggc0yhms130k7x4qp5k9c42fwg6n8hmk5cmynh6gi9h7xc"))))
  48. (build-system gnu-build-system)
  49. (arguments
  50. '(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
  51. "/share/guile/site/2.0")
  52. "--disable-static")
  53. #:make-flags '("V=1")
  54. #:phases (modify-phases %standard-phases
  55. (add-before 'check 'silence-guile
  56. (lambda _
  57. ;; Guile is too talkative, which disturbs the test
  58. ;; infrastructure. Gag it.
  59. (setenv "GUILE_AUTO_COMPILE" "0")
  60. (setenv "GUILE_WARN_DEPRECATED" "no")
  61. #t))
  62. (replace 'check
  63. (lambda _
  64. ;; Test '71: append + dooffs + env' fails if $V is not 2.
  65. (invoke "make" "check" "V=2"))))))
  66. (native-inputs `(("groff" ,groff)))
  67. (inputs
  68. `(("m4" ,m4) ;used at run time
  69. ("pcre" ,pcre)
  70. ("python" ,python-2)
  71. ("guile" ,guile-2.2)
  72. ("gsasl" ,gsasl)
  73. ("readline" ,readline)
  74. ("zlib" ,zlib)
  75. ("wordnet" ,wordnet)
  76. ("libltdl" ,libltdl)))
  77. (home-page "https://www.gnu.org/software/dico/")
  78. (synopsis "Implementation of DICT server (RFC 2229)")
  79. (description
  80. "GNU Dico implements a flexible dictionary server and client according to
  81. RFC 2229 (DICT Server). It is able to access any database available,
  82. regardless of format, thanks to its modular structure. New modules may be
  83. written in C, Guile or Python. Dico also includes a command-line client,
  84. which may be used to query remote dictionary databases.")
  85. (license gpl3+)))