dc.scm 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
  3. ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages dc)
  20. #:use-module (gnu packages)
  21. #:use-module (gnu packages compression)
  22. #:use-module (gnu packages glib)
  23. #:use-module (gnu packages ncurses)
  24. #:use-module (gnu packages pkg-config)
  25. #:use-module (gnu packages sqlite)
  26. #:use-module (gnu packages tls)
  27. #:use-module (guix packages)
  28. #:use-module (guix download)
  29. #:use-module (guix build-system gnu)
  30. #:use-module ((guix licenses) #:prefix license:))
  31. (define-public ncdc
  32. (package
  33. (name "ncdc")
  34. (version "1.22.1")
  35. (source
  36. (origin
  37. (method url-fetch)
  38. (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version
  39. ".tar.gz"))
  40. (sha256
  41. (base32 "1bdgqd07f026qk6vpbxqsin536znd33931m3b4z44prlm9wd6pyi"))))
  42. (build-system gnu-build-system)
  43. (inputs
  44. `(("bzip2" ,bzip2)
  45. ("glib" ,glib)
  46. ("gnutls" ,gnutls)
  47. ("ncurses" ,ncurses)
  48. ("sqlite" ,sqlite)
  49. ("zlib" ,zlib)))
  50. (native-inputs
  51. `(("pkg-config" ,pkg-config)))
  52. (home-page "https://dev.yorhel.nl/ncdc")
  53. (synopsis
  54. "Lightweight direct connect client with a friendly ncurses interface")
  55. (description
  56. "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented
  57. using ncurses. It is known for its smaller footprint and ease of use.")
  58. (license license:x11)))