cvassistant.scm 3.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
  3. ;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages cvassistant)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu)
  23. #:use-module ((guix licenses) #:prefix license:)
  24. #:use-module (gnu packages qt)
  25. #:use-module (gnu packages compression))
  26. (define-public cvassistant
  27. (package
  28. (name "cvassistant")
  29. (version "3.1.0")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append "mirror://sourceforge/cvassistant/"
  33. "cvassistant-" version "-src.tar.bz2"))
  34. (sha256
  35. (base32
  36. "1y2680bazyiwm50gdhdd4982ckbjscrkbw2mngyk7yw708iadvr7"))))
  37. (build-system gnu-build-system)
  38. (arguments
  39. `(#:phases
  40. (modify-phases %standard-phases
  41. (add-after 'unpack 'remove-donation-banner
  42. ;; Remove dialog box with a donation link, as suggested by
  43. ;; the INSTALL file.
  44. (lambda _
  45. (substitute* "controllers/mainwindow.cpp"
  46. (("//(#define NO_DONATION_PROMPT)" _ line) line))
  47. #t))
  48. (add-after 'unpack 'fix-quazip-directory
  49. (lambda _
  50. (substitute* "models/resumedocument.h"
  51. (("quazip(/quazipfile\\.h)" _ suffix)
  52. (string-append "quazip5" suffix)))
  53. #t))
  54. (add-after 'fix-quazip-directory 'fix-quazip-link
  55. (lambda _
  56. (substitute* "CVAssistant.pro"
  57. (("lquazip-qt5")
  58. "lquazip5"))
  59. #t))
  60. (add-after 'fix-quazip-directory 'fix-install-root
  61. (lambda* (#:key outputs #:allow-other-keys)
  62. (let ((out (assoc-ref outputs "out")))
  63. (substitute* "CVAssistant.pro"
  64. (("/usr/(bin|share/)" _ suffix)
  65. (string-append out "/" suffix)))
  66. #t)))
  67. (replace 'configure
  68. (lambda _ (invoke "qmake"))))))
  69. (inputs
  70. `(("qtbase" ,qtbase-5)
  71. ("quazip" ,quazip)
  72. ("zlib" ,zlib)))
  73. (home-page "https://cvassistant.sourceforge.io/")
  74. (synopsis "Job application organizer")
  75. (description "Whether you're looking for a job or trying to help
  76. a friend to find one, CVAssistant is a tool for you. It helps you by
  77. preparing resumes and cover letters and organizing your job
  78. application process. It:
  79. @itemize
  80. @item Stores all your skills and experiences.
  81. @item Creates resumes tailored for each job you apply.
  82. @item Creates cover letters summarized to match each job
  83. advertisement.
  84. @item Keeps a history of job applications so you are ready when you
  85. receive a phone call.
  86. @item Writes resumes in your language. All languages are supported!
  87. @end itemize")
  88. (license license:gpl3+)))