cpio.scm 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
  3. ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages cpio)
  21. #:use-module (guix licenses)
  22. #:use-module (gnu packages)
  23. #:use-module (gnu packages autotools)
  24. #:use-module (guix packages)
  25. #:use-module (guix download)
  26. #:use-module (guix build-system gnu))
  27. (define-public cpio
  28. (package
  29. (name "cpio")
  30. (version "2.13")
  31. (source (origin
  32. (method url-fetch)
  33. (uri (string-append "mirror://gnu/cpio/cpio-"
  34. version ".tar.bz2"))
  35. (sha256
  36. (base32
  37. "0vbgnhkawdllgnkdn6zn1f56fczwk0518krakz2qbwhxmv2vvdga"))
  38. (modules '((guix build utils)))
  39. (snippet
  40. '(begin
  41. ;; Remove superfluous declaration that trips GCC 10.
  42. (substitute* "src/global.c"
  43. (("char \\*program_name;")
  44. ""))))))
  45. (build-system gnu-build-system)
  46. (home-page "https://www.gnu.org/software/cpio/")
  47. (synopsis "Manage cpio and tar file archives")
  48. (description
  49. "GNU cpio copies files into or out of cpio or tar archives. Indeed,
  50. many formats are supported, including legacy formats. The format is
  51. determined automatically by the program and is handled appropriately.
  52. Furthermore, the location of the archive is not important. It can be another
  53. file on the drive, a tape, or data on a pipe.")
  54. (license gpl3+)))