terraform.scm 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
  3. ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages terraform)
  20. #:use-module ((guix licenses) #:prefix license:)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix git-download)
  24. #:use-module (guix build-system go))
  25. (define-public terraform-docs
  26. (package
  27. (name "terraform-docs")
  28. (version "0.6.0")
  29. (source (origin
  30. (method git-fetch)
  31. (uri (git-reference
  32. (url "https://github.com/segmentio/terraform-docs")
  33. (commit (string-append "v" version))))
  34. (file-name (git-file-name name version))
  35. (sha256
  36. (base32
  37. "1p6prhjf82qnhf1zwl9h92j4ds5g383a6g9pwwnqbc3wdwy5zx7d"))))
  38. (build-system go-build-system)
  39. (arguments
  40. '(#:import-path "github.com/segmentio/terraform-docs"))
  41. (synopsis "Generate documentation from Terraform modules")
  42. (description
  43. "The @code{terraform-docs} utility can generate documentation describing
  44. the inputs and outputs for modules of the Terraform infrastructure management
  45. tool. These can be shown, or written to a file in JSON or Markdown formats.")
  46. (home-page "https://github.com/segmentio/terraform-docs")
  47. (license license:expat)))