sml.scm 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017 Andy Patterson <ajpatter@uwaterloo.ca>
  3. ;;; Copyright © 2017, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
  5. ;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages sml)
  22. #:use-module (gnu packages lesstif)
  23. #:use-module (gnu packages libffi)
  24. #:use-module (gnu packages multiprecision)
  25. #:use-module (gnu packages xorg)
  26. #:use-module (guix build-system gnu)
  27. #:use-module (guix download)
  28. #:use-module (guix git-download)
  29. #:use-module ((guix licenses) #:prefix license:)
  30. #:use-module (guix packages))
  31. (define-public polyml
  32. (package
  33. (name "polyml")
  34. (version "5.8.2")
  35. (source (origin
  36. (method git-fetch)
  37. (uri (git-reference
  38. (url "https://github.com/polyml/polyml")
  39. (commit (string-append "v" version))))
  40. (file-name (git-file-name name version))
  41. (sha256
  42. (base32
  43. "1y3i919kzylvhwfsi6adnc0ah0xahl6ncna0g5bcjyhxsq2416rn"))))
  44. (build-system gnu-build-system)
  45. (inputs
  46. `(("gmp" ,gmp)
  47. ("lesstif" ,lesstif)
  48. ("libffi" ,libffi)
  49. ("libx11" ,libx11)
  50. ("libxt" ,libxt)))
  51. (arguments
  52. '(#:configure-flags
  53. (list "--with-system-libffi=yes"
  54. "--with-x=yes"
  55. "--with-threads=yes"
  56. "--with-gmp=yes")
  57. #:phases
  58. (modify-phases %standard-phases
  59. (add-after 'build 'build-compiler
  60. (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
  61. (define flags
  62. (if parallel-build?
  63. (cons (format #f "-j~d" (parallel-job-count))
  64. make-flags)
  65. make-flags))
  66. (apply system* "make" (append flags (list "compiler"))))))))
  67. (home-page "https://www.polyml.org/")
  68. (synopsis "Standard ML implementation")
  69. (description "Poly/ML is a Standard ML implementation. It is fully
  70. compatible with the ML97 standard. It includes a thread library, a foreign
  71. function interface, and a symbolic debugger.")
  72. ;; Some source files specify 'or any later version'; some don't
  73. (license
  74. (list license:lgpl2.1
  75. license:lgpl2.1+))))