pv.scm 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Claes Wallin <claes.wallin@greatsinodevelopment.com>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages pv)
  19. #:use-module (guix licenses)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu))
  23. (define-public pv
  24. (package
  25. (name "pv")
  26. (version "1.6.6")
  27. (source
  28. (origin
  29. (method url-fetch)
  30. (uri (string-append "https://www.ivarch.com/programs/sources/pv-"
  31. version ".tar.bz2"))
  32. (sha256
  33. (base32
  34. "1wbk14xh9rfypiwyy68ssl8dliyji30ly70qki1y2xx3ywszk3k0"))))
  35. (build-system gnu-build-system)
  36. (home-page "https://www.ivarch.com/programs/pv.shtml")
  37. (synopsis "Pipeline progress indicator")
  38. (description
  39. "pv (Pipe Viewer) is a terminal-based tool for monitoring the progress
  40. of data through a pipeline. It can be inserted into any normal pipeline
  41. between two processes to give a visual indication of how quickly data is
  42. passing through, how long it has taken, how near to completion it is, and an
  43. estimate of how long it will be until completion.")
  44. (license artistic2.0)))