nano.scm 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
  3. ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
  5. ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages nano)
  22. #:use-module (guix licenses)
  23. #:use-module (gnu packages gettext)
  24. #:use-module (gnu packages ncurses)
  25. #:use-module (guix packages)
  26. #:use-module (guix download)
  27. #:use-module (guix build-system gnu))
  28. (define-public nano
  29. (package
  30. (name "nano")
  31. (version "5.8")
  32. (source
  33. (origin
  34. (method url-fetch)
  35. (uri (string-append "mirror://gnu/nano/nano-" version ".tar.xz"))
  36. (sha256
  37. (base32 "133nhxg4xfxisjzi85rn2l575hdbvcax1s13l4m6wcvq5zdn6fz4"))))
  38. (build-system gnu-build-system)
  39. (inputs
  40. `(("gettext" ,gettext-minimal)
  41. ("ncurses" ,ncurses)))
  42. (home-page "https://www.nano-editor.org/")
  43. (synopsis "Small, user-friendly console text editor")
  44. (description
  45. "GNU nano is a small and simple text editor for use in a terminal. Besides
  46. basic editing, it supports: undo/redo, syntax highlighting, spell checking,
  47. justifying, auto-indentation, bracket matching, interactive search-and-replace
  48. (with regular expressions), and the editing of multiple files.")
  49. (license gpl3+))) ; some files are under GPLv2+