musl.scm 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 Vincent Legoll <vincent.legoll@gmail.com>
  3. ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
  4. ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages musl)
  21. #:use-module (guix download)
  22. #:use-module (guix packages)
  23. #:use-module (guix build-system gnu)
  24. #:use-module ((guix licenses) #:prefix license:)
  25. #:use-module (gnu packages))
  26. (define-public musl
  27. (package
  28. (name "musl")
  29. (version "1.2.2")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append "https://www.musl-libc.org/releases/"
  33. "musl-" version ".tar.gz"))
  34. (sha256
  35. (base32
  36. "1p8r6bac64y98ln0wzmnixysckq3crca69ys7p16sy9d04i975lv"))))
  37. (build-system gnu-build-system)
  38. (arguments
  39. `(#:tests? #f ; musl has no tests
  40. #:configure-flags
  41. (list "--disable-gcc-wrapper")))
  42. (synopsis "Small C standard library")
  43. (description "musl is a simple and lightweight C standard library. It
  44. strives to be correct in the sense of standards-conformance and safety.")
  45. (home-page "https://musl.libc.org")
  46. ;; Musl as a whole is released under the Expat license. Parts of it are
  47. ;; derived from various third-party projects that are released under
  48. ;; non-copyleft licenses. See the COPYRIGHT file for details.
  49. (license license:expat)))