mtools.scm 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 John Darrington <jmd@gnu.org>
  3. ;;; Copyright © 2015, 2019 Ludovic Courtès <ludo@gnu.org>
  4. ;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages mtools)
  22. #:use-module (guix licenses)
  23. #:use-module (guix packages)
  24. #:use-module (guix download)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (gnu packages))
  27. (define-public mtools
  28. (package
  29. (name "mtools")
  30. (version "4.0.35")
  31. (source (origin
  32. (method url-fetch)
  33. (uri (string-append "mirror://gnu/mtools/mtools-"
  34. version ".tar.bz2"))
  35. (sha256
  36. (base32
  37. "0ja7lkbw6v36p0cq0hs3xsw2ks970k47d350j7cg1lji6wbrwxil"))
  38. (patches
  39. (search-patches "mtools-mformat-uninitialized.patch"))))
  40. (build-system gnu-build-system)
  41. (home-page "https://www.gnu.org/software/mtools/")
  42. (synopsis "Access MS-DOS disks without mounting")
  43. (description
  44. "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
  45. or Unix system. It supports long file names and multiple disk formats. It
  46. also supports some FAT-specific features such as volume labels and
  47. FAT-specific file attributes.")
  48. (license gpl3+)))