mpi.scm 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014, 2015, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
  3. ;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
  4. ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
  5. ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
  6. ;;; Copyright © 2017 Dave Love <fx@gnu.org>
  7. ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
  8. ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
  9. ;;; Copyright © 2018 Paul Garlick <pgarlick@tourbillion-technology.com>
  10. ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
  11. ;;;
  12. ;;; This file is part of GNU Guix.
  13. ;;;
  14. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  15. ;;; under the terms of the GNU General Public License as published by
  16. ;;; the Free Software Foundation; either version 3 of the License, or (at
  17. ;;; your option) any later version.
  18. ;;;
  19. ;;; GNU Guix is distributed in the hope that it will be useful, but
  20. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  21. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  22. ;;; GNU General Public License for more details.
  23. ;;;
  24. ;;; You should have received a copy of the GNU General Public License
  25. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  26. (define-module (gnu packages mpi)
  27. #:use-module (guix packages)
  28. #:use-module ((guix licenses) #:prefix license:)
  29. #:use-module (guix download)
  30. #:use-module (guix utils)
  31. #:use-module (guix deprecation)
  32. #:use-module (guix build-system gnu)
  33. #:use-module (guix build-system python)
  34. #:use-module (gnu packages)
  35. #:use-module (gnu packages base)
  36. #:use-module (gnu packages compression)
  37. #:use-module (gnu packages fabric-management)
  38. #:use-module (gnu packages gcc)
  39. #:use-module (gnu packages java)
  40. #:use-module (gnu packages libevent)
  41. #:use-module (gnu packages linux)
  42. #:use-module (gnu packages pciutils)
  43. #:use-module (gnu packages xorg)
  44. #:use-module (gnu packages gtk)
  45. #:use-module (gnu packages xml)
  46. #:use-module (gnu packages perl)
  47. #:use-module (gnu packages ncurses)
  48. #:use-module (gnu packages parallel)
  49. #:use-module (gnu packages pkg-config)
  50. #:use-module (gnu packages valgrind)
  51. #:use-module (srfi srfi-1)
  52. #:use-module (ice-9 match))
  53. (define-public hwloc-1
  54. ;; Note: For now we keep 1.x as the default because many packages have yet
  55. ;; to migrate to 2.0.
  56. (package
  57. (name "hwloc")
  58. (version "1.11.12")
  59. (source (origin
  60. (method url-fetch)
  61. (uri (string-append "https://www.open-mpi.org/software/hwloc/v"
  62. (version-major+minor version)
  63. "/downloads/hwloc-" version ".tar.bz2"))
  64. (sha256
  65. (base32
  66. "0za1b9lvrm3rhn0lrxja5f64r0aq1qs4m0pxn1ji2mbi8ndppyyx"))))
  67. (properties
  68. ;; Tell the 'generic-html' updater to monitor this URL for updates.
  69. `((release-monitoring-url
  70. . "https://www-lb.open-mpi.org/software/hwloc/current")))
  71. (build-system gnu-build-system)
  72. (outputs '("out" ;'lstopo' & co., depends on Cairo, libx11, etc.
  73. "lib" ;small closure
  74. "doc" ;400+ section 3 man pages
  75. "debug"))
  76. (inputs
  77. `(("libx11" ,libx11)
  78. ("cairo" ,cairo)
  79. ("ncurses" ,ncurses)
  80. ("expat" ,expat)
  81. ,@(if (not (string-prefix? "armhf"
  82. (or (%current-target-system)
  83. (%current-system))))
  84. `(("numactl" ,numactl))
  85. '())))
  86. (propagated-inputs
  87. ;; hwloc.pc lists it in 'Requires.private'.
  88. `(("libpciaccess" ,libpciaccess)))
  89. (native-inputs
  90. `(("pkg-config" ,pkg-config)))
  91. (arguments
  92. `(#:configure-flags '("--localstatedir=/var")
  93. #:phases
  94. (modify-phases %standard-phases
  95. (add-before 'check 'skip-linux-libnuma-test
  96. (lambda _
  97. ;; Arrange to skip 'tests/linux-libnuma', which fails on some
  98. ;; machines: <https://github.com/open-mpi/hwloc/issues/213>.
  99. (substitute* "tests/linux-libnuma.c"
  100. (("numa_available\\(\\)")
  101. "-1"))
  102. #t))
  103. (add-after 'install 'refine-libnuma
  104. ;; Give -L arguments for libraries to avoid propagation
  105. (lambda* (#:key inputs outputs #:allow-other-keys)
  106. (let ((out (assoc-ref outputs "lib"))
  107. (numa (assoc-ref inputs "numactl")))
  108. (substitute* (map (lambda (f) (string-append out "/" f))
  109. '("lib/pkgconfig/hwloc.pc" "lib/libhwloc.la"))
  110. (("-lnuma" lib)
  111. (string-append "-L" numa "/lib " lib))))))
  112. (add-after 'install 'avoid-circular-references
  113. (lambda* (#:key outputs #:allow-other-keys)
  114. (let ((lib (assoc-ref outputs "lib")))
  115. ;; Suppress the 'prefix=' and 'exec_prefix=' lines so that the
  116. ;; "lib" output doesn't refer to "out".
  117. (substitute* (string-append lib "/lib/pkgconfig/hwloc.pc")
  118. (("^.*prefix=.*$")
  119. ""))
  120. #t)))
  121. (add-after 'install 'move-man3-pages
  122. (lambda* (#:key outputs #:allow-other-keys)
  123. ;; Move section 3 man pages to the "doc" output.
  124. (let ((out (assoc-ref outputs "out"))
  125. (doc (assoc-ref outputs "doc")))
  126. (copy-recursively (string-append out "/share/man/man3")
  127. (string-append doc "/share/man/man3"))
  128. (delete-file-recursively (string-append out "/share/man/man3"))
  129. #t))))))
  130. (home-page "https://www.open-mpi.org/projects/hwloc/")
  131. (synopsis "Abstraction of hardware architectures")
  132. (description
  133. "hwloc provides a portable abstraction (across OS,
  134. versions, architectures, ...) of the hierarchical topology of modern
  135. architectures, including NUMA memory nodes, sockets, shared caches, cores and
  136. simultaneous multithreading. It also gathers various attributes such as cache
  137. and memory information. It primarily aims at helping high-performance
  138. computing applications with gathering information about the hardware so as to
  139. exploit it accordingly and efficiently.
  140. hwloc may display the topology in multiple convenient formats. It also offers
  141. a powerful programming interface to gather information about the hardware,
  142. bind processes, and much more.")
  143. (license license:bsd-3)))
  144. (define-public hwloc-2
  145. ;; Note: 2.x isn't the default yet, see above.
  146. (package
  147. (inherit hwloc-1)
  148. (version "2.5.0")
  149. (source (origin
  150. (method url-fetch)
  151. (uri (string-append "https://download.open-mpi.org/release/hwloc/v"
  152. (version-major+minor version)
  153. "/hwloc-" version ".tar.bz2"))
  154. (sha256
  155. (base32
  156. "1j2j9wn39a8v91r23xncm1rzls6rjkgkvdvqghbdsnq8ps491kx9"))))
  157. ;; libnuma is no longer needed.
  158. (inputs (alist-delete "numactl" (package-inputs hwloc-1)))
  159. (arguments
  160. (substitute-keyword-arguments (package-arguments hwloc-1)
  161. ((#:phases phases)
  162. `(modify-phases ,phases
  163. (replace 'skip-linux-libnuma-test
  164. (lambda _
  165. ;; Arrange to skip 'tests/hwloc/linux-libnuma', which fails on
  166. ;; some machines: <https://github.com/open-mpi/hwloc/issues/213>.
  167. (substitute* "tests/hwloc/linux-libnuma.c"
  168. (("numa_available\\(\\)")
  169. "-1"))
  170. #t))
  171. (add-before 'check 'skip-test-that-fails-on-qemu
  172. (lambda _
  173. ;; Skip test that fails on emulated hardware due to QEMU bug:
  174. ;; <https://bugs.gnu.org/40342>.
  175. (substitute* "tests/hwloc/hwloc_get_last_cpu_location.c"
  176. (("hwloc_topology_init" all)
  177. (string-append "exit (77);\n" all)))
  178. #t))))))))
  179. (define-deprecated hwloc-2.0 hwloc-2)
  180. (define-public hwloc
  181. ;; The latest stable series of hwloc.
  182. hwloc-2)
  183. (define-public openmpi
  184. (package
  185. (name "openmpi")
  186. (version "4.1.1")
  187. (source
  188. (origin
  189. (method url-fetch)
  190. (uri (string-append "https://www.open-mpi.org/software/ompi/v"
  191. (version-major+minor version)
  192. "/downloads/openmpi-" version ".tar.bz2"))
  193. (sha256
  194. (base32 "1nkwq123vvmggcay48snm9qqmrh0bdzpln0l1jnp26niidvplkz2"))
  195. (patches (search-patches "openmpi-mtl-priorities.patch"))))
  196. (properties
  197. ;; Tell the 'generic-html' updater to monitor this URL for updates.
  198. `((release-monitoring-url
  199. . "https://www.open-mpi.org/software/ompi/current")))
  200. (build-system gnu-build-system)
  201. (inputs
  202. `(("hwloc" ,hwloc-2 "lib")
  203. ("gfortran" ,gfortran)
  204. ("libfabric" ,libfabric)
  205. ("libevent" ,libevent)
  206. ("opensm" ,opensm)
  207. ,@(if (and (not (%current-target-system))
  208. (member (%current-system) (package-supported-systems psm)))
  209. `(("psm" ,psm))
  210. '())
  211. ,@(if (and (not (%current-target-system))
  212. (member (%current-system) (package-supported-systems psm2)))
  213. `(("psm2" ,psm2))
  214. '())
  215. ,@(if (and (not (%current-target-system))
  216. (member (%current-system) (package-supported-systems ucx)))
  217. `(("ucx" ,ucx))
  218. '())
  219. ("rdma-core" ,rdma-core)
  220. ("valgrind" ,valgrind)
  221. ("slurm" ,slurm))) ;for PMI support (launching via "srun")
  222. (native-inputs
  223. `(("pkg-config" ,pkg-config)
  224. ("perl" ,perl)))
  225. (outputs '("out" "debug"))
  226. (arguments
  227. `(#:configure-flags `("--enable-mpi-ext=affinity" ;cr doesn't work
  228. "--enable-memchecker"
  229. "--with-sge"
  230. "--with-valgrind"
  231. "--with-hwloc=external"
  232. "--with-libevent"
  233. ;; Help 'orterun' and 'mpirun' find their tools
  234. ;; under $prefix by default.
  235. "--enable-mpirun-prefix-by-default"
  236. ;; InfiniBand support
  237. "--enable-openib-control-hdr-padding"
  238. "--enable-openib-dynamic-sl"
  239. "--enable-openib-udcm"
  240. "--enable-openib-rdmacm"
  241. "--enable-openib-rdmacm-ibaddr"
  242. ;; Enable support for SLURM's Process Manager
  243. ;; Interface (PMI).
  244. ,(string-append "--with-pmi="
  245. (assoc-ref %build-inputs "slurm")))
  246. #:phases (modify-phases %standard-phases
  247. ;; opensm is needed for InfiniBand support.
  248. (add-after 'unpack 'find-opensm-headers
  249. (lambda* (#:key inputs #:allow-other-keys)
  250. (setenv "C_INCLUDE_PATH"
  251. (search-input-directory inputs
  252. "/include/infiniband"))
  253. (setenv "CPLUS_INCLUDE_PATH"
  254. (search-input-directory inputs
  255. "/include/infiniband"))))
  256. (add-before 'build 'remove-absolute
  257. (lambda _
  258. ;; Remove compiler absolute file names (OPAL_FC_ABSOLUTE
  259. ;; etc.) to reduce the closure size. See
  260. ;; <https://lists.gnu.org/archive/html/guix-devel/2017-07/msg00388.html>
  261. ;; and
  262. ;; <https://www.mail-archive.com/users@lists.open-mpi.org//msg31397.html>.
  263. (substitute* '("orte/tools/orte-info/param.c"
  264. "oshmem/tools/oshmem_info/param.c"
  265. "ompi/tools/ompi_info/param.c")
  266. (("_ABSOLUTE") ""))
  267. ;; Avoid valgrind (which pulls in gdb etc.).
  268. (substitute*
  269. '("./ompi/mca/io/romio321/src/io_romio321_component.c")
  270. (("MCA_io_romio321_COMPLETE_CONFIGURE_FLAGS")
  271. "\"[elided to reduce closure]\""))
  272. #t))
  273. (add-before 'build 'scrub-timestamps ;reproducibility
  274. (lambda _
  275. (substitute* '("ompi/tools/ompi_info/param.c"
  276. "orte/tools/orte-info/param.c"
  277. "oshmem/tools/oshmem_info/param.c")
  278. ((".*(Built|Configured) on.*") ""))
  279. #t))
  280. (add-after 'install 'remove-logs ;reproducibility
  281. (lambda* (#:key outputs #:allow-other-keys)
  282. (let ((out (assoc-ref outputs "out")))
  283. (for-each delete-file (find-files out "config.log"))
  284. #t))))))
  285. (home-page "https://www.open-mpi.org")
  286. (synopsis "MPI-3 implementation")
  287. (description
  288. "The Open MPI Project is an MPI-3 implementation that is developed and
  289. maintained by a consortium of academic, research, and industry partners. Open
  290. MPI is therefore able to combine the expertise, technologies, and resources
  291. from all across the High Performance Computing community in order to build the
  292. best MPI library available. Open MPI offers advantages for system and
  293. software vendors, application developers and computer science researchers.")
  294. ;; See file://LICENSE
  295. (license license:bsd-2)))
  296. ;; TODO: javadoc files contain timestamps.
  297. (define-public java-openmpi
  298. (package/inherit openmpi
  299. (name "java-openmpi")
  300. (inputs
  301. `(("openmpi" ,openmpi)
  302. ,@(package-inputs openmpi)))
  303. (native-inputs
  304. `(("jdk" ,openjdk11 "jdk")
  305. ("zip" ,(@ (gnu packages compression) zip))
  306. ,@(package-native-inputs openmpi)))
  307. (outputs '("out"))
  308. (arguments
  309. `(#:modules ((guix build gnu-build-system)
  310. ((guix build ant-build-system) #:prefix ant:)
  311. (guix build utils))
  312. #:imported-modules ((guix build ant-build-system)
  313. (guix build syscalls)
  314. ,@%gnu-build-system-modules)
  315. ,@(substitute-keyword-arguments (package-arguments openmpi)
  316. ((#:configure-flags flags)
  317. `(cons "--enable-mpi-java" ,flags))
  318. ((#:make-flags flags ''())
  319. `(append '("-C" "ompi/mpi/java")
  320. ,flags))
  321. ((#:phases phases)
  322. `(modify-phases ,phases
  323. ;; We could provide the location of the JDK in the configure
  324. ;; flags, but since the configure flags are embedded in the
  325. ;; info binaries that would leave a reference to the JDK in
  326. ;; the "out" output. To avoid this we set JAVA_HOME.
  327. (add-after 'unpack 'set-JAVA_HOME
  328. (lambda* (#:key inputs #:allow-other-keys)
  329. (setenv "JAVA_HOME" (assoc-ref inputs "jdk"))
  330. #t))
  331. (add-after 'unpack 'link-with-existing-mpi-libraries
  332. (lambda* (#:key inputs #:allow-other-keys)
  333. (substitute* "ompi/mpi/java/c/Makefile.in"
  334. (("\\$\\(top_builddir\\)/ompi/lib@OMPI_LIBMPI_NAME@.la")
  335. (search-input-file inputs "/lib/libmpi.la")))))
  336. (add-after 'install 'strip-jar-timestamps
  337. (assoc-ref ant:%standard-phases 'strip-jar-timestamps)))))))
  338. (synopsis "Java bindings for MPI")))
  339. (define-public openmpi-thread-multiple
  340. (package/inherit openmpi
  341. (name "openmpi-thread-multiple")
  342. (arguments
  343. (substitute-keyword-arguments (package-arguments openmpi)
  344. ((#:configure-flags flags)
  345. `(cons "--enable-mpi-thread-multiple" ,flags))))
  346. (description " This version of Open@tie{}MPI has an implementation of
  347. @code{MPI_Init_thread} that provides @code{MPI_THREAD_MULTIPLE}. This won't
  348. work correctly with all transports (such as @code{openib}), and the
  349. performance is generally worse than the vanilla @code{openmpi} package, which
  350. only provides @code{MPI_THREAD_FUNNELED}.")))
  351. ;;; Build phase to be used for packages that execute MPI code.
  352. (define-public %openmpi-setup
  353. '(lambda _
  354. ;; By default, running the test suite would fail because 'ssh' could not
  355. ;; be found in $PATH. Define this variable to placate Open MPI without
  356. ;; adding a dependency on OpenSSH (the agent isn't used anyway.)
  357. (setenv "OMPI_MCA_plm_rsh_agent" (which "false"))
  358. ;; Allow oversubscription in case there are less physical cores available
  359. ;; in the build environment than the package wants while testing.
  360. (setenv "OMPI_MCA_rmaps_base_mapping_policy" "core:OVERSUBSCRIBE")
  361. ;; UCX sometimes outputs uninteresting warnings such as:
  362. ;;
  363. ;; mpool.c:38 UCX WARN object 0x7ffff44fffc0 was not returned to mpool ucp_am_bufs
  364. ;;
  365. ;; These in turn leads to failures of test suites that capture and
  366. ;; compare stdout, such as that of 'hdf5-parallel-openmpi'. Thus, tell
  367. ;; UCX to not emit those warnings.
  368. (setenv "UCX_LOG_LEVEL" "error")
  369. #t))
  370. (define-public python-mpi4py
  371. (package
  372. (name "python-mpi4py")
  373. (version "3.0.3")
  374. (source
  375. (origin
  376. (method url-fetch)
  377. (uri (pypi-uri "mpi4py" version))
  378. (sha256
  379. (base32 "07ssbhssv27rrjx1c5vd3vsr31vay5d8xcf4zh9yblcyidn72b81"))))
  380. (build-system python-build-system)
  381. (arguments
  382. `(#:phases
  383. (modify-phases %standard-phases
  384. (add-after 'build 'mpi-setup
  385. ,%openmpi-setup)
  386. (add-before 'check 'pre-check
  387. (lambda _
  388. ;; Skip BaseTestSpawn class (causes error 'ompi_dpm_dyn_init()
  389. ;; failed --> Returned "Unreachable"' in chroot environment).
  390. (substitute* "test/test_spawn.py"
  391. (("unittest.skipMPI\\('openmpi\\(<3.0.0\\)'\\)")
  392. "unittest.skipMPI('openmpi')"))
  393. #t)))))
  394. (inputs
  395. `(("openmpi" ,openmpi)))
  396. (home-page "https://bitbucket.org/mpi4py/mpi4py/")
  397. (synopsis "Python bindings for the Message Passing Interface standard")
  398. (description "MPI for Python (mpi4py) provides bindings of the Message
  399. Passing Interface (MPI) standard for the Python programming language, allowing
  400. any Python program to exploit multiple processors.
  401. mpi4py is constructed on top of the MPI-1/MPI-2 specification and provides an
  402. object oriented interface which closely follows MPI-2 C++ bindings. It
  403. supports point-to-point and collective communications of any picklable Python
  404. object as well as optimized communications of Python objects (such as NumPy
  405. arrays) that expose a buffer interface.")
  406. (license license:bsd-3)))
  407. (define-public mpich
  408. (package
  409. (name "mpich")
  410. (version "3.3.2")
  411. (source (origin
  412. (method url-fetch)
  413. (uri (string-append "http://www.mpich.org/static/downloads/"
  414. version "/mpich-" version ".tar.gz"))
  415. (sha256
  416. (base32
  417. "1farz5zfx4cd0c3a0wb9pgfypzw0xxql1j1294z1sxslga1ziyjb"))))
  418. (build-system gnu-build-system)
  419. (inputs
  420. `(("zlib" ,zlib)
  421. ("hwloc" ,hwloc-2 "lib")
  422. ("slurm" ,slurm)
  423. ,@(if (and (not (%current-target-system))
  424. (member (%current-system) (package-supported-systems ucx)))
  425. `(("ucx" ,ucx))
  426. '())))
  427. (native-inputs
  428. `(("perl" ,perl)
  429. ("which" ,which)
  430. ("gfortran" ,gfortran)))
  431. (outputs '("out" "debug"))
  432. (arguments
  433. `(#:configure-flags
  434. (list "--disable-silent-rules" ;let's see what's happening
  435. "--enable-debuginfo"
  436. ;; Default to "ch4", as will be the case in 3.4. It also works
  437. ;; around issues when running test suites of packages that use
  438. ;; MPICH: <https://issues.guix.gnu.org/39588#15>.
  439. "--with-device=ch4:ucx" ; --with-device=ch4:ofi segfaults in tests
  440. (string-append "--with-hwloc-prefix="
  441. (assoc-ref %build-inputs "hwloc"))
  442. ,@(if (assoc "ucx" (package-inputs this-package))
  443. `((string-append "--with-ucx="
  444. (assoc-ref %build-inputs "ucx")))
  445. '()))
  446. #:phases (modify-phases %standard-phases
  447. (add-after 'unpack 'patch-sources
  448. (lambda _
  449. (substitute* "./maint/gen_subcfg_m4"
  450. (("/usr/bin/env") (which "env")))
  451. (substitute* "src/glue/romio/all_romio_symbols"
  452. (("/usr/bin/env") (which "env")))
  453. (substitute* (find-files "." "buildiface")
  454. (("/usr/bin/env") (which "env")))
  455. (substitute* "maint/extracterrmsgs"
  456. (("/usr/bin/env") (which "env")))
  457. (substitute* (find-files "." "f77tof90")
  458. (("/usr/bin/env") (which "env")))
  459. (substitute* (find-files "." "\\.sh$")
  460. (("/bin/sh") (which "sh")))
  461. #t))
  462. (add-before 'configure 'fix-makefile
  463. (lambda _
  464. ;; Remove "@hwloclib@" from 'pmpi_convenience_libs'.
  465. ;; This fixes "No rule to make target '-lhwloc', needed
  466. ;; by 'lib/libmpi.la'".
  467. (substitute* "Makefile.in"
  468. (("^pmpi_convenience_libs = (.*) @hwloclib@ (.*)$" _
  469. before after)
  470. (string-append "pmpi_convenience_libs = "
  471. before " " after)))
  472. #t)))))
  473. (home-page "https://www.mpich.org/")
  474. (synopsis "Implementation of the Message Passing Interface (MPI)")
  475. (description
  476. "MPICH is a high-performance and portable implementation of the Message
  477. Passing Interface (MPI) standard (MPI-1, MPI-2 and MPI-3). MPICH provides an
  478. MPI implementation that efficiently supports different computation and
  479. communication platforms including commodity clusters, high-speed networks (10
  480. Gigabit Ethernet, InfiniBand, Myrinet, Quadrics), and proprietary high-end
  481. computing systems (Blue Gene, Cray). It enables research in MPI through a
  482. modular framework for other derived implementations.")
  483. (license license:bsd-2)))