lout.scm 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages lout)
  20. #:use-module (guix licenses)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (gnu packages ghostscript))
  25. (define-public lout
  26. (package
  27. (name "lout")
  28. (version "3.40")
  29. (source (origin
  30. (method url-fetch)
  31. (uri (string-append "mirror://savannah/lout/lout-"
  32. version ".tar.gz"))
  33. (sha256
  34. (base32
  35. "1gb8vb1wl7ikn269dd1c7ihqhkyrwk19jwx5kd0rdvbk6g7g25ix"))))
  36. (build-system gnu-build-system) ; actually, just a makefile
  37. (outputs '("out" "doc"))
  38. (native-inputs
  39. `(("ghostscript" ,ghostscript)))
  40. (arguments
  41. `(#:modules ((guix build utils)
  42. (guix build gnu-build-system)
  43. (srfi srfi-1)) ; we need SRFI-1
  44. #:tests? #f ; no "check" target
  45. #:phases
  46. (modify-phases %standard-phases
  47. ;; This package is a bit tricky, because it doesn't follow the GNU
  48. ;; Build System rules. Instead, it has a makefile that has to be
  49. ;; patched to set the prefix, etc., and it has no makefile rules to
  50. ;; build its documentation.
  51. (replace 'configure
  52. (lambda* (#:key outputs #:allow-other-keys)
  53. (let ((out (assoc-ref outputs "out"))
  54. (doc (assoc-ref outputs "doc")))
  55. (substitute* "makefile"
  56. (("^PREFIX[[:blank:]]*=.*$")
  57. (string-append "PREFIX = " out "\n"))
  58. (("^LOUTLIBDIR[[:blank:]]*=.*$")
  59. (string-append "LOUTLIBDIR = " out "/lib/lout\n"))
  60. (("^LOUTDOCDIR[[:blank:]]*=.*$")
  61. (string-append "LOUTDOCDIR = " doc "/share/doc/lout\n"))
  62. (("^MANDIR[[:blank:]]*=.*$")
  63. (string-append "MANDIR = " out "/man\n")))
  64. (mkdir out)
  65. (mkdir (string-append out "/bin"))
  66. (mkdir (string-append out "/lib"))
  67. (mkdir (string-append out "/man"))
  68. (mkdir-p (string-append doc "/share/doc/lout"))
  69. #t)))
  70. (add-after 'install 'install-man-pages
  71. (lambda* (#:key outputs #:allow-other-keys)
  72. (invoke "make" "installman")
  73. #t))
  74. (add-after 'install 'install-doc
  75. (lambda* (#:key outputs #:allow-other-keys)
  76. (let ((out (assoc-ref outputs "doc")))
  77. (setenv "PATH"
  78. (string-append (assoc-ref outputs "out")
  79. "/bin:" (getenv "PATH")))
  80. (with-directory-excursion "doc"
  81. (every (lambda (doc)
  82. (format #t "doc: building `~a'...~%" doc)
  83. (with-directory-excursion doc
  84. (let ((file (string-append out "/share/doc/lout/"
  85. doc ".ps")))
  86. (unless (file-exists? "outfile.ps")
  87. (invoke "lout" "-r4" "-o"
  88. "outfile.ps" "all"))
  89. (copy-file "outfile.ps" file)
  90. (invoke "ps2pdf"
  91. "-dPDFSETTINGS=/prepress"
  92. "-sPAPERSIZE=a4"
  93. file
  94. (string-append out "/share/doc/lout/"
  95. doc ".pdf")))))
  96. '("design" "expert" "slides" "user")))
  97. #t))))))
  98. (synopsis "Document layout system")
  99. (description
  100. "The Lout document formatting system reads a high-level description of
  101. a document similar in style to LaTeX and produces a PostScript or plain text
  102. output file.
  103. Lout offers an unprecedented range of advanced features, including optimal
  104. paragraph and page breaking, automatic hyphenation, PostScript EPS file
  105. inclusion and generation, equation formatting, tables, diagrams, rotation and
  106. scaling, sorted indexes, bibliographic databases, running headers and
  107. odd-even pages, automatic cross referencing, multilingual documents including
  108. hyphenation (most European languages are supported), formatting of computer
  109. programs, and much more, all ready to use. Furthermore, Lout is easily
  110. extended with definitions which are very much easier to write than troff of
  111. TeX macros because Lout is a high-level, purely functional language, the
  112. outcome of an eight-year research project that went back to the
  113. beginning.")
  114. (license gpl3+)
  115. (home-page "https://savannah.nongnu.org/projects/lout/")))