libunwind.scm 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages libunwind)
  21. #:use-module (guix packages)
  22. #:use-module (gnu packages)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (guix licenses))
  26. (define-public libunwind
  27. (package
  28. (name "libunwind")
  29. (version "1.5.0")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append "mirror://savannah/libunwind/libunwind-"
  33. version ".tar.gz"))
  34. (sha256
  35. (base32
  36. "05qhzcg1xag3l5m3c805np6k342gc0f3g087b7g16jidv59pccwh"))))
  37. (build-system gnu-build-system)
  38. (arguments
  39. ;; FIXME: As of glibc 2.25, we get 1 out of 34 test failures (2 are
  40. ;; expected to fail).
  41. ;; Report them upstream.
  42. '(#:tests? #f))
  43. (home-page "https://www.nongnu.org/libunwind")
  44. (synopsis "Determining the call chain of a program")
  45. (description
  46. "The primary goal of this project is to define a portable and efficient C
  47. programming interface (API) to determine the call-chain of a program. The API
  48. additionally provides the means to manipulate the preserved (callee-saved)
  49. state of each call-frame and to resume execution at any point in the
  50. call-chain (non-local goto). The API supports both local (same-process) and
  51. remote (across-process) operation. As such, the API is useful in a number of
  52. applications.")
  53. (license x11)))