key-mon.scm 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages key-mon)
  19. #:use-module (guix licenses)
  20. #:use-module (guix packages)
  21. #:use-module (guix download)
  22. #:use-module (gnu packages)
  23. #:use-module (gnu packages python)
  24. #:use-module (gnu packages python-xyz)
  25. #:use-module (gnu packages gtk)
  26. #:use-module (gnu packages gnome)
  27. #:use-module (guix build-system python))
  28. (define-public key-mon
  29. (package
  30. (name "key-mon")
  31. (version "1.17")
  32. (source (origin
  33. (method url-fetch)
  34. (uri (string-append
  35. "http://key-mon.googlecode.com/files/key-mon-"
  36. version ".tar.gz"))
  37. (sha256
  38. (base32
  39. "1liz0dxcqmchbnl1xhlxkqm3gh76wz9jxdxn9pa7dy77fnrjkl5q"))))
  40. (build-system python-build-system)
  41. (arguments
  42. `(#:python ,python-2 ;uses the Python 2 'print' syntax
  43. #:tests? #f)) ;no tests
  44. (inputs
  45. `(("python2-xlib" ,python2-xlib)
  46. ("python2-pygtk" ,python2-pygtk)
  47. ("python2-rsvg" ,python2-rsvg)))
  48. (home-page "https://code.google.com/p/key-mon")
  49. (synopsis "Show keyboard and mouse status")
  50. (description
  51. "The key-mon utility displays the current keyboard and mouse status.
  52. This is useful for teaching and screencasts.")
  53. (license asl2.0)))