kde-utils.scm 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
  3. ;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages kde-utils)
  21. #:use-module (guix build-system qt)
  22. #:use-module (guix download)
  23. #:use-module ((guix licenses) #:prefix license:)
  24. #:use-module (guix packages)
  25. #:use-module (gnu packages)
  26. #:use-module (gnu packages bash)
  27. #:use-module (gnu packages backup)
  28. #:use-module (gnu packages cmake)
  29. #:use-module (gnu packages compression)
  30. #:use-module (gnu packages gnome)
  31. #:use-module (gnu packages imagemagick)
  32. #:use-module (gnu packages pkg-config)
  33. #:use-module (gnu packages kde)
  34. #:use-module (gnu packages kde-frameworks)
  35. #:use-module (gnu packages kde-plasma)
  36. #:use-module (gnu packages qt)
  37. #:use-module (gnu packages samba)
  38. #:use-module (gnu packages xorg))
  39. (define-public ark
  40. (package
  41. (name "ark")
  42. (version "21.08.1")
  43. (source (origin
  44. (method url-fetch)
  45. (uri (string-append "mirror://kde/stable/release-service/" version
  46. "/src/ark-" version ".tar.xz"))
  47. (sha256
  48. (base32
  49. "1ss33qizhg325k4hhf8339xg52iv4s32qjm048zhi2jaz54pdnv0"))
  50. ;; The libarchive package in Guix does not support
  51. ;; xar; disable related tests.
  52. (patches (search-patches "ark-skip-xar-test.patch"))))
  53. (build-system qt-build-system)
  54. (arguments
  55. `(#:phases
  56. (modify-phases %standard-phases
  57. (add-before 'check 'start-xserver
  58. ;; adddialogtest requires DISPLAY.
  59. (lambda* (#:key inputs #:allow-other-keys)
  60. (let ((xorg-server (assoc-ref inputs "xorg-server")))
  61. (setenv "HOME" (getcwd))
  62. (system (format #f "~a/bin/Xvfb :1 &" xorg-server))
  63. (setenv "DISPLAY" ":1"))))
  64. (add-after 'install 'wrap-executable
  65. (lambda* (#:key inputs outputs #:allow-other-keys)
  66. (let* ((out (assoc-ref outputs "out"))
  67. (lrzip (assoc-ref inputs "lrzip"))
  68. (lzop (assoc-ref inputs "lzop"))
  69. (p7zip (assoc-ref inputs "p7zip"))
  70. (unzip (assoc-ref inputs "unzip"))
  71. (zip (assoc-ref inputs "zip"))
  72. (zstd (assoc-ref inputs "zstd")))
  73. (wrap-program (string-append out "/bin/ark")
  74. `("PATH" suffix
  75. ,(map (lambda (p)
  76. (string-append p "/bin"))
  77. (list lrzip lzop p7zip unzip zip zstd))))))))))
  78. (native-inputs
  79. `(("extra-cmake-modules" ,extra-cmake-modules)
  80. ("pkg-config" ,pkg-config)
  81. ("kdoctools" ,kdoctools)
  82. ("xorg-server" ,xorg-server)))
  83. (inputs
  84. `(("bash-minimal" ,bash-minimal) ; wrap-program
  85. ("breeze-icons" ,breeze-icons)
  86. ("karchive" ,karchive)
  87. ("kconfig" ,kconfig)
  88. ("kcrash" ,kcrash)
  89. ("kdbusaddons" ,kdbusaddons)
  90. ("khtml" ,khtml)
  91. ("ki18n" ,ki18n)
  92. ("kio" ,kio)
  93. ("kitemmodels" ,kitemmodels)
  94. ("kparts" ,kparts)
  95. ("kpty" ,kpty)
  96. ("kservice" ,kservice)
  97. ("kwidgetsaddons" ,kwidgetsaddons)
  98. ("libarchive" ,libarchive)
  99. ("libzip" ,libzip)
  100. ("qtbase" ,qtbase-5)
  101. ("zlib" ,zlib)
  102. ;; Command line tools used by Ark.
  103. ("lrzip" ,lrzip)
  104. ("lzop" ,lzop)
  105. ("p7zip" ,p7zip)
  106. ("unzip" ,unzip)
  107. ("zip" ,zip)
  108. ("zstd" ,zstd)))
  109. (home-page "https://apps.kde.org/ark/")
  110. (synopsis "Graphical archiving tool")
  111. (description "Ark is a graphical file compression/decompression utility
  112. with support for multiple formats, including tar, gzip, bzip2, rar and zip, as
  113. well as CD-ROM images.")
  114. (license license:gpl2+)))
  115. (define-public kate
  116. (package
  117. (name "kate")
  118. (version "21.08.1")
  119. (source
  120. (origin
  121. (method url-fetch)
  122. (uri (string-append "mirror://kde/stable/release-service/" version
  123. "/src/kate-" version ".tar.xz"))
  124. (sha256
  125. (base32 "0k9kf8x5gbj5vbnr6lfhizi8122p76xixw480a3zsqi57i4bxk0z"))))
  126. (build-system qt-build-system)
  127. (native-inputs
  128. `(("extra-cmake-modules" ,extra-cmake-modules)
  129. ("kdoctools" ,kdoctools)))
  130. (inputs
  131. `(("kactivities" ,kactivities)
  132. ("kconfig" ,kconfig)
  133. ("kcrash" ,kcrash)
  134. ("kdbusaddons" ,kdbusaddons)
  135. ("kguiaddons" ,kguiaddons)
  136. ("ki18n" ,ki18n)
  137. ("kiconthemes" ,kiconthemes)
  138. ("kitemmodels" ,kitemmodels)
  139. ("threadweaver" ,threadweaver)
  140. ("knewstuff" ,knewstuff)
  141. ("kio" ,kio)
  142. ("kjobwidgets" ,kjobwidgets)
  143. ("kparts" ,kparts)
  144. ("ksyntaxhighlighting" ,ksyntaxhighlighting)
  145. ("ktexteditor" ,ktexteditor)
  146. ("kwallet" ,kwallet)
  147. ("plasma-framework" ,plasma-framework)
  148. ("kwindowsystem" ,kwindowsystem)
  149. ("kxmlgui" ,kxmlgui)
  150. ("breeze-icons" ,breeze-icons) ;; default icon set
  151. ("qtbase" ,qtbase-5)
  152. ("qtscript" ,qtscript)))
  153. (arguments
  154. `(#:phases
  155. (modify-phases %standard-phases
  156. (add-before 'check 'check-setup
  157. (lambda _
  158. ;; make Qt render "offscreen", required for tests
  159. (setenv "QT_QPA_PLATFORM" "offscreen")
  160. (setenv "XDG_CACHE_HOME" "/tmp/xdg-cache")
  161. #t))
  162. (replace 'check
  163. (lambda* (#:key tests? #:allow-other-keys)
  164. (when tests? ;; Test looks for /usr/bin. Other ones hang.
  165. (invoke "ctest" "-E" "(plugin-externaltools_test|\
  166. kateapp-session_manager_test|\
  167. kateapp-sessions_action_test)"))
  168. #t)))))
  169. (home-page "https://kate-editor.org/")
  170. (synopsis "Multi-document, multi-view text editor")
  171. (description "Kate is a powerful text editor that can open multiple files
  172. simultaneously.
  173. With a built-in terminal, syntax highlighting, and tabbed sidebar, it performs
  174. as a lightweight but capable development environment. Kate's many tools,
  175. plugins, and scripts make it highly customizable.
  176. Kate's features include:
  177. @itemize
  178. @item Multiple saved sessions, each with numerous files
  179. @item Scriptable syntax highlighting, indentation, and code-folding
  180. @item Configurable templates and text snippets
  181. @item Symbol viewers for C, C++, and Python
  182. @item XML completion and validation
  183. @end itemize")
  184. (license ;; GPL for programs, LGPL for libraries
  185. (list license:gpl2+ license:lgpl2.0))))
  186. (define-public kmag
  187. (package
  188. (name "kmag")
  189. (version "21.08.1")
  190. (source
  191. (origin
  192. (method url-fetch)
  193. (uri (string-append "mirror://kde/stable/release-service/" version
  194. "/src/kmag-" version ".tar.xz"))
  195. (sha256
  196. (base32 "1hdjcya1jv6adz0d9hp1sq7y8f6fvzpw30fchmjkdm9y2kf8il6c"))))
  197. (build-system qt-build-system)
  198. (native-inputs
  199. `(("extra-cmake-modules" ,extra-cmake-modules)
  200. ("kdoctools" ,kdoctools)))
  201. (inputs
  202. `(("ki18n" ,ki18n)
  203. ("kio" ,kio)
  204. ("kxmlgui" ,kxmlgui)
  205. ("breeze-icons" ,breeze-icons) ;; default icon set
  206. ;; TODO: QAccessibilityClient - libqaccessibilityclien
  207. ("qtbase" ,qtbase-5)))
  208. (home-page "https://apps.kde.org/kmag/")
  209. (synopsis "Screen magnifier tool")
  210. (description "You can use KMagnifier to magnify a part of the screen just
  211. as you would use a lens to magnify a newspaper fine-print or a photograph.
  212. This application is useful for a variety of people: from researchers to
  213. artists to web-designers to people with low vision.")
  214. (license ;; GPL for programs, FDL for documentation
  215. (list license:gpl2+ license:fdl1.2+))))
  216. (define-public kmousetool
  217. (package
  218. (name "kmousetool")
  219. (version "21.08.1")
  220. (source
  221. (origin
  222. (method url-fetch)
  223. (uri (string-append "mirror://kde/stable/release-service/" version
  224. "/src/kmousetool-" version ".tar.xz"))
  225. (sha256
  226. (base32 "04a5zrxg48svrvdf8gf3qc7cj7cayzhw0q4l1v8nzs2ykc330xq1"))))
  227. (build-system qt-build-system)
  228. (native-inputs
  229. `(("extra-cmake-modules" ,extra-cmake-modules)
  230. ("kdoctools" ,kdoctools)))
  231. (inputs
  232. `(("kauth" ,kauth)
  233. ("kcoreaddons" ,kcoreaddons)
  234. ("kconfigwidgets" ,kconfigwidgets)
  235. ("kdbusaddons" ,kdbusaddons)
  236. ("ki18n" ,ki18n)
  237. ("kiconthemes" ,kiconthemes)
  238. ("knotifications" ,knotifications)
  239. ("kxmlgui" ,kxmlgui)
  240. ("kwindowsystem" ,kwindowsystem)
  241. ("libxtst" ,libxtst)
  242. ("libxt" ,libxt)
  243. ("phonon" ,phonon)
  244. ("breeze-icons" ,breeze-icons) ;; default icon set
  245. ("qtbase" ,qtbase-5)))
  246. (home-page "https://apps.kde.org/kmousetool/")
  247. (synopsis "Automatic mouse click and mouse manipulation tool for the
  248. disabled")
  249. (description "KMouseTool clicks the mouse whenever the mouse cursor pauses
  250. briefly. It was designed to help those with repetitive strain injuries, for
  251. whom pressing buttons hurts.")
  252. (license ;; GPL for programs, FDL for documentation
  253. (list license:gpl2+ license:fdl1.2+))))
  254. (define-public kmouth
  255. (package
  256. (name "kmouth")
  257. (version "21.08.1")
  258. (source
  259. (origin
  260. (method url-fetch)
  261. (uri (string-append "mirror://kde/stable/release-service/" version
  262. "/src/kmouth-" version ".tar.xz"))
  263. (sha256
  264. (base32 "1rmqppmjjcrc7xp63csdgp440f003nia6hcnixxlya8pwn90bpwr"))))
  265. (build-system qt-build-system)
  266. (native-inputs
  267. `(("extra-cmake-modules" ,extra-cmake-modules)
  268. ("kdoctools" ,kdoctools)))
  269. (inputs
  270. `(("kcompletion" ,kcompletion)
  271. ("kconfig" ,kconfig)
  272. ("kconfigwidgets" ,kconfigwidgets)
  273. ("kcoreaddons" ,kcoreaddons)
  274. ("kcrash" ,kcrash)
  275. ("ki18n" ,ki18n)
  276. ("kio" ,kio)
  277. ("kwidgetsaddons" ,kwidgetsaddons)
  278. ("kxmlgui" ,kxmlgui)
  279. ("breeze-icons" ,breeze-icons) ;; default icon set
  280. ("qtbase" ,qtbase-5)
  281. ("qtspeech" ,qtspeech)))
  282. (home-page "https://apps.kde.org/kmouth/")
  283. (synopsis "Type-and-say frontend for speech synthesizers")
  284. (description "KMouth is a program which enables persons that cannot speak
  285. to let their computer speak, e.g. mutal people or people who have lost their
  286. voice. It has a text input field and speaks the sentences that you enter. It
  287. also has support for user defined phrasebooks.
  288. It includes a history of spoken sentences from which the user can select
  289. sentences to be re-spoken.")
  290. (license ;; GPL for programs, FDL for documentation
  291. (list license:gpl2+ license:fdl1.2+))))
  292. (define-public kronometer
  293. (package
  294. (name "kronometer")
  295. (version "2.2.3")
  296. (source
  297. (origin
  298. (method url-fetch)
  299. (uri (string-append "mirror://kde/stable/kronometer/" version
  300. "/src/kronometer-" version ".tar.xz"))
  301. (sha256
  302. (base32 "05hs8729a3aqjpwmn2xdf2sriacrll4sj4ax3lm4s1ravj09n9bm"))))
  303. (build-system qt-build-system)
  304. (native-inputs
  305. `(("extra-cmake-modules" ,extra-cmake-modules)
  306. ("kdoctools" ,kdoctools)))
  307. (inputs
  308. `(("kauth" ,kauth)
  309. ("kconfig" ,kconfig)
  310. ("kconfigwidgets" ,kconfigwidgets)
  311. ("kcoreaddons" ,kcoreaddons)
  312. ("kcrash" ,kcrash)
  313. ("ki18n" ,ki18n)
  314. ("kwidgetsaddons" ,kwidgetsaddons)
  315. ("kxmlgui" ,kxmlgui)
  316. ("breeze-icons" ,breeze-icons) ;; default icon set
  317. ("qtbase" ,qtbase-5)))
  318. (home-page "https://apps.kde.org/kronometer/")
  319. (synopsis "Simple stopwatch application")
  320. (description "Kronometer is a stopwatch application. It features the
  321. basic stopwatch actions (pause, resume, reset, laps), as well as the ability
  322. to save the times and resume them later.")
  323. (license ;; GPL for programs, LGPL for libraries, FDL for documentation
  324. license:gpl2+)))
  325. (define-public krusader
  326. (package
  327. (name "krusader")
  328. (version "2.7.2")
  329. (source
  330. (origin
  331. (method url-fetch)
  332. (uri (string-append "mirror://kde/stable/krusader/" version
  333. "/krusader-" version ".tar.xz"))
  334. (sha256
  335. (base32 "02b1jz5a7cjr13v6c7fczrhs1xmg1krnva5fxk8x2bf4nd1rm8s1"))))
  336. (build-system qt-build-system)
  337. (native-inputs
  338. `(("extra-cmake-modules" ,extra-cmake-modules)
  339. ("kdoctools" ,kdoctools)))
  340. (inputs
  341. `(("karchive" ,karchive)
  342. ("kbookmarks" ,kbookmarks)
  343. ("kcodecs" ,kcodecs)
  344. ("kcompletion" ,kcompletion)
  345. ("kconfig" ,kconfig)
  346. ("kcoreaddons" ,kcoreaddons)
  347. ("kguiaddons" ,kguiaddons)
  348. ("ki18n" ,ki18n)
  349. ("kiconthemes" ,kiconthemes)
  350. ("kio" ,kio)
  351. ("kitemviews" ,kitemviews)
  352. ("knotifications" ,knotifications)
  353. ("kparts" ,kparts)
  354. ("ktextwidgets" ,ktextwidgets)
  355. ("kwallet" ,kwallet)
  356. ("kwidgetsaddons" ,kwidgetsaddons)
  357. ("kwindowsystem" ,kwindowsystem)
  358. ("kxmlgui" ,kxmlgui)
  359. ("breeze-icons" ,breeze-icons) ;; default icon set
  360. ("qtbase" ,qtbase-5)
  361. ("solid" ,solid)
  362. ("zlib" ,zlib)))
  363. (home-page "https://krusader.org/")
  364. (synopsis "Twin-panel (commander-style) file manager")
  365. (description "Krusader is a simple, easy, yet powerful,
  366. twin-panel (commander-style) file manager, similar to Midnight Commander or
  367. Total Commander
  368. It provides all the file management features you could possibly want. Plus:
  369. extensive archive handling, mounted file system support, FTP, advanced search
  370. module, an internal viewer/editor, directory synchronisation, file content
  371. comparisons, powerful batch renaming and much much more. It supports a wide
  372. variety of archive formats and can handle other KIO slaves such as smb or
  373. fish.
  374. Almost completely customizable, Krusader is very user friendly, fast and looks
  375. great on your desktop.")
  376. (license license:gpl2+)))
  377. (define-public kxstitch
  378. (package
  379. (name "kxstitch")
  380. (version "2.2.0")
  381. (source
  382. (origin
  383. (method url-fetch)
  384. (uri (string-append "mirror://kde/stable/kxstitch/" version
  385. "/kxstitch-" version ".tar.xz"))
  386. (sha256
  387. (base32 "1q6blvcqz6hxdfrkdi0fplmz7rmk3im56kpp68r0yrivhx3hn8sc"))))
  388. (build-system qt-build-system)
  389. (native-inputs
  390. `(("extra-cmake-modules" ,extra-cmake-modules)
  391. ("kdoctools" ,kdoctools)
  392. ("pkg-config" ,pkg-config)))
  393. (inputs
  394. `(("ktexteditor" ,ktexteditor)
  395. ("imagemagick" ,imagemagick)
  396. ("qtbase" ,qtbase-5)
  397. ("qtx11extras" ,qtx11extras)))
  398. (home-page "https://apps.kde.org/kxstitch/")
  399. (synopsis "Create and print cross stitch patterns")
  400. (description
  401. "KXStitch allows creating and printing cross stitch patterns, which can
  402. either be created or generated from a image.")
  403. (license license:gpl2+)))
  404. (define-public okteta
  405. (package
  406. (name "okteta")
  407. (version "0.26.6")
  408. (source
  409. (origin
  410. (method url-fetch)
  411. (uri (string-append "mirror://kde/stable/okteta/" version
  412. "/src/okteta-" version ".tar.xz"))
  413. (sha256
  414. (base32 "0k0lw2z5iii6z7rg7ijjm8kc9248n1i92p2v3bglcgjhamdwssf5"))))
  415. (build-system qt-build-system)
  416. (native-inputs
  417. `(("extra-cmake-modules" ,extra-cmake-modules)
  418. ("kdoctools" ,kdoctools)
  419. ("qttools" ,qttools)
  420. ("shared-mime-info" ,shared-mime-info)))
  421. (inputs
  422. `(("kbookmarks" ,kbookmarks)
  423. ("kcmutils" ,kcmutils)
  424. ("kcodecs" ,kcodecs)
  425. ("kcrash" ,kcrash)
  426. ("kcompletion" ,kcompletion)
  427. ("kconfigwidgets" ,kconfigwidgets)
  428. ("kdbusaddons" ,kdbusaddons)
  429. ("ki18n" ,ki18n)
  430. ("kiconthemes" ,kiconthemes)
  431. ("kio" ,kio)
  432. ("knewstuff" ,knewstuff)
  433. ("kparts" ,kparts)
  434. ("kservice" ,kservice)
  435. ("kwidgetsaddons" ,kwidgetsaddons)
  436. ("kxmlgui" ,kxmlgui)
  437. ("breeze-icons" ,breeze-icons) ;; default icon set
  438. ("qca" ,qca)
  439. ("qtbase" ,qtbase-5)
  440. ("qtdeclarative" ,qtdeclarative)
  441. ("qtscript" ,qtscript)))
  442. (arguments
  443. `(#:phases
  444. (modify-phases %standard-phases
  445. (add-before 'check 'check-setup
  446. (lambda _
  447. ;; make Qt render "offscreen", required for tests
  448. (setenv "QT_QPA_PLATFORM" "offscreen")
  449. (setenv "HOME" "/tmp/dummy-home")
  450. #t)))))
  451. (home-page "https://apps.kde.org/okteta/")
  452. (synopsis "Hexadecimal editor for binary files")
  453. (description "Okteta is a simple editor for the raw data of files. This
  454. type of program is also called hex editor or binary editor.
  455. The data is displayed in the traditional view with two columns: one with the
  456. numeric values and one with the assigned characters. Editing can be done both
  457. in the value column and the character column. Besides the usual editing
  458. capabilities Okteta also brings a small set of tools, like a table listing
  459. decodings into common simple data types, a table listing all possible bytes
  460. with its character and value equivalents, a info view with a statistic and a
  461. filter tool. All modifications to the data loaded can be endlessly undone or
  462. redone.")
  463. (license ;; GPL for programs, LGPL for libraries, FDL for documentation
  464. (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
  465. (define-public rsibreak
  466. (package
  467. (name "rsibreak")
  468. (version "0.12.14")
  469. (source
  470. (origin
  471. (method url-fetch)
  472. (uri (string-append "mirror://kde//stable/rsibreak/0.12/"
  473. "rsibreak-" version ".tar.xz"))
  474. (sha256
  475. (base32 "0yjv5awngi2hk6xzlwzmj92i6qppnfc0inqdp16rd8gzfpw7xqqw"))))
  476. (build-system qt-build-system)
  477. (native-inputs
  478. `(("extra-cmake-modules" ,extra-cmake-modules)
  479. ("kdoctools" ,kdoctools)))
  480. (inputs
  481. `(("kauth" ,kauth)
  482. ("kconfig" ,kconfig)
  483. ("kconfigwidgets" ,kconfigwidgets)
  484. ("kcoreaddons" ,kcoreaddons)
  485. ("kcrash" ,kcrash)
  486. ("kdbusaddons" ,kdbusaddons)
  487. ("ki18n" ,ki18n)
  488. ("kiconthemes" ,kiconthemes)
  489. ("kidletime" ,kidletime)
  490. ("knotifications" ,knotifications)
  491. ("knotifyconfig" ,knotifyconfig)
  492. ("ktextwidgets" ,ktextwidgets)
  493. ("kwindowsystem" ,kwindowsystem)
  494. ("kxmlgui" ,kxmlgui)
  495. ("breeze-icons" ,breeze-icons) ;; default icon set
  496. ("qtbase" ,qtbase-5)))
  497. (home-page "https://apps.kde.org/rsibreak/")
  498. (synopsis "Assists in the Recovery and Prevention of Repetitive Strain
  499. Injury")
  500. (description "Repetitive Strain Injury is an illness which can occur as a
  501. result of working with a mouse and keyboard. This utility can be used to
  502. remind you to take a break now and then.")
  503. (license ;; GPL for programs, FDL for documentation
  504. (list license:gpl2+ license:fdl1.2+))))
  505. (define-public smb4k
  506. (package
  507. (name "smb4k")
  508. (version "3.1.1")
  509. (source
  510. (origin
  511. (method url-fetch)
  512. (uri (string-append "https://sourceforge.net/projects/smb4k/files/"
  513. version "/smb4k-" version ".tar.xz/download"))
  514. (file-name (string-append name "-" version ".tar.xz"))
  515. (sha256
  516. (base32 "189h5znan2kfqflik308ghqc2z55s5z8kwpq8gjz2y0lwyqdiw0b"))))
  517. (build-system qt-build-system)
  518. (native-inputs
  519. `(("extra-cmake-modules" ,extra-cmake-modules)
  520. ("kdoctools" ,kdoctools)))
  521. (inputs
  522. `(("kauth" ,kauth)
  523. ("kconfig" ,kconfig)
  524. ("kconfigwidgets" ,kconfigwidgets)
  525. ("kcompletion" ,kcompletion)
  526. ("kcoreaddons" ,kcoreaddons)
  527. ("kcrash" ,kcrash)
  528. ("kdnssd" ,kdnssd)
  529. ("kdbusaddons" ,kdbusaddons)
  530. ("ki18n" ,ki18n)
  531. ("kiconthemes" ,kiconthemes)
  532. ("kio" ,kio)
  533. ("kjobwidgets" ,kjobwidgets)
  534. ("knotifications" ,knotifications)
  535. ("knotifyconfig" ,knotifyconfig)
  536. ("ktextwidgets" ,ktextwidgets)
  537. ("kwallet" ,kwallet)
  538. ("kwidgetsaddons" ,kwidgetsaddons)
  539. ("kwindowsystem" ,kwindowsystem)
  540. ("kxmlgui" ,kxmlgui)
  541. ("libsmbclient" ,samba)
  542. ("breeze-icons" ,breeze-icons) ;; default icon set
  543. ("plasma-framework" ,plasma-framework)
  544. ("qtbase" ,qtbase-5)
  545. ("qtdeclarative" ,qtdeclarative)
  546. ("solid" ,solid)))
  547. (home-page "https://apps.kde.org/smb4k/")
  548. (synopsis "Samba (SMB) share advanced browser")
  549. (description "Smb4K is an network neighborhood browser for the KDE
  550. Software Compilation and a frontend to the programs of the Samba software
  551. suite.
  552. Features:
  553. @itemize
  554. @item Scanning for (active) workgroups, hosts, and shares
  555. @item Support of the CIFS (Linux) and SMBFS (FreeBSD) file system
  556. @item Mounting and unmounting of shares (using the KAuth framework)
  557. @item Access to the files of a mounted share using a file manager or terminal
  558. @item Auto-detection of external mounts and unmounts
  559. @item Remounting of previously used shares on program start
  560. @item Miscellaneous infos about remote network items and mounted shares
  561. @item Network search
  562. @item WINS server support
  563. @item Preview of the contents of a share
  564. @item Several methods to look up the initial list of workgroups and domains
  565. @item Default login
  566. @item Special handling of homes shares
  567. @item Ability to bookmark favorite shares and organize them in groups
  568. @item System tray widget
  569. @item Support of advanced Samba options
  570. @item Support of printer shares
  571. @item KWallet support
  572. @item Synchronization of a remote share with a local copy and vice versa
  573. @item Ability to define custom options for individual servers and shares
  574. @item Laptop support through the Solid hardware device framework
  575. @end itemize")
  576. (license license:gpl2+)))
  577. (define-public sweeper
  578. (package
  579. (name "sweeper")
  580. (version "21.08.1")
  581. (source
  582. (origin
  583. (method url-fetch)
  584. (uri (string-append "mirror://kde/stable/release-service/" version
  585. "/src/sweeper-" version ".tar.xz"))
  586. (sha256
  587. (base32 "0p25bkczxmx93igicyiasvjd4v9rc3sg7gm7b9ddgzz8rrnr0d9p"))))
  588. (build-system qt-build-system)
  589. (native-inputs
  590. `(("extra-cmake-modules" ,extra-cmake-modules)
  591. ("kdoctools" ,kdoctools)))
  592. (inputs
  593. `(("kactivities-stats" ,kactivities-stats)
  594. ("kbookmarks" ,kbookmarks)
  595. ("kcrash" ,kcrash)
  596. ("kconfig" ,kconfig)
  597. ("kconfigwidgets" ,kconfigwidgets)
  598. ("kcoreaddons" ,kcoreaddons)
  599. ("ki18n" ,ki18n)
  600. ("kio" ,kio)
  601. ("ktextwidgets" ,ktextwidgets)
  602. ("kxmlgui" ,kxmlgui)
  603. ("breeze-icons" ,breeze-icons) ;; default icon set
  604. ("qtbase" ,qtbase-5)))
  605. (home-page "https://apps.kde.org/sweeper/")
  606. (synopsis "Temporary file and history cleaner")
  607. (description "
  608. Sweeper helps to clean unwanted traces the user leaves on the system and to
  609. regain disk space removing unused temporary files.
  610. It can quickly remove temporary information, such as web page cookies,
  611. browser history, or the list of recently-opened documents. It helps provide
  612. additional privacy on a system shared between multiple users.")
  613. (license license:lgpl2.0+ )))