123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
- ;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
- ;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages kde-utils)
- #:use-module (guix build-system qt)
- #:use-module (guix download)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (gnu packages)
- #:use-module (gnu packages bash)
- #:use-module (gnu packages backup)
- #:use-module (gnu packages cmake)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages gnome)
- #:use-module (gnu packages imagemagick)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages kde)
- #:use-module (gnu packages kde-frameworks)
- #:use-module (gnu packages kde-plasma)
- #:use-module (gnu packages qt)
- #:use-module (gnu packages samba)
- #:use-module (gnu packages xorg))
- (define-public ark
- (package
- (name "ark")
- (version "21.08.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/ark-" version ".tar.xz"))
- (sha256
- (base32
- "1ss33qizhg325k4hhf8339xg52iv4s32qjm048zhi2jaz54pdnv0"))
- ;; The libarchive package in Guix does not support
- ;; xar; disable related tests.
- (patches (search-patches "ark-skip-xar-test.patch"))))
- (build-system qt-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'start-xserver
- ;; adddialogtest requires DISPLAY.
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xorg-server (assoc-ref inputs "xorg-server")))
- (setenv "HOME" (getcwd))
- (system (format #f "~a/bin/Xvfb :1 &" xorg-server))
- (setenv "DISPLAY" ":1"))))
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lrzip (assoc-ref inputs "lrzip"))
- (lzop (assoc-ref inputs "lzop"))
- (p7zip (assoc-ref inputs "p7zip"))
- (unzip (assoc-ref inputs "unzip"))
- (zip (assoc-ref inputs "zip"))
- (zstd (assoc-ref inputs "zstd")))
- (wrap-program (string-append out "/bin/ark")
- `("PATH" suffix
- ,(map (lambda (p)
- (string-append p "/bin"))
- (list lrzip lzop p7zip unzip zip zstd))))))))))
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("pkg-config" ,pkg-config)
- ("kdoctools" ,kdoctools)
- ("xorg-server" ,xorg-server)))
- (inputs
- `(("bash-minimal" ,bash-minimal) ; wrap-program
- ("breeze-icons" ,breeze-icons)
- ("karchive" ,karchive)
- ("kconfig" ,kconfig)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("khtml" ,khtml)
- ("ki18n" ,ki18n)
- ("kio" ,kio)
- ("kitemmodels" ,kitemmodels)
- ("kparts" ,kparts)
- ("kpty" ,kpty)
- ("kservice" ,kservice)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("libarchive" ,libarchive)
- ("libzip" ,libzip)
- ("qtbase" ,qtbase-5)
- ("zlib" ,zlib)
- ;; Command line tools used by Ark.
- ("lrzip" ,lrzip)
- ("lzop" ,lzop)
- ("p7zip" ,p7zip)
- ("unzip" ,unzip)
- ("zip" ,zip)
- ("zstd" ,zstd)))
- (home-page "https://apps.kde.org/ark/")
- (synopsis "Graphical archiving tool")
- (description "Ark is a graphical file compression/decompression utility
- with support for multiple formats, including tar, gzip, bzip2, rar and zip, as
- well as CD-ROM images.")
- (license license:gpl2+)))
- (define-public kate
- (package
- (name "kate")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/kate-" version ".tar.xz"))
- (sha256
- (base32 "0k9kf8x5gbj5vbnr6lfhizi8122p76xixw480a3zsqi57i4bxk0z"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kactivities" ,kactivities)
- ("kconfig" ,kconfig)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("kguiaddons" ,kguiaddons)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kitemmodels" ,kitemmodels)
- ("threadweaver" ,threadweaver)
- ("knewstuff" ,knewstuff)
- ("kio" ,kio)
- ("kjobwidgets" ,kjobwidgets)
- ("kparts" ,kparts)
- ("ksyntaxhighlighting" ,ksyntaxhighlighting)
- ("ktexteditor" ,ktexteditor)
- ("kwallet" ,kwallet)
- ("plasma-framework" ,plasma-framework)
- ("kwindowsystem" ,kwindowsystem)
- ("kxmlgui" ,kxmlgui)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qtbase" ,qtbase-5)
- ("qtscript" ,qtscript)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "XDG_CACHE_HOME" "/tmp/xdg-cache")
- #t))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests? ;; Test looks for /usr/bin. Other ones hang.
- (invoke "ctest" "-E" "(plugin-externaltools_test|\
- kateapp-session_manager_test|\
- kateapp-sessions_action_test)"))
- #t)))))
- (home-page "https://kate-editor.org/")
- (synopsis "Multi-document, multi-view text editor")
- (description "Kate is a powerful text editor that can open multiple files
- simultaneously.
- With a built-in terminal, syntax highlighting, and tabbed sidebar, it performs
- as a lightweight but capable development environment. Kate's many tools,
- plugins, and scripts make it highly customizable.
- Kate's features include:
- @itemize
- @item Multiple saved sessions, each with numerous files
- @item Scriptable syntax highlighting, indentation, and code-folding
- @item Configurable templates and text snippets
- @item Symbol viewers for C, C++, and Python
- @item XML completion and validation
- @end itemize")
- (license ;; GPL for programs, LGPL for libraries
- (list license:gpl2+ license:lgpl2.0))))
- (define-public kmag
- (package
- (name "kmag")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/kmag-" version ".tar.xz"))
- (sha256
- (base32 "1hdjcya1jv6adz0d9hp1sq7y8f6fvzpw30fchmjkdm9y2kf8il6c"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("ki18n" ,ki18n)
- ("kio" ,kio)
- ("kxmlgui" ,kxmlgui)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ;; TODO: QAccessibilityClient - libqaccessibilityclien
- ("qtbase" ,qtbase-5)))
- (home-page "https://apps.kde.org/kmag/")
- (synopsis "Screen magnifier tool")
- (description "You can use KMagnifier to magnify a part of the screen just
- as you would use a lens to magnify a newspaper fine-print or a photograph.
- This application is useful for a variety of people: from researchers to
- artists to web-designers to people with low vision.")
- (license ;; GPL for programs, FDL for documentation
- (list license:gpl2+ license:fdl1.2+))))
- (define-public kmousetool
- (package
- (name "kmousetool")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/kmousetool-" version ".tar.xz"))
- (sha256
- (base32 "04a5zrxg48svrvdf8gf3qc7cj7cayzhw0q4l1v8nzs2ykc330xq1"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kauth" ,kauth)
- ("kcoreaddons" ,kcoreaddons)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("knotifications" ,knotifications)
- ("kxmlgui" ,kxmlgui)
- ("kwindowsystem" ,kwindowsystem)
- ("libxtst" ,libxtst)
- ("libxt" ,libxt)
- ("phonon" ,phonon)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qtbase" ,qtbase-5)))
- (home-page "https://apps.kde.org/kmousetool/")
- (synopsis "Automatic mouse click and mouse manipulation tool for the
- disabled")
- (description "KMouseTool clicks the mouse whenever the mouse cursor pauses
- briefly. It was designed to help those with repetitive strain injuries, for
- whom pressing buttons hurts.")
- (license ;; GPL for programs, FDL for documentation
- (list license:gpl2+ license:fdl1.2+))))
- (define-public kmouth
- (package
- (name "kmouth")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/kmouth-" version ".tar.xz"))
- (sha256
- (base32 "1rmqppmjjcrc7xp63csdgp440f003nia6hcnixxlya8pwn90bpwr"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("ki18n" ,ki18n)
- ("kio" ,kio)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qtbase" ,qtbase-5)
- ("qtspeech" ,qtspeech)))
- (home-page "https://apps.kde.org/kmouth/")
- (synopsis "Type-and-say frontend for speech synthesizers")
- (description "KMouth is a program which enables persons that cannot speak
- to let their computer speak, e.g. mutal people or people who have lost their
- voice. It has a text input field and speaks the sentences that you enter. It
- also has support for user defined phrasebooks.
- It includes a history of spoken sentences from which the user can select
- sentences to be re-spoken.")
- (license ;; GPL for programs, FDL for documentation
- (list license:gpl2+ license:fdl1.2+))))
- (define-public kronometer
- (package
- (name "kronometer")
- (version "2.2.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/kronometer/" version
- "/src/kronometer-" version ".tar.xz"))
- (sha256
- (base32 "05hs8729a3aqjpwmn2xdf2sriacrll4sj4ax3lm4s1ravj09n9bm"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kauth" ,kauth)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("ki18n" ,ki18n)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qtbase" ,qtbase-5)))
- (home-page "https://apps.kde.org/kronometer/")
- (synopsis "Simple stopwatch application")
- (description "Kronometer is a stopwatch application. It features the
- basic stopwatch actions (pause, resume, reset, laps), as well as the ability
- to save the times and resume them later.")
- (license ;; GPL for programs, LGPL for libraries, FDL for documentation
- license:gpl2+)))
- (define-public krusader
- (package
- (name "krusader")
- (version "2.7.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/krusader/" version
- "/krusader-" version ".tar.xz"))
- (sha256
- (base32 "02b1jz5a7cjr13v6c7fczrhs1xmg1krnva5fxk8x2bf4nd1rm8s1"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("karchive" ,karchive)
- ("kbookmarks" ,kbookmarks)
- ("kcodecs" ,kcodecs)
- ("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kcoreaddons" ,kcoreaddons)
- ("kguiaddons" ,kguiaddons)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kio" ,kio)
- ("kitemviews" ,kitemviews)
- ("knotifications" ,knotifications)
- ("kparts" ,kparts)
- ("ktextwidgets" ,ktextwidgets)
- ("kwallet" ,kwallet)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kwindowsystem" ,kwindowsystem)
- ("kxmlgui" ,kxmlgui)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qtbase" ,qtbase-5)
- ("solid" ,solid)
- ("zlib" ,zlib)))
- (home-page "https://krusader.org/")
- (synopsis "Twin-panel (commander-style) file manager")
- (description "Krusader is a simple, easy, yet powerful,
- twin-panel (commander-style) file manager, similar to Midnight Commander or
- Total Commander
- It provides all the file management features you could possibly want. Plus:
- extensive archive handling, mounted file system support, FTP, advanced search
- module, an internal viewer/editor, directory synchronisation, file content
- comparisons, powerful batch renaming and much much more. It supports a wide
- variety of archive formats and can handle other KIO slaves such as smb or
- fish.
- Almost completely customizable, Krusader is very user friendly, fast and looks
- great on your desktop.")
- (license license:gpl2+)))
- (define-public kxstitch
- (package
- (name "kxstitch")
- (version "2.2.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/kxstitch/" version
- "/kxstitch-" version ".tar.xz"))
- (sha256
- (base32 "1q6blvcqz6hxdfrkdi0fplmz7rmk3im56kpp68r0yrivhx3hn8sc"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("ktexteditor" ,ktexteditor)
- ("imagemagick" ,imagemagick)
- ("qtbase" ,qtbase-5)
- ("qtx11extras" ,qtx11extras)))
- (home-page "https://apps.kde.org/kxstitch/")
- (synopsis "Create and print cross stitch patterns")
- (description
- "KXStitch allows creating and printing cross stitch patterns, which can
- either be created or generated from a image.")
- (license license:gpl2+)))
- (define-public okteta
- (package
- (name "okteta")
- (version "0.26.6")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/okteta/" version
- "/src/okteta-" version ".tar.xz"))
- (sha256
- (base32 "0k0lw2z5iii6z7rg7ijjm8kc9248n1i92p2v3bglcgjhamdwssf5"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)
- ("qttools" ,qttools)
- ("shared-mime-info" ,shared-mime-info)))
- (inputs
- `(("kbookmarks" ,kbookmarks)
- ("kcmutils" ,kcmutils)
- ("kcodecs" ,kcodecs)
- ("kcrash" ,kcrash)
- ("kcompletion" ,kcompletion)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kio" ,kio)
- ("knewstuff" ,knewstuff)
- ("kparts" ,kparts)
- ("kservice" ,kservice)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qca" ,qca)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
- ("qtscript" ,qtscript)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "HOME" "/tmp/dummy-home")
- #t)))))
- (home-page "https://apps.kde.org/okteta/")
- (synopsis "Hexadecimal editor for binary files")
- (description "Okteta is a simple editor for the raw data of files. This
- type of program is also called hex editor or binary editor.
- The data is displayed in the traditional view with two columns: one with the
- numeric values and one with the assigned characters. Editing can be done both
- in the value column and the character column. Besides the usual editing
- capabilities Okteta also brings a small set of tools, like a table listing
- decodings into common simple data types, a table listing all possible bytes
- with its character and value equivalents, a info view with a statistic and a
- filter tool. All modifications to the data loaded can be endlessly undone or
- redone.")
- (license ;; GPL for programs, LGPL for libraries, FDL for documentation
- (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
- (define-public rsibreak
- (package
- (name "rsibreak")
- (version "0.12.14")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde//stable/rsibreak/0.12/"
- "rsibreak-" version ".tar.xz"))
- (sha256
- (base32 "0yjv5awngi2hk6xzlwzmj92i6qppnfc0inqdp16rd8gzfpw7xqqw"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kauth" ,kauth)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kidletime" ,kidletime)
- ("knotifications" ,knotifications)
- ("knotifyconfig" ,knotifyconfig)
- ("ktextwidgets" ,ktextwidgets)
- ("kwindowsystem" ,kwindowsystem)
- ("kxmlgui" ,kxmlgui)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qtbase" ,qtbase-5)))
- (home-page "https://apps.kde.org/rsibreak/")
- (synopsis "Assists in the Recovery and Prevention of Repetitive Strain
- Injury")
- (description "Repetitive Strain Injury is an illness which can occur as a
- result of working with a mouse and keyboard. This utility can be used to
- remind you to take a break now and then.")
- (license ;; GPL for programs, FDL for documentation
- (list license:gpl2+ license:fdl1.2+))))
- (define-public smb4k
- (package
- (name "smb4k")
- (version "3.1.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://sourceforge.net/projects/smb4k/files/"
- version "/smb4k-" version ".tar.xz/download"))
- (file-name (string-append name "-" version ".tar.xz"))
- (sha256
- (base32 "189h5znan2kfqflik308ghqc2z55s5z8kwpq8gjz2y0lwyqdiw0b"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kauth" ,kauth)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcompletion" ,kcompletion)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdnssd" ,kdnssd)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kio" ,kio)
- ("kjobwidgets" ,kjobwidgets)
- ("knotifications" ,knotifications)
- ("knotifyconfig" ,knotifyconfig)
- ("ktextwidgets" ,ktextwidgets)
- ("kwallet" ,kwallet)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kwindowsystem" ,kwindowsystem)
- ("kxmlgui" ,kxmlgui)
- ("libsmbclient" ,samba)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("plasma-framework" ,plasma-framework)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
- ("solid" ,solid)))
- (home-page "https://apps.kde.org/smb4k/")
- (synopsis "Samba (SMB) share advanced browser")
- (description "Smb4K is an network neighborhood browser for the KDE
- Software Compilation and a frontend to the programs of the Samba software
- suite.
- Features:
- @itemize
- @item Scanning for (active) workgroups, hosts, and shares
- @item Support of the CIFS (Linux) and SMBFS (FreeBSD) file system
- @item Mounting and unmounting of shares (using the KAuth framework)
- @item Access to the files of a mounted share using a file manager or terminal
- @item Auto-detection of external mounts and unmounts
- @item Remounting of previously used shares on program start
- @item Miscellaneous infos about remote network items and mounted shares
- @item Network search
- @item WINS server support
- @item Preview of the contents of a share
- @item Several methods to look up the initial list of workgroups and domains
- @item Default login
- @item Special handling of homes shares
- @item Ability to bookmark favorite shares and organize them in groups
- @item System tray widget
- @item Support of advanced Samba options
- @item Support of printer shares
- @item KWallet support
- @item Synchronization of a remote share with a local copy and vice versa
- @item Ability to define custom options for individual servers and shares
- @item Laptop support through the Solid hardware device framework
- @end itemize")
- (license license:gpl2+)))
- (define-public sweeper
- (package
- (name "sweeper")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/sweeper-" version ".tar.xz"))
- (sha256
- (base32 "0p25bkczxmx93igicyiasvjd4v9rc3sg7gm7b9ddgzz8rrnr0d9p"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kactivities-stats" ,kactivities-stats)
- ("kbookmarks" ,kbookmarks)
- ("kcrash" ,kcrash)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("ki18n" ,ki18n)
- ("kio" ,kio)
- ("ktextwidgets" ,ktextwidgets)
- ("kxmlgui" ,kxmlgui)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qtbase" ,qtbase-5)))
- (home-page "https://apps.kde.org/sweeper/")
- (synopsis "Temporary file and history cleaner")
- (description "
- Sweeper helps to clean unwanted traces the user leaves on the system and to
- regain disk space removing unused temporary files.
- It can quickly remove temporary information, such as web page cookies,
- browser history, or the list of recently-opened documents. It helps provide
- additional privacy on a system shared between multiple users.")
- (license license:lgpl2.0+ )))
|