jrnl.scm 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Eric Bavier <address@hidden>
  3. ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  5. ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages jrnl)
  22. #:use-module (guix packages)
  23. #:use-module (guix licenses)
  24. #:use-module (guix git-download)
  25. #:use-module (guix build-system python)
  26. #:use-module (gnu packages check)
  27. #:use-module (gnu packages python)
  28. #:use-module (gnu packages python-crypto)
  29. #:use-module (gnu packages python-xyz)
  30. #:use-module (gnu packages time))
  31. (define-public jrnl
  32. (package
  33. (name "jrnl")
  34. (version "1.9.7")
  35. (source
  36. (origin
  37. (method git-fetch)
  38. (uri (git-reference
  39. (url "https://github.com/maebert/jrnl")
  40. (commit version)))
  41. (file-name (git-file-name name version))
  42. (sha256
  43. (base32 "1bjjyfc3fnsy0h299s3jj42wnigj43xdyp5ppi1cvkqbwl369935"))))
  44. (build-system python-build-system)
  45. (native-inputs
  46. `(("behave" ,behave)))
  47. (inputs
  48. `(("python" ,python)
  49. ("python-keyring" ,python-keyring)
  50. ("python-pycrypto" ,python-pycrypto)
  51. ("python-pytz" ,python-pytz)
  52. ("python-tzlocal" ,python-tzlocal)
  53. ("python-six" ,python-six)
  54. ("python-dateutil" ,python-dateutil)
  55. ("python-parsedatetime" ,python-parsedatetime)))
  56. (home-page "https://maebert.github.io/jrnl/")
  57. (synopsis "Personal journal application")
  58. (description
  59. "Jrnl is a command line journal application that stores your journal in a
  60. plain text file. Optionally, your journal can be encrypted using 256-bit AES
  61. encryption.")
  62. (license x11)))