gxmessage.scm 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages gxmessage)
  20. #:use-module (guix licenses)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (gnu packages glib)
  25. #:use-module (gnu packages pkg-config)
  26. #:use-module (gnu packages gtk)
  27. #:use-module (gnu packages))
  28. (define-public gxmessage
  29. (package
  30. (name "gxmessage")
  31. (version "3.4.3")
  32. (source (origin
  33. (method url-fetch)
  34. (uri (string-append "mirror://gnu/gxmessage/gxmessage-"
  35. version ".tar.gz"))
  36. (sha256
  37. (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv"))))
  38. (build-system gnu-build-system)
  39. (arguments
  40. '(#:phases
  41. (modify-phases %standard-phases
  42. (add-before 'install 'skip-gtk-update-icon-cache
  43. ;; Don't create 'icon-theme.cache'.
  44. (lambda _
  45. (substitute* "Makefile"
  46. (("gtk-update-icon-cache") "true"))
  47. #t)))))
  48. (inputs
  49. `(("gtk+" ,gtk+)))
  50. (native-inputs
  51. `(("intltool" ,intltool)
  52. ("pkg-config" ,pkg-config)))
  53. (home-page "https://www.gnu.org/software/gxmessage/")
  54. (synopsis "Open popup message window with buttons for return")
  55. (description "GNU gxmessage is a program that pops up dialog windows, which display
  56. a message to the user and waits for their action. The program then exits
  57. with an exit code corresponding to the response.")
  58. (license gpl3+)))