fvwm.scm 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2017 Nikita <nikita@n0.is>
  5. ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages fvwm)
  22. #:use-module ((guix licenses) #:select (gpl2+))
  23. #:use-module (guix packages)
  24. #:use-module (guix download)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (gnu packages fribidi)
  27. #:use-module (gnu packages gnome)
  28. #:use-module (gnu packages image)
  29. #:use-module (gnu packages perl)
  30. #:use-module (gnu packages pkg-config)
  31. #:use-module (gnu packages readline)
  32. #:use-module (gnu packages xml)
  33. #:use-module (gnu packages xorg))
  34. (define-public fvwm
  35. (package
  36. (name "fvwm")
  37. (version "2.6.9")
  38. (source (origin
  39. (method url-fetch)
  40. (uri (string-append
  41. "https://github.com/fvwmorg/fvwm/releases/download/"
  42. version "/fvwm-" version ".tar.gz"))
  43. (sha256
  44. (base32
  45. "1bliqcnap7vb3m2rn8wvxyfhbf35h9x34s41fl4301yhrkrlrihv"))))
  46. (build-system gnu-build-system)
  47. (arguments
  48. `(#:phases
  49. (modify-phases %standard-phases
  50. (add-after 'install 'install-xsession
  51. (lambda* (#:key outputs #:allow-other-keys)
  52. (let* ((out (assoc-ref outputs "out"))
  53. (xsessions (string-append out "/share/xsessions")))
  54. (mkdir-p xsessions)
  55. (make-desktop-entry-file
  56. (string-append xsessions "/fvwm2.desktop")
  57. #:name "FVWM"
  58. #:exec (string-append out "/bin/" ,name)
  59. #:comment '("FVWM")))
  60. #t)))))
  61. (native-inputs
  62. `(("perl" ,perl)
  63. ("pkg-config" ,pkg-config)
  64. ("xsltproc" ,libxslt)))
  65. (inputs
  66. `(("fribidi" ,fribidi)
  67. ("libpng" ,libpng)
  68. ("librsvg" ,librsvg)
  69. ("libxcursor" ,libxcursor)
  70. ("libxext" ,libxext)
  71. ("libxft" ,libxft)
  72. ("libxinerama" ,libxinerama)
  73. ("libxpm" ,libxpm)
  74. ("libxt" ,libxt)
  75. ("readline" ,readline)))
  76. (synopsis "Virtual window manager for X11")
  77. (description
  78. "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
  79. window manager for the X Window system.")
  80. (home-page "https://www.fvwm.org/")
  81. (license gpl2+)))