flex.scm 3.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012, 2013, 2014, 2019 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages flex)
  20. #:use-module (guix licenses)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (guix utils)
  25. #:use-module (gnu packages)
  26. #:use-module (gnu packages m4)
  27. #:use-module (gnu packages man)
  28. #:use-module (gnu packages bison)
  29. #:use-module (srfi srfi-1))
  30. (define-public flex
  31. (package
  32. (name "flex")
  33. (version "2.6.4")
  34. (source (origin
  35. (method url-fetch)
  36. (uri (string-append
  37. "https://github.com/westes/flex"
  38. "/releases/download/v" version "/"
  39. "flex-" version ".tar.gz"))
  40. (sha256
  41. (base32
  42. "15g9bv236nzi665p9ggqjlfn4dwck5835vf0bbw2cz7h5c1swyp8"))))
  43. (build-system gnu-build-system)
  44. (inputs
  45. (let ((bison-for-tests
  46. (package
  47. (inherit bison)
  48. (arguments
  49. ;; Disable tests, since they require flex.
  50. (substitute-keyword-arguments (package-arguments bison)
  51. ((#:tests? _ #f) #f)))
  52. (inputs (alist-delete "flex" (package-inputs bison))))))
  53. `(("bison" ,bison-for-tests))))
  54. ;; m4 is not present in PATH when cross-building
  55. (native-inputs
  56. `(("help2man" ,help2man)
  57. ("m4" ,m4)))
  58. (propagated-inputs `(("m4" ,m4)))
  59. (home-page "https://github.com/westes/flex")
  60. (synopsis "Fast lexical analyser generator")
  61. (description
  62. "Flex is a tool for generating scanners. A scanner, sometimes
  63. called a tokenizer, is a program which recognizes lexical patterns in
  64. text. The flex program reads user-specified input files, or its standard
  65. input if no file names are given, for a description of a scanner to
  66. generate. The description is in the form of pairs of regular expressions
  67. and C code, called rules. Flex generates a C source file named,
  68. \"lex.yy.c\", which defines the function yylex(). The file \"lex.yy.c\"
  69. can be compiled and linked to produce an executable. When the executable
  70. is run, it analyzes its input for occurrences of text matching the
  71. regular expressions for each rule. Whenever it finds a match, it
  72. executes the corresponding C code.")
  73. (license (non-copyleft "file://COPYING"
  74. "See COPYING in the distribution."))))