file.scm 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
  3. ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
  5. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
  7. ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
  8. ;;;
  9. ;;; This file is part of GNU Guix.
  10. ;;;
  11. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  12. ;;; under the terms of the GNU General Public License as published by
  13. ;;; the Free Software Foundation; either version 3 of the License, or (at
  14. ;;; your option) any later version.
  15. ;;;
  16. ;;; GNU Guix is distributed in the hope that it will be useful, but
  17. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  18. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  19. ;;; GNU General Public License for more details.
  20. ;;;
  21. ;;; You should have received a copy of the GNU General Public License
  22. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  23. (define-module (gnu packages file)
  24. #:use-module (gnu packages)
  25. #:use-module (guix licenses)
  26. #:use-module (guix packages)
  27. #:use-module (guix download)
  28. #:use-module (guix build-system gnu))
  29. (define-public file
  30. (package
  31. (name "file")
  32. (version "5.39")
  33. (source (origin
  34. (method url-fetch)
  35. (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
  36. version ".tar.gz"))
  37. (sha256
  38. (base32
  39. "1lgs2w2sgamzf27kz5h7pajz7v62554q21fbs11n4mfrfrm2hpgh"))))
  40. (build-system gnu-build-system)
  41. ;; When cross-compiling, this package depends upon a native install of
  42. ;; itself.
  43. (native-inputs (if (%current-target-system)
  44. `(("self" ,this-package))
  45. '()))
  46. (properties
  47. `((release-monitoring-url . "http://ftp.astron.com/pub/file/")))
  48. (synopsis "File type guesser")
  49. (description
  50. "The file command is a file type guesser, a command-line tool that tells
  51. you in words what kind of data a file contains. It does not rely on filename
  52. extensions to tell you the type of a file, but looks at the actual contents
  53. of the file. This package provides the libmagic library.")
  54. (license bsd-2)
  55. (home-page "https://www.darwinsys.com/file/")))