dvtm.scm 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages dvtm)
  19. #:use-module (guix build-system gnu)
  20. #:use-module (guix download)
  21. #:use-module (guix licenses)
  22. #:use-module (guix packages)
  23. #:use-module (gnu packages ncurses))
  24. (define-public dvtm
  25. (package
  26. (name "dvtm")
  27. (version "0.15")
  28. (source (origin
  29. (method url-fetch)
  30. (uri (string-append "http://www.brain-dump.org/projects/dvtm/dvtm-"
  31. version ".tar.gz"))
  32. (sha256
  33. (base32
  34. "0475w514b7i3gxk6khy8pfj2gx9l7lv2pwacmq92zn1abv01a84g"))))
  35. (build-system gnu-build-system)
  36. (arguments
  37. `(#:make-flags (list "CC=gcc"
  38. (string-append "PREFIX=" (assoc-ref %outputs "out")))
  39. #:phases (modify-phases %standard-phases
  40. (delete 'configure)
  41. (delete 'check)))) ; no test suite
  42. (inputs `(("ncurses" ,ncurses)))
  43. (synopsis "Tiling window management for the console")
  44. (description "dvtm brings the concept of tiling window management,
  45. popularized by X11-window managers like dwm, to the console. As a console
  46. window manager it tries to make it easy to work with multiple console based
  47. programs.")
  48. (home-page "https://www.brain-dump.org/projects/dvtm/")
  49. ;; "dvtm reuses some code of dwm and is released under the same MIT/X11
  50. ;; license. The terminal emulation part is licensed under the ISC license."
  51. ;; source: http://www.brain-dump.org/projects/dvtm/#license
  52. (license (list expat isc))))