apr.scm 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
  3. ;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages apr)
  20. #:use-module ((guix licenses) #:prefix l:)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (gnu packages)
  25. #:use-module (gnu packages perl)
  26. #:use-module (gnu packages xml)
  27. #:use-module (gnu packages autotools))
  28. (define-public apr
  29. (package
  30. (name "apr")
  31. (version "1.6.5")
  32. (source (origin
  33. (method url-fetch)
  34. (uri (string-append "mirror://apache/apr/apr-"
  35. version ".tar.bz2"))
  36. (sha256
  37. (base32
  38. "01d1n1ql66bxsjx0wyzazmkqdqdmr0is6a7lwyy5kzy4z7yajz56"))
  39. (patches
  40. (search-patches "apr-skip-getservbyname-test.patch"))
  41. (patch-flags '("-p0"))))
  42. (build-system gnu-build-system)
  43. (arguments
  44. ;; Sometimes we end up with two processes concurrently trying to make
  45. ;; 'libmod_test.la': <http://hydra.gnu.org/build/60266/nixlog/2/raw>.
  46. ;; Thus, build sequentially.
  47. '(#:parallel-build? #f
  48. #:parallel-tests? #f))
  49. (inputs `(("perl" ,perl)
  50. ("libltdl" ,libltdl)))
  51. (home-page "http://apr.apache.org/")
  52. (synopsis "The Apache Portable Runtime Library")
  53. (description
  54. "The mission of the Apache Portable Runtime (APR) project is to create and
  55. maintain software libraries that provide a predictable and consistent interface
  56. to underlying platform-specific implementations. The primary goal is to provide
  57. an API to which software developers may code and be assured of predictable if
  58. not identical behaviour regardless of the platform on which their software is
  59. built, relieving them of the need to code special-case conditions to work
  60. around or take advantage of platform-specific deficiencies or features.")
  61. (license l:asl2.0)))
  62. (define-public apr-util
  63. (package
  64. (name "apr-util")
  65. (version "1.6.1")
  66. (source (origin
  67. (method url-fetch)
  68. (uri (string-append "mirror://apache/apr/apr-util-"
  69. version ".tar.bz2"))
  70. (sha256
  71. (base32
  72. "0nq3s1yn13vplgl6qfm09f7n0wm08malff9s59bqf9nid9xjzqfk"))))
  73. (build-system gnu-build-system)
  74. (inputs
  75. `(("apr" ,apr)))
  76. (propagated-inputs
  77. `(("expat" ,expat)))
  78. (arguments
  79. '(#:phases
  80. (modify-phases %standard-phases
  81. (replace 'configure
  82. (lambda* (#:key inputs outputs #:allow-other-keys)
  83. (let ((out (assoc-ref outputs "out"))
  84. (apr (assoc-ref inputs "apr"))
  85. (expat (assoc-ref inputs "expat")))
  86. (setenv "CONFIG_SHELL" (which "bash"))
  87. (invoke "./configure"
  88. (string-append "--prefix=" out)
  89. (string-append "--with-apr=" apr)
  90. (string-append "--with-expat=" expat))))))
  91. ;; There are race conditions during 'make check'. Typically, the
  92. ;; 'testall' executable is not built yet by the time 'make check' tries
  93. ;; to run it. See
  94. ;; <http://lists.gnu.org/archive/html/guix-devel/2014-03/msg00261.html>.
  95. #:parallel-tests? #f))
  96. (home-page "http://apr.apache.org/")
  97. (synopsis "One of the Apache Portable Runtime Library companions")
  98. (description
  99. "APR-util provides a number of helpful abstractions on top of APR.")
  100. (license l:asl2.0)))