acct.scm 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
  3. ;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages acct)
  20. #:use-module (guix licenses)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu))
  24. (define-public acct
  25. (package
  26. (name "acct")
  27. (version "6.6.4")
  28. (source
  29. (origin
  30. (method url-fetch)
  31. (uri (string-append "mirror://gnu/acct/acct-"
  32. version ".tar.gz"))
  33. (sha256
  34. (base32
  35. "0gv6m8giazshvgpvwbng98chpas09myyfw1zr2y7hqxib0mvy5ac"))))
  36. (build-system gnu-build-system)
  37. (home-page "https://www.gnu.org/software/acct/")
  38. (synopsis "Standard login and process accounting utilities")
  39. (description
  40. "GNU acct provides a means for system administrators to determine
  41. system usage patterns. It provides information on, for example, connections,
  42. programs executed, and system resources used.")
  43. (license gpl3+)))