abiword.scm 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
  3. ;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
  5. ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
  6. ;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  7. ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
  8. ;;;
  9. ;;; This file is part of GNU Guix.
  10. ;;;
  11. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  12. ;;; under the terms of the GNU General Public License as published by
  13. ;;; the Free Software Foundation; either version 3 of the License, or (at
  14. ;;; your option) any later version.
  15. ;;;
  16. ;;; GNU Guix is distributed in the hope that it will be useful, but
  17. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  18. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  19. ;;; GNU General Public License for more details.
  20. ;;;
  21. ;;; You should have received a copy of the GNU General Public License
  22. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  23. (define-module (gnu packages abiword)
  24. #:use-module ((guix licenses) #:prefix license:)
  25. #:use-module (guix packages)
  26. #:use-module (guix download)
  27. #:use-module (guix build-system gnu)
  28. #:use-module (guix build-system glib-or-gtk)
  29. #:use-module (gnu packages)
  30. #:use-module (gnu packages autotools)
  31. #:use-module (gnu packages boost)
  32. #:use-module (gnu packages compression)
  33. #:use-module (gnu packages enchant)
  34. #:use-module (gnu packages fribidi)
  35. #:use-module (gnu packages fontutils)
  36. #:use-module (gnu packages glib)
  37. #:use-module (gnu packages gnome)
  38. #:use-module (gnu packages gtk)
  39. #:use-module (gnu packages image)
  40. #:use-module (gnu packages ots)
  41. #:use-module (gnu packages popt)
  42. #:use-module (gnu packages pkg-config)
  43. #:use-module (gnu packages readline)
  44. #:use-module (gnu packages wv)
  45. #:use-module (gnu packages xml))
  46. (define-public abiword
  47. (package
  48. (name "abiword")
  49. (version "3.0.5")
  50. (source
  51. (origin
  52. (method url-fetch)
  53. (uri
  54. (string-append "https://www.abisource.com/downloads/abiword/" version
  55. "/source/abiword-" version ".tar.gz"))
  56. (sha256
  57. (base32 "1d1179pnslijpjhz1q155fsc828rrlqf7lsn2inqsl3hk5z28mqj"))
  58. (patches
  59. (search-patches "abiword-explictly-cast-bools.patch"))))
  60. (build-system glib-or-gtk-build-system)
  61. (arguments ;; NOTE: rsvg is disabled, since Abiword
  62. `(#:configure-flags ;; supports it directly, and its BS is broken.
  63. (list ;; wmf was removed from Guix for security.
  64. "--enable-clipart" ;; TODO: The following plugins have unresolved
  65. "--enable-templates" ;; dependencies: aiksaurus, grammar, wpg, gda,
  66. (string-append ;; wordperfect, psion, mathview.
  67. "--enable-plugins="
  68. "applix " "babelfish " "bmp " "clarisworks " "collab " "command "
  69. "docbook " "eml " "epub " "freetranslation " "garble " "gdict "
  70. "gimp " "goffice " "google " "hancom " "hrtext " "iscii " "kword "
  71. "latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
  72. "openwriter " "openxml " "opml " "ots " "paint " "passepartout "
  73. "pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
  74. "wikipedia " "wml " "xslfo"))
  75. ;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
  76. ;; assertion 'GDK_IS_SCREEN (screen)' failed
  77. ;; GLib-GObject-CRITICAL **: g_object_get_qdata:
  78. ;; assertion 'G_IS_OBJECT (object)' failed
  79. ;; Manually starting the X server before the test phase did not help
  80. ;; the tests to pass.
  81. #:tests? #f
  82. #:make-flags
  83. (list "gtk_update_icon_cache=true")))
  84. (inputs
  85. `(("boost" ,boost)
  86. ("enchant" ,enchant)
  87. ("fontconfig" ,fontconfig)
  88. ("fribidi" ,fribidi)
  89. ("glib" ,glib)
  90. ("goffice" ,goffice)
  91. ("gtk+" ,gtk+)
  92. ("libchamplain" ,libchamplain)
  93. ("libglade" ,libglade)
  94. ("libgsf" ,libgsf)
  95. ("libjpeg" ,libjpeg-turbo)
  96. ("libpng" ,libpng)
  97. ("librsvg" ,librsvg)
  98. ("libxml2" ,libxml2)
  99. ("libxslt" ,libxslt)
  100. ("ots" ,ots)
  101. ("popt" ,popt)
  102. ("readline" ,readline)
  103. ("telepathy" ,telepathy-glib)
  104. ("wv" ,wv)
  105. ("zlib" ,zlib)))
  106. (native-inputs
  107. `(("intltool" ,intltool)
  108. ("glib:bin" ,glib "bin")
  109. ("libtool" ,libtool)
  110. ("pkg-config" ,pkg-config)))
  111. (home-page "https://www.abisource.com/")
  112. (synopsis "Word processing program")
  113. ;; HACKERS: The comment below is here so that it shows up early in the
  114. ;; .pot file.
  115. ;; TRANSLATORS: Dear translator, We would like to inform you that package
  116. ;; descriptions may occasionally include Texinfo markup. Texinfo markup
  117. ;; looks like "@code{rm -rf}", "@emph{important}", etc. When translating,
  118. ;; please leave markup as is.
  119. (description "AbiWord is a word processing program. It is rapidly
  120. becoming a state of the art word processor, with lots of features useful for
  121. your daily work, personal needs, or for just some good old typing fun.")
  122. (license license:gpl2+)))