12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273 |
- (define-module (gnu packages libedit)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages ncurses))
- (define-public libedit
- (package
- (name "libedit")
- (version "20191231-3.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://thrysoee.dk/editline"
- "/libedit-" version ".tar.gz"))
- (sha256
- (base32 "0wch48nml28jj6ild889745dsg2agm7mpvrmbl1gi98nw6vjrf6v"))))
- (build-system gnu-build-system)
- (inputs
- (list ncurses))
- (home-page "https://thrysoee.dk/editline/")
- (synopsis "NetBSD Editline library")
- (description
- "This is an autotool- and libtoolized port of the NetBSD Editline
- library (libedit). This Berkeley-style licensed command line editor library
- provides generic line editing, history, and tokenization functions, similar to
- those found in GNU Readline.")
- (license bsd-3)))
- (define-public editline
- (package
- (name "editline")
- (version "1.17.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://ftp.troglobit.com/editline/editline-" version ".tar.xz"))
- (sha256
- (base32 "03pw3z6pz590v8xfnjx0yynnzij2sb9xwjbvqvdzsid56crkn8nz"))))
- (build-system gnu-build-system)
- (home-page "https://troglobit.com/projects/editline/")
- (synopsis "Line editing library")
- (description
- "@code{editline} is a small line editing library. It can be linked into almost
- any program to provide command line editing and history functions. It is call
- compatible with the GNU Readline library, but at a fraction of the size,
- and as a result fewer features.")
- (license bsd-4)))
|