wordnet.scm 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages wordnet)
  20. #:use-module (guix packages)
  21. #:use-module (guix build-system gnu)
  22. #:use-module (guix licenses)
  23. #:use-module (guix download)
  24. #:use-module (gnu packages)
  25. #:use-module (gnu packages gcc)
  26. #:use-module (gnu packages tcl))
  27. (define-public wordnet
  28. (package
  29. (name "wordnet")
  30. (version "3.0")
  31. (source (origin
  32. (method url-fetch)
  33. (uri (string-append "http://wordnetcode.princeton.edu/"
  34. version "/WordNet-" version ".tar.bz2"))
  35. (sha256
  36. (base32
  37. "08pgjvd2vvmqk3h641x63nxp7wqimb9r30889mkyfh2agc62sjbc"))
  38. (patches (search-patches
  39. "wordnet-CVE-2008-2149.patch"
  40. "wordnet-CVE-2008-3908-pt1.patch"
  41. "wordnet-CVE-2008-3908-pt2.patch"))))
  42. (build-system gnu-build-system)
  43. (arguments
  44. `(#:configure-flags (list (string-append "--with-tcl="
  45. (assoc-ref %build-inputs "tcl")
  46. "/lib")
  47. (string-append "--with-tk="
  48. (assoc-ref %build-inputs "tk")
  49. "/lib")
  50. ;; Provide the `result' field in `Tcl_Interp'.
  51. ;; See <https://bugs.gentoo.org/show_bug.cgi?id=452034>.
  52. "CFLAGS=-DUSE_INTERP_RESULT -O2")
  53. #:phases
  54. (modify-phases %standard-phases
  55. (add-before 'build 'build-libwn-PIC
  56. (lambda _
  57. ;; GNU Dico links libWN.a in its wordnet.so plugin, so it needs
  58. ;; PIC.
  59. (invoke "make" "-C" "lib" "CFLAGS=-O2 -g -fPIC"
  60. "LDFLAGS=-fPIC")))
  61. (add-after 'install 'post-install
  62. (lambda* (#:key inputs outputs #:allow-other-keys)
  63. (let ((out (assoc-ref outputs "out"))
  64. (bin (assoc-ref outputs "tk"))
  65. (tk (assoc-ref inputs "tk"))
  66. (tkv ,(let ((v (package-version tk)))
  67. (string-take v (string-index-right v #\.)))))
  68. ;; Move `wishwn' and `wnb' to BIN.
  69. (for-each (lambda (prog)
  70. (let ((orig (string-append out "/bin/" prog))
  71. (dst (string-append bin "/bin/" prog))
  72. (dir (string-append tk "/lib/tk" tkv)))
  73. (mkdir-p (dirname dst))
  74. (copy-file orig dst)
  75. (delete-file orig)
  76. (wrap-program dst
  77. `("TK_LIBRARY" "" = (,dir))
  78. `("PATH" ":" prefix
  79. (,(string-append out
  80. "/bin"))))))
  81. '("wishwn" "wnb"))
  82. #t))))))
  83. (outputs '("out"
  84. "tk")) ; for the Tcl/Tk GUI
  85. (inputs `(("tk" ,tk)
  86. ("tcl" ,tcl)))
  87. (home-page "https://wordnet.princeton.edu/")
  88. (synopsis "Lexical database for the English language")
  89. (description
  90. "WordNet is a large lexical database of English. Nouns, verbs,
  91. adjectives and adverbs are grouped into sets of cognitive synonyms (synsets),
  92. each expressing a distinct concept. Synsets are interlinked by means of
  93. conceptual-semantic and lexical relations. The resulting network of
  94. meaningfully related words and concepts can be navigated with the browser.
  95. WordNet is also freely and publicly available for download. WordNet's
  96. structure makes it a useful tool for computational linguistics and natural
  97. language processing.")
  98. (license x11)))