stenography.scm 2.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
  3. ;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages stenography)
  20. #:use-module (guix build-system python)
  21. #:use-module (guix git-download)
  22. #:use-module ((guix licenses) #:prefix license:)
  23. #:use-module (guix packages)
  24. #:use-module (gnu packages)
  25. #:use-module (gnu packages qt)
  26. #:use-module (gnu packages check)
  27. #:use-module (gnu packages libusb)
  28. #:use-module (gnu packages python)
  29. #:use-module (gnu packages python-xyz)
  30. #:use-module (gnu packages wxwidgets))
  31. (define-public plover
  32. (package
  33. (name "plover")
  34. (version "4.0.0.dev8")
  35. (source
  36. (origin
  37. (method git-fetch)
  38. (uri (git-reference
  39. (url "https://github.com/openstenoproject/plover")
  40. (commit (string-append "v" version))))
  41. (file-name (git-file-name name version))
  42. (sha256
  43. (base32 "1b2ys77bkjsdmyg97i7lq3lj45q56bycvsm06d4rs656kxhvc0a3"))))
  44. (build-system python-build-system)
  45. (native-inputs
  46. `(("python-mock" ,python-mock)
  47. ("python-pytest" ,python-pytest)
  48. ("python-setuptools-scm" ,python-setuptools-scm)))
  49. (inputs
  50. `(("python-appdirs" ,python-appdirs)
  51. ("python-pyqt" ,python-pyqt)
  52. ("python-babel" ,python-babel)
  53. ("python-dbus" ,python-dbus)
  54. ("python-hidapi" ,python-hidapi)
  55. ("python-pyserial" ,python-pyserial)
  56. ("python-wxpython" ,python-wxpython)
  57. ("python-xlib" ,python-xlib)))
  58. (home-page "https://www.openstenoproject.org/plover/")
  59. (synopsis "Stenography engine")
  60. (description
  61. "Plover (rhymes with @emph{lover}) is a desktop application that
  62. allows anyone to use stenography to write on their computer, up to
  63. speeds of 200WPM and beyond.")
  64. (license license:gpl2+)))