serveez.scm 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages serveez)
  19. #:use-module (guix packages)
  20. #:use-module (guix licenses)
  21. #:use-module (guix download)
  22. #:use-module (guix build-system gnu)
  23. #:use-module (gnu packages)
  24. #:use-module (gnu packages guile))
  25. (define-public serveez
  26. (package
  27. (name "serveez")
  28. (version "0.2.2")
  29. (source
  30. (origin
  31. (method url-fetch)
  32. (uri (string-append "mirror://gnu/serveez/serveez-"
  33. version ".tar.xz"))
  34. (sha256
  35. (base32
  36. "09a5jh762ps71ivlg7vdlzp3y29ncl3nsad7qbcni78bq2mzwxsc"))))
  37. (build-system gnu-build-system)
  38. (inputs `(("guile" ,guile-2.0)))
  39. (arguments
  40. `(#:configure-flags '("--enable-libserveez-install")
  41. #:phases
  42. (modify-phases %standard-phases
  43. (add-before 'patch-source-shebangs 'patch-test-source
  44. (lambda _
  45. (substitute*
  46. (find-files "test" "^t[0-9]{3}$")
  47. (("/bin/sh") (which "sh")))
  48. #t)))))
  49. (home-page "https://www.gnu.org/software/serveez/")
  50. (synopsis "Framework for implementing IP-based servers")
  51. (description
  52. "GNU Serveez is a server framework providing the routines necessary to
  53. easily implement IP-based servers in your application. It
  54. demonstrates aspects of network programming in a portable manner,
  55. making it convenient for both simplifying the process of adding a
  56. server to your application or for learning about how network services
  57. work. Several example servers are provided already, such as an HTTP
  58. server and an IRC server.")
  59. (license gpl3+)))