ragel.scm 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
  3. ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages ragel)
  20. #:use-module ((guix licenses) #:prefix license:)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (gnu packages))
  25. (define-public ragel
  26. (package
  27. (name "ragel")
  28. (version "6.10")
  29. (source (origin
  30. (method url-fetch)
  31. (uri (string-append "https://www.colm.net/files/ragel/ragel-"
  32. version ".tar.gz"))
  33. (sha256
  34. (base32
  35. "0gvcsl62gh6sg73nwaxav4a5ja23zcnyxncdcdnqa2yjcpdnw5az"))))
  36. (build-system gnu-build-system)
  37. (home-page "https://www.colm.net/open-source/ragel/")
  38. (synopsis "State machine compiler")
  39. (description
  40. "Ragel compiles executable finite state machines from regular languages.
  41. Ragel targets C, C++, Obj-C, C#, D, Java, Go and Ruby. Ragel state machines
  42. can not only recognize byte sequences as regular expression machines do, but
  43. can also execute code at arbitrary points in the recognition of a regular
  44. language. Code embedding is done using inline operators that do not disrupt
  45. the regular language syntax.")
  46. ;; GPLv2 (or later) with exception for generated code.
  47. (license license:gpl2+)))