pv.scm 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Claes Wallin <claes.wallin@greatsinodevelopment.com>
  3. ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages pv)
  20. #:use-module (guix licenses)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu))
  24. (define-public pv
  25. (package
  26. (name "pv")
  27. (version "1.6.20")
  28. (source
  29. (origin
  30. (method url-fetch)
  31. (uri (string-append "https://www.ivarch.com/programs/sources/pv-"
  32. version ".tar.bz2"))
  33. (sha256
  34. (base32 "00y6zla8h653sn4axgqz7rr0x79vfwl62a7gn6lzn607zwg9acg8"))))
  35. (build-system gnu-build-system)
  36. (home-page "https://www.ivarch.com/programs/pv.shtml")
  37. (synopsis "Pipeline progress indicator")
  38. (description
  39. "@acronym{pv, Pipe Viewer} is a terminal tool for monitoring the progress
  40. of data through a pipeline. It can be inserted into any normal pipeline
  41. between two processes. It gives a visual indication of how quickly data is
  42. passing through, how much has been transferred and how near to completion it is
  43. (with a progress bar), how long it has taken, and an estimate of the remaining
  44. time before completion.")
  45. (license artistic2.0)))