plan9.scm 2.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2021 宋文武 <iyzsong@member.fsf.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages plan9)
  19. #:use-module (guix build-system gnu)
  20. #:use-module (guix git-download)
  21. #:use-module (guix packages)
  22. #:use-module (guix utils)
  23. #:use-module ((guix licenses) #:prefix license:)
  24. #:use-module (gnu packages xorg))
  25. (define-public drawterm
  26. (let ((revision "1")
  27. (commit "c97fe4693f6112504d6f13fab46f7cc8b27685c1"))
  28. (package
  29. (name "drawterm")
  30. (version (git-version "20210628" revision commit))
  31. (source
  32. (origin
  33. (method git-fetch)
  34. (uri (git-reference
  35. (url "git://git.9front.org/plan9front/drawterm")
  36. (commit commit)))
  37. (file-name (git-file-name name version))
  38. (sha256
  39. (base32 "059sl60ap6c9lz8k91k6bd34694a290wm0s93b2vfszzzv683spw"))))
  40. (build-system gnu-build-system)
  41. (arguments
  42. `(#:make-flags (list "CONF=unix"
  43. (string-append "CC=" ,(cc-for-target)))
  44. #:tests? #f ; no tests
  45. #:phases
  46. (modify-phases %standard-phases
  47. (delete 'configure) ; no configure script
  48. (replace 'install ; no install target
  49. (lambda* (#:key outputs #:allow-other-keys)
  50. (let* ((out (assoc-ref outputs "out"))
  51. (bin (string-append out "/bin/"))
  52. (man (string-append out "/share/man/man1/")))
  53. (install-file "drawterm" bin)
  54. (install-file "drawterm.1" man)))))))
  55. (inputs
  56. `(("libx11" ,libx11)
  57. ("libxt" ,libxt)))
  58. (synopsis "Connect to Plan 9 systems")
  59. (home-page "http://drawterm.9front.org")
  60. (description
  61. "@command{drawterm} is a client for connecting venerable systems to
  62. Plan 9 systems. It behaves like a Plan 9 kernel and will attempt to
  63. reconstruct a Plan 9 terminal-like experience from a non-Plan 9 system.")
  64. (license license:expat))))