openbox.scm 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
  3. ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2017 Nikita <nikita@n0.is>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages openbox)
  21. #:use-module ((guix licenses) #:select (gpl2+))
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (gnu packages freedesktop)
  26. #:use-module (gnu packages gettext)
  27. #:use-module (gnu packages gnome)
  28. #:use-module (gnu packages gtk)
  29. #:use-module (gnu packages image)
  30. #:use-module (gnu packages pkg-config)
  31. #:use-module (gnu packages python)
  32. #:use-module (gnu packages xdisorg)
  33. #:use-module (gnu packages xml)
  34. #:use-module (gnu packages xorg))
  35. (define-public openbox
  36. (package
  37. (name "openbox")
  38. (version "3.6.1")
  39. (source (origin
  40. (method url-fetch)
  41. (uri (string-append
  42. "http://openbox.org/dist/openbox/" name "-"
  43. version ".tar.xz"))
  44. (sha256
  45. (base32
  46. "0vg2y1qddsdxkjv806mzpvmkgzliab8ll4s7zm7ma5jnriamirxb"))))
  47. (build-system gnu-build-system)
  48. (native-inputs `(("pkg-config" ,pkg-config)))
  49. (propagated-inputs `(("python2-pyxdg" ,python2-pyxdg)))
  50. (inputs `(("imlib2" ,imlib2)
  51. ("libxml2" ,libxml2)
  52. ("librsvg" ,librsvg)
  53. ("libsm" ,libsm)
  54. ("libxcursor" ,libxcursor)
  55. ("libxinerama" ,libxinerama)
  56. ("libxml2" ,libxml2)
  57. ("libxrandr" ,libxrandr)
  58. ("libxft" ,libxft)
  59. ("pango" ,pango)
  60. ("python-2" ,python-2)))
  61. (synopsis "Box style window manager")
  62. (description
  63. "Openbox is a highly configurable, next generation window manager with
  64. extensive standards support. The *box visual style is well known for its
  65. minimalistic appearance. Openbox uses the *box visual style, while providing
  66. a greater number of options for theme developers than previous *box
  67. implementations.")
  68. (home-page "http://openbox.org/wiki/Main_Page")
  69. (license gpl2+)))
  70. (define-public obconf
  71. (package
  72. (name "obconf")
  73. (version "2.0.4")
  74. (source
  75. (origin
  76. (method url-fetch)
  77. (uri (string-append "http://openbox.org/dist/" name
  78. "/" name "-" version ".tar.gz"))
  79. (sha256
  80. (base32
  81. "1fanjdmd8727kk74x5404vi8v7s4kpq48l583d12fsi4xvsfb8vi"))))
  82. (inputs
  83. `(("gtk+-2" ,gtk+-2)
  84. ("imlib2" ,imlib2)
  85. ("libglade" ,libglade)
  86. ("openbox" ,openbox)
  87. ("startup-notification" ,startup-notification)
  88. ("libsm" ,libsm)
  89. ("librsvg" ,librsvg)
  90. ("libxft" ,libxft)))
  91. (native-inputs
  92. `(("gettext" ,gettext-minimal)
  93. ("pkg-config" ,pkg-config)))
  94. (build-system gnu-build-system)
  95. (arguments
  96. `(#:configure-flags (list "--enable-nls")))
  97. (home-page "http://openbox.org/wiki/ObConf:About")
  98. (synopsis "Openbox configuration tool")
  99. (description
  100. "Obconf is a tool for configuring the Openbox window manager.
  101. You can configure its appearance, themes, and much more.")
  102. (license gpl2+)))
  103. ;;; openbox.scm ends here