onc-rpc.scm 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
  4. ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
  5. ;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
  7. ;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
  8. ;;;
  9. ;;; This file is part of GNU Guix.
  10. ;;;
  11. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  12. ;;; under the terms of the GNU General Public License as published by
  13. ;;; the Free Software Foundation; either version 3 of the License, or (at
  14. ;;; your option) any later version.
  15. ;;;
  16. ;;; GNU Guix is distributed in the hope that it will be useful, but
  17. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  18. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  19. ;;; GNU General Public License for more details.
  20. ;;;
  21. ;;; You should have received a copy of the GNU General Public License
  22. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  23. (define-module (gnu packages onc-rpc)
  24. #:use-module (guix licenses)
  25. #:use-module (guix packages)
  26. #:use-module (guix download)
  27. #:use-module (guix git-download)
  28. #:use-module (gnu packages)
  29. #:use-module (gnu packages autotools)
  30. #:use-module (gnu packages gettext)
  31. #:use-module (gnu packages kerberos)
  32. #:use-module (gnu packages pkg-config)
  33. #:use-module (guix build-system gnu)
  34. #:use-module (guix utils))
  35. (define-public libtirpc
  36. (package
  37. (name "libtirpc")
  38. (version "1.3.1")
  39. (source (origin
  40. (method url-fetch)
  41. (uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
  42. version "/libtirpc-"
  43. version ".tar.bz2"))
  44. (sha256
  45. (base32
  46. "05zf16ilwwkzv4cccaac32nssrj3rg444n9pskiwbgk6y359an14"))))
  47. (build-system gnu-build-system)
  48. (arguments
  49. `(#:configure-flags '("--disable-static")
  50. #:phases
  51. (modify-phases %standard-phases
  52. (add-after 'unpack 'adjust-netconfig-reference
  53. (lambda* (#:key outputs #:allow-other-keys)
  54. (substitute* '("man/netconfig.5"
  55. "man/getnetconfig.3t"
  56. "man/getnetpath.3t"
  57. "man/rpc.3t"
  58. "src/getnetconfig.c"
  59. "tirpc/netconfig.h")
  60. (("/etc/netconfig") (string-append (assoc-ref outputs "out")
  61. "/etc/netconfig"))))))))
  62. (inputs `(("mit-krb5" ,mit-krb5)))
  63. (home-page "https://sourceforge.net/projects/libtirpc/")
  64. (synopsis "Transport-independent Sun/ONC RPC implementation")
  65. (description
  66. "This package provides a library that implements the Sun/ONC RPC (remote
  67. procedure calls) protocol in a transport-independent manner. It supports both
  68. IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
  69. (license bsd-3)))
  70. (define-public libtirpc/hurd
  71. (package/inherit libtirpc
  72. (name "libtirpc-hurd")
  73. (source (origin (inherit (package-source libtirpc))
  74. (patches (search-patches "libtirpc-hurd.patch"))))
  75. (arguments
  76. (substitute-keyword-arguments (package-arguments libtirpc)
  77. ((#:configure-flags flags ''())
  78. ;; When cross-building the target system's krb5-config should be used.
  79. `(list (string-append "ac_cv_prog_KRB5_CONFIG="
  80. (assoc-ref %build-inputs "mit-krb5")
  81. "/bin/krb5-config")))))))
  82. (define-public rpcbind
  83. (package
  84. (name "rpcbind")
  85. (version "1.2.6")
  86. (source
  87. (origin
  88. (method url-fetch)
  89. (uri (string-append "mirror://sourceforge/" name "/" name "/"
  90. version "/"
  91. name "-" version ".tar.bz2"))
  92. (patches (search-patches "rpcbind-CVE-2017-8779.patch"))
  93. (sha256
  94. (base32 "1pp8xvprsfz8nlmmvxf829gilx0ibb08bfs3lhisxrfai5j784sn"))))
  95. (build-system gnu-build-system)
  96. (arguments
  97. `(#:configure-flags
  98. `("--with-systemdsystemunitdir=no" "--enable-warmstarts")))
  99. (inputs
  100. `(("libnsl" ,libnsl)
  101. ("libtirpc" ,libtirpc)))
  102. (native-inputs
  103. `(("pkg-config" ,pkg-config)))
  104. (home-page "http://rpcbind.sourceforge.net/")
  105. (synopsis "Server to convert RPC program numbers into universal addresses")
  106. (description
  107. "@command{Rpcbind} is a server that converts RPC program numbers into
  108. universal addresses.")
  109. (license bsd-3)))
  110. (define-public rpcsvc-proto
  111. (package
  112. (name "rpcsvc-proto")
  113. (version "1.4")
  114. (home-page "https://github.com/thkukuk/rpcsvc-proto")
  115. (source (origin
  116. (method url-fetch)
  117. (uri (string-append home-page "/releases/download/v" version
  118. "/rpcsvc-proto-" version ".tar.xz"))
  119. (sha256
  120. (base32
  121. "0i93wbpw5dk2gf5v4a5hq6frh814wzgjydh7saj28wlgbpqdaja1"))))
  122. (build-system gnu-build-system)
  123. (synopsis "RPCSVC protocol definitions")
  124. (description
  125. "This package provides @code{rpcsvc} @file{protocol.x} files and headers
  126. that are not included with the @code{libtirpc} package. Additionally it
  127. contains @command{rpcgen}, which is used to produce header files and sources
  128. from the protocol files.")
  129. (license bsd-3)))
  130. (define-public libnsl
  131. (package
  132. (name "libnsl")
  133. (version "1.3.0")
  134. (source (origin
  135. (method git-fetch)
  136. (uri (git-reference
  137. (url "https://github.com/thkukuk/libnsl")
  138. (commit (string-append "v" version))))
  139. (file-name (git-file-name name version))
  140. (sha256
  141. (base32
  142. "1dayj5i4bh65gn7zkciacnwv2a0ghm6nn58d78rsi4zby4lyj5w5"))))
  143. (build-system gnu-build-system)
  144. (arguments
  145. `(#:configure-flags '("--disable-static")))
  146. (native-inputs
  147. `(("autoconf" ,autoconf)
  148. ("automake" ,automake)
  149. ("gettext" ,gettext-minimal)
  150. ("libtool" ,libtool)
  151. ("pkg-config" ,pkg-config)))
  152. (inputs
  153. `(("libtirpc" ,libtirpc)))
  154. (synopsis "Public client interface for NIS(YP) and NIS+")
  155. (description "Libnsl is the public client interface for the Network
  156. Information Service / Yellow Pages (NIS/YP) and NIS+. It includes IPv6 support.
  157. This library was part of glibc < 2.26, but is now distributed separately.")
  158. (home-page "https://github.com/thkukuk/libnsl")
  159. ;; The package is distributed under the LGPL 2.1. Some files in
  160. ;; 'src/nisplus/' are LGPL 2.1+, and some files in 'src/rpcsvc/' are BSD-3.
  161. (license lgpl2.1)))