nutrition.scm 3.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
  3. ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages nutrition)
  22. #:use-module (guix packages)
  23. #:use-module (guix licenses)
  24. #:use-module (guix git-download)
  25. #:use-module (guix build-system python)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages databases)
  28. #:use-module (gnu packages gtk)
  29. #:use-module (gnu packages glib)
  30. #:use-module (gnu packages image)
  31. #:use-module (gnu packages python)
  32. #:use-module (gnu packages python-xyz)
  33. #:use-module (gnu packages xml))
  34. (define-public gourmet
  35. (package
  36. (name "gourmet")
  37. (version "0.17.4")
  38. (source
  39. (origin
  40. (method git-fetch)
  41. (uri (git-reference
  42. (url "https://github.com/thinkle/gourmet")
  43. (commit version)))
  44. (file-name (git-file-name name version))
  45. (sha256
  46. (base32
  47. "09a2zk140l4babwdj8pwcgl9v7rvwff9cn7h3ppfhm3yvsgkrx07"))))
  48. (build-system python-build-system)
  49. (native-inputs
  50. `(("distutils-extra" ,python2-distutils-extra)
  51. ("intltool" ,intltool)
  52. ("python-pygtk" ,python2-pygtk))) ;for tests
  53. ;; TODO: Add python-reportlab and/or python-poppler for printing/pdf
  54. ;; export, and python-beautifulsoup for web import plugin.
  55. (inputs
  56. `(("pygtk" ,python2-pygtk)
  57. ("sqlalchemy" ,python2-sqlalchemy)
  58. ("python-lxml" ,python2-lxml)
  59. ("python-pillow" ,python2-pillow)
  60. ("elib.intl" ,python2-elib.intl)))
  61. (arguments
  62. `(#:python ,python-2 ;exception and print syntax
  63. #:tests? #f ;tests look bitrotted
  64. #:phases
  65. (modify-phases %standard-phases
  66. (replace 'install
  67. (lambda* (#:key outputs #:allow-other-keys)
  68. (invoke "python" "setup.py" "install" "--prefix"
  69. (assoc-ref outputs "out")))))))
  70. (home-page "https://thinkle.github.io/gourmet/")
  71. (synopsis "Recipe organizer")
  72. (description
  73. "Gourmet Recipe Manager is a recipe organizer that allows you to collect,
  74. search, organize, and browse your recipes. Gourmet can also generate shopping
  75. lists and calculate nutritional information. It imports Mealmaster,
  76. MasterCook and KRecipe files and exports PDFs, webpages, and other formats.")
  77. (license gpl2+)))