nettle.scm 4.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2016, 2021 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2017, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
  5. ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages nettle)
  22. #:use-module (guix utils)
  23. #:use-module (guix licenses)
  24. #:use-module (guix packages)
  25. #:use-module (guix download)
  26. #:use-module (guix build-system gnu)
  27. #:use-module (gnu packages)
  28. #:use-module (gnu packages multiprecision)
  29. #:use-module (gnu packages m4))
  30. (define-public nettle-2
  31. (package
  32. (name "nettle")
  33. (version "2.7.1")
  34. (source (origin
  35. (method url-fetch)
  36. (uri (string-append "mirror://gnu/nettle/nettle-"
  37. version ".tar.gz"))
  38. (sha256
  39. (base32
  40. "0h2vap31yvi1a438d36lg1r1nllfx3y19r4rfxv7slrm6kafnwdw"))))
  41. (build-system gnu-build-system)
  42. (arguments
  43. ;; 'sexp-conv' and other programs need to have their RUNPATH point to
  44. ;; $libdir, which is not the case by default. Work around it.
  45. '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
  46. (assoc-ref %outputs "out")
  47. "/lib"))
  48. #:phases (modify-phases %standard-phases
  49. (add-after 'install 'move-static-libraries
  50. (lambda* (#:key outputs #:allow-other-keys)
  51. (let ((out (assoc-ref outputs "out"))
  52. (slib (string-append (assoc-ref outputs "static")
  53. "/lib")))
  54. (mkdir-p slib)
  55. (with-directory-excursion (string-append out "/lib")
  56. (for-each (lambda (ar)
  57. (rename-file ar (string-append
  58. slib "/"
  59. (basename ar))))
  60. (find-files "." "\\.a$")))
  61. #t))))))
  62. (outputs '("out" "debug" "static"))
  63. (native-inputs `(("m4" ,m4)))
  64. (propagated-inputs `(("gmp" ,gmp)))
  65. (home-page "https://www.lysator.liu.se/~nisse/nettle/")
  66. (synopsis "C library for low-level cryptographic functionality")
  67. (description
  68. "GNU Nettle is a low-level cryptographic library. It is designed to
  69. fit in easily in almost any context. It can be easily included in
  70. cryptographic toolkits for object-oriented languages or in applications
  71. themselves.")
  72. (license gpl2+)))
  73. (define-public nettle
  74. ;; This version is not API-compatible with version 2. In particular, lsh
  75. ;; cannot use it yet. So keep it separate.
  76. (package (inherit nettle-2)
  77. (version "3.7.3")
  78. (source (origin
  79. (method url-fetch)
  80. (uri (string-append "mirror://gnu/nettle/nettle-"
  81. version ".tar.gz"))
  82. (sha256
  83. (base32
  84. "1w5wwc3q0r97d2ifhx77cw7y8s20bm8x52is9j93p2h47yq5w7v6"))))
  85. (arguments
  86. (substitute-keyword-arguments (package-arguments nettle-2)
  87. ((#:configure-flags flags)
  88. ;; Build "fat" binaries where the right implementation is chosen
  89. ;; at run time based on CPU features (starting from 3.1.)
  90. `(cons "--enable-fat" ,flags))))))