libffcall.scm 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
  3. ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
  5. ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages libffcall)
  22. #:use-module ((guix licenses) #:prefix l:)
  23. #:use-module (guix packages)
  24. #:use-module (guix download)
  25. #:use-module (guix build-system gnu))
  26. (define-public libffcall
  27. (package
  28. (name "libffcall")
  29. (version "2.2")
  30. (source
  31. (origin
  32. (method url-fetch)
  33. (uri (string-append
  34. "mirror://gnu/libffcall/libffcall-" version ".tar.gz"))
  35. (sha256
  36. (base32
  37. "0ixp7kbr7y8s34nsrsdfh77ig5c2zkwr6cfg9v1gm53cggwkgypb"))))
  38. (build-system gnu-build-system)
  39. (arguments
  40. '(#:parallel-build? #f
  41. #:configure-flags '("--disable-static")))
  42. (synopsis "Foreign function calls from interpreters")
  43. (description
  44. "GNU Libffcall is a collection of libraries that can be used to build
  45. foreign function call interfaces in embedded interpreters.")
  46. (home-page "https://www.gnu.org/software/libffcall/")
  47. (license l:gpl2+)))