irc.scm 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
  3. ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
  4. ;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
  5. ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
  6. ;;; Copyright © 2016 Nikita <nikita@n0.is>
  7. ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
  8. ;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
  9. ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
  10. ;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
  11. ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
  12. ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
  13. ;;; Copyright © 2021 WinterHound <winterhound@yandex.com>
  14. ;;;
  15. ;;; This file is part of GNU Guix.
  16. ;;;
  17. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  18. ;;; under the terms of the GNU General Public License as published by
  19. ;;; the Free Software Foundation; either version 3 of the License, or (at
  20. ;;; your option) any later version.
  21. ;;;
  22. ;;; GNU Guix is distributed in the hope that it will be useful, but
  23. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  24. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  25. ;;; GNU General Public License for more details.
  26. ;;;
  27. ;;; You should have received a copy of the GNU General Public License
  28. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  29. (define-module (gnu packages irc)
  30. #:use-module ((guix licenses) #:prefix license:)
  31. #:use-module (guix download)
  32. #:use-module (guix git-download)
  33. #:use-module (guix utils)
  34. #:use-module (guix packages)
  35. #:use-module (guix utils)
  36. #:use-module (guix build-system cmake)
  37. #:use-module (guix build-system gnu)
  38. #:use-module (guix build-system meson)
  39. #:use-module (guix build-system python)
  40. #:use-module (guix build-system qt)
  41. #:use-module (gnu packages)
  42. #:use-module (gnu packages admin)
  43. #:use-module (gnu packages aspell)
  44. #:use-module (gnu packages autogen)
  45. #:use-module (gnu packages autotools)
  46. #:use-module (gnu packages base)
  47. #:use-module (gnu packages backup)
  48. #:use-module (gnu packages check)
  49. #:use-module (gnu packages code)
  50. #:use-module (gnu packages compression)
  51. #:use-module (gnu packages curl)
  52. #:use-module (gnu packages cyrus-sasl)
  53. #:use-module (gnu packages databases)
  54. #:use-module (gnu packages file)
  55. #:use-module (gnu packages gettext)
  56. #:use-module (gnu packages geo)
  57. #:use-module (gnu packages glib)
  58. #:use-module (gnu packages gnome)
  59. #:use-module (gnu packages gnupg)
  60. #:use-module (gnu packages gtk)
  61. #:use-module (gnu packages guile)
  62. #:use-module (gnu packages lua)
  63. #:use-module (gnu packages lxqt)
  64. #:use-module (gnu packages ncurses)
  65. #:use-module (gnu packages openldap)
  66. #:use-module (gnu packages kde)
  67. #:use-module (gnu packages kde-frameworks)
  68. #:use-module (gnu packages password-utils)
  69. #:use-module (gnu packages pcre)
  70. #:use-module (gnu packages perl)
  71. #:use-module (gnu packages pkg-config)
  72. #:use-module (gnu packages python)
  73. #:use-module (gnu packages python-crypto)
  74. #:use-module (gnu packages python-xyz)
  75. #:use-module (gnu packages regex)
  76. #:use-module (gnu packages ruby)
  77. #:use-module (gnu packages sphinx)
  78. #:use-module (gnu packages sqlite)
  79. #:use-module (gnu packages qt)
  80. #:use-module (gnu packages tcl)
  81. #:use-module (gnu packages textutils)
  82. #:use-module (gnu packages time)
  83. #:use-module (gnu packages tls)
  84. #:use-module (gnu packages web)
  85. #:use-module (srfi srfi-1)
  86. #:use-module (srfi srfi-26))
  87. (define-public quassel
  88. (package
  89. (name "quassel")
  90. (version "0.13.1")
  91. (source
  92. (origin
  93. (method url-fetch)
  94. (uri (string-append "https://quassel-irc.org/pub/quassel-"
  95. version ".tar.bz2"))
  96. (sha256
  97. (base32
  98. "0mg8jydc70vlylppzich26q4s40kr78r3ysfyjwisfvlg2byxvs8"))
  99. (patches (search-patches "quassel-qt-514-compat.patch"))
  100. (modules '((guix build utils)))
  101. ;; We don't want to install the bundled inxi script.
  102. (snippet
  103. '(begin
  104. (delete-file "data/scripts/inxi")
  105. #t))))
  106. (build-system qt-build-system)
  107. (arguments
  108. ;; The three binaries are not mutually exlusive, and are all built
  109. ;; by default.
  110. '(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 6.1 MiB
  111. ;;"-DWANT_CORE=OFF" ; 3.0 MiB
  112. ;;"-DWANT_MONO=OFF" ; 7.6 MiB
  113. "-DWITH_KDE=OFF" ; no to kde integration ...
  114. "-DWITH_BUNDLED_ICONS=ON" ; so we install bundled icons
  115. "-DWITH_OXYGEN_ICONS=ON" ; also the oxygen ones
  116. "-DWITH_WEBENGINE=OFF") ; we don't depend on qtwebengine
  117. #:phases
  118. (modify-phases %standard-phases
  119. (add-after 'unpack 'patch-inxi-reference
  120. (lambda* (#:key inputs #:allow-other-keys)
  121. (let ((inxi (search-input-file inputs "/bin/inxi")))
  122. (symlink inxi "data/scripts/inxi")
  123. #t))))
  124. #:tests? #f)) ; no test target
  125. (native-inputs
  126. `(("extra-cmake-modules" ,extra-cmake-modules)
  127. ("pkg-config" ,pkg-config)
  128. ("qttools" ,qttools)))
  129. (inputs
  130. `(("inxi" ,inxi-minimal)
  131. ("libdbusmenu-qt" ,libdbusmenu-qt)
  132. ("qca" ,qca)
  133. ("qtbase" ,qtbase-5)
  134. ("qtmultimedia" ,qtmultimedia)
  135. ("qtscript" ,qtscript)
  136. ("qtsvg" ,qtsvg)
  137. ("snorenotify" ,snorenotify)
  138. ("zlib" ,zlib)))
  139. (home-page "https://quassel-irc.org/")
  140. (synopsis "Distributed IRC client")
  141. (description "Quassel is a distributed IRC client, meaning that one or more
  142. clients can attach to and detach from the central core. It resembles the
  143. popular combination of screen and a text-based IRC client such as WeeChat or
  144. irssi, but graphical.")
  145. (license (list license:gpl2 license:gpl3)))) ;; dual licensed
  146. (define-public irssi
  147. (package
  148. (name "irssi")
  149. (version "1.2.3")
  150. (source (origin
  151. (method url-fetch)
  152. (uri (string-append "https://github.com/irssi/irssi/"
  153. "releases/download/" version "/irssi-"
  154. version ".tar.xz"))
  155. (sha256
  156. (base32
  157. "17vninwcdfxw39xl2q55qircckckjk2xlvkvlwgj5lhlxppvyix6"))))
  158. (build-system gnu-build-system)
  159. (arguments
  160. `(#:phases
  161. (modify-phases %standard-phases
  162. (replace 'configure
  163. (lambda* (#:key inputs outputs #:allow-other-keys)
  164. (let ((out (assoc-ref outputs "out")))
  165. (setenv "CONFIG_SHELL" (which "bash"))
  166. (invoke "./configure"
  167. (string-append "--prefix=" out)
  168. (string-append "--with-proxy")
  169. (string-append "--with-socks")
  170. (string-append "--with-bot")))))
  171. (add-before 'check 'set-home
  172. (lambda _
  173. (setenv "HOME" (getcwd)))))))
  174. (inputs
  175. `(("glib" ,glib)
  176. ("ncurses" ,ncurses)
  177. ("openssl" ,openssl)
  178. ("perl" ,perl)))
  179. (native-inputs
  180. `(("pkg-config" ,pkg-config)))
  181. (home-page "https://irssi.org/")
  182. (synopsis "Terminal-based IRC client")
  183. (description
  184. "Irssi is a terminal based IRC client for UNIX systems. It also supports
  185. SILC and ICB protocols via plugins.")
  186. (license license:gpl2+)))
  187. (define-public weechat
  188. (package
  189. (name "weechat")
  190. (version "3.3")
  191. (source (origin
  192. (method url-fetch)
  193. (uri (string-append "https://weechat.org/files/src/weechat-"
  194. version ".tar.xz"))
  195. (sha256
  196. (base32
  197. "1pyb1yaw61cbdg1g4cc22px1wsh8wm0gsx1yzp684idyz25apzna"))))
  198. (build-system cmake-build-system)
  199. (native-inputs
  200. `(("gettext" ,gettext-minimal)
  201. ("pkg-config" ,pkg-config)
  202. ;; For tests.
  203. ("cpputest" ,cpputest)))
  204. (inputs
  205. `(("aspell" ,aspell)
  206. ("curl" ,curl)
  207. ("gnutls" ,gnutls)
  208. ("libgcrypt" ,libgcrypt "out")
  209. ("ncurses" ,ncurses)
  210. ("zlib" ,zlib)
  211. ;; Scripting language plug-ins.
  212. ("guile" ,guile-3.0)
  213. ("lua" ,lua-5.1)
  214. ("perl" ,perl)
  215. ("python" ,python)
  216. ("tcl" ,tcl)))
  217. (arguments
  218. `(#:configure-flags
  219. (list "-DENABLE_PHP=OFF"
  220. "-DENABLE_RUBY=OFF"
  221. "-DENABLE_TESTS=ON") ; ‘make test’ fails otherwise
  222. ;; Tests hang indefinitely on non-Intel platforms.
  223. #:tests? ,(if (any (cute string-prefix? <> (or (%current-target-system)
  224. (%current-system)))
  225. '("i686" "x86_64"))
  226. '#t '#f)))
  227. (synopsis "Extensible chat client")
  228. (description "WeeChat (Wee Enhanced Environment for Chat) is an
  229. @dfn{Internet Relay Chat} (IRC) client, which is designed to be light and fast.
  230. The client uses a curses frontend, and there are remote interfaces for Web,
  231. Qt, Android, and Emacs.
  232. Everything in WeeChat can be done with the keyboard, though it also supports
  233. using a mouse. It is customizable and extensible with plugins and scripts.")
  234. (home-page "https://www.weechat.org/")
  235. (license license:gpl3)))
  236. (define-public srain
  237. (package
  238. (name "srain")
  239. (version "1.3.0")
  240. (source
  241. (origin
  242. (method git-fetch)
  243. (uri (git-reference
  244. (url "https://github.com/SrainApp/srain")
  245. (commit version)))
  246. (file-name (git-file-name name version))
  247. (sha256
  248. (base32 "14s0h5wgvlkdylnjis2fa7m835142jzw0d0yqjnir1wqnwmq1rld"))))
  249. (build-system meson-build-system)
  250. (arguments
  251. `(#:tests? #f ;there are no tests
  252. #:glib-or-gtk? #t))
  253. (native-inputs
  254. `(("gettext" ,gettext-minimal)
  255. ("glib:bin" ,glib "bin")
  256. ("pkg-config" ,pkg-config)
  257. ("python" ,python-wrapper)
  258. ("python-sphinx" ,python-sphinx)))
  259. (inputs
  260. `(("glib-networking" ,glib-networking)
  261. ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
  262. ("gtk+" ,gtk+)
  263. ("libconfig" ,libconfig)
  264. ("libsecret" ,libsecret)
  265. ("libsoup" ,libsoup)
  266. ("openssl" ,openssl)))
  267. (home-page "https://srain.im")
  268. (synopsis "Modern IRC client written in GTK")
  269. (description
  270. "Srain is an IRC client written in GTK. It aims to be modern and easy to
  271. use while still remaining useful to power users. It also has partial support
  272. for the IRCv3 protocol.")
  273. (license license:gpl3+)))
  274. (define-public ircii
  275. (package
  276. (name "ircii")
  277. (version "20210314")
  278. (source (origin
  279. (method url-fetch)
  280. (uri (string-append "https://ircii.warped.com/"
  281. name "-" version ".tar.gz"))
  282. (sha256
  283. (base32
  284. "04jczayv1vdn21fcf5zkfaa98sy7d6ydrv2sns2i67gvya2z28j3"))))
  285. (build-system gnu-build-system)
  286. ;; TODO: We should package a small socks4/5 library/server to configure
  287. ;; ircii with socks client. `ghc-socks' pulls in lots of haskell, which
  288. ;; is too big.
  289. (arguments
  290. `(#:tests? #f
  291. #:configure-flags (list
  292. "--enable-ipv6"
  293. "--with-emacs-meta-keys"
  294. (string-append "--with-openssl="
  295. (assoc-ref %build-inputs "openssl")))
  296. #:phases
  297. (modify-phases %standard-phases
  298. (add-after 'unpack 'patch-bsdinstall-absolute-path-bins
  299. (lambda* (#:key inputs #:allow-other-keys)
  300. (substitute* "bsdinstall"
  301. (("/bin/strip") "strip")
  302. (("/bin/cp") "cp")
  303. (("/bin/chmod") "chmod")
  304. (("/etc/chown") "chown")
  305. (("/bin/chgrp") "chgrp")
  306. (("/bin/mkdir") "mkdir")
  307. (("/bin/rm") "rm")
  308. (("/bin/mv") "mv")))))))
  309. (inputs
  310. `(("ncurses" ,ncurses)
  311. ("openssl" ,openssl)))
  312. (native-inputs
  313. `(("pkg-config" ,pkg-config)
  314. ("perl" ,perl)))
  315. (home-page "http://www.eterna.com.au/ircii/")
  316. (synopsis "Terminal-based IRC and ICB client")
  317. (description
  318. "ircII is a terminal based IRC and ICB client for UNIX systems.")
  319. (license license:bsd-3)))
  320. (define-public catgirl
  321. (package
  322. (name "catgirl")
  323. (version "1.9a")
  324. (source (origin
  325. (method url-fetch)
  326. (uri (string-append "https://git.causal.agency/catgirl/snapshot/"
  327. name "-" version ".tar.gz"))
  328. (sha256
  329. (base32
  330. "0pci8crcgm33zb58y7ky2aydzyqsirj8ri8ik1zdlz6npadbjj9h"))))
  331. (build-system gnu-build-system)
  332. (arguments
  333. `(#:tests? #f ; no tests
  334. #:make-flags (list (string-append "PREFIX=" %output)
  335. ,(string-append "CC=" (cc-for-target)))))
  336. (native-inputs
  337. `(("universal-ctags" ,universal-ctags)
  338. ("pkg-config" ,pkg-config)))
  339. (inputs
  340. `(("libressl" ,libressl)
  341. ("ncurses" ,ncurses)))
  342. (home-page "https://git.causal.agency/catgirl")
  343. (synopsis "TLS-only terminal IRC client")
  344. (description
  345. "@command{catgirl} is a TLS-only terminal IRC client.
  346. Notable features include:
  347. @itemize
  348. @item Tab complete: most recently seen or mentioned nicks are completed first.
  349. Commas are inserted between multiple nicks.
  350. @item Prompt: the prompt clearly shows whether input will be interpreted as a
  351. command or sent as a message.
  352. @item Split scroll: keeps the latest messages in view while scrolling.
  353. @item URL detection: recent URLs from a particular user or matching a
  354. substring can be opened or copied.
  355. @item Nick coloring: color generation based on usernames remains stable across
  356. nick changes. Mentions of users in messages are colored.
  357. @item Topic diffing: the modified portion of a channel topic change is
  358. highlighted.
  359. @end itemize")
  360. (license license:gpl3+)))
  361. (define-public ii
  362. (package
  363. (name "ii")
  364. (version "1.8")
  365. (source (origin
  366. (method url-fetch)
  367. (uri (string-append "http://dl.suckless.org/tools/"
  368. name "-" version ".tar.gz"))
  369. (sha256
  370. (base32
  371. "1lk8vjl7i8dcjh4jkg8h8bkapcbs465sy8g9c0chfqsywbmf3ndr"))))
  372. (build-system gnu-build-system)
  373. (arguments
  374. `(#:tests? #f ; no tests
  375. #:make-flags (list (string-append "PREFIX=" %output)
  376. ,(string-append "CC=" (cc-for-target)))
  377. #:phases
  378. (modify-phases %standard-phases
  379. (delete 'configure)))) ; no configure
  380. (home-page "https://tools.suckless.org/ii/")
  381. (synopsis "FIFO and file system based IRC client")
  382. (description
  383. "ii (Irc it) is a minimalist FIFO and file system based IRC client.")
  384. (license license:expat)))
  385. (define-public sic
  386. (package
  387. (name "sic")
  388. (version "1.2")
  389. (source (origin
  390. (method url-fetch)
  391. (uri (string-append "http://dl.suckless.org/tools/"
  392. name "-" version ".tar.gz"))
  393. (sha256
  394. (base32
  395. "11aiavxp44yayibc58bvimi8mrxvbw1plbci8cnbl4syk42zj1xc"))))
  396. (build-system gnu-build-system)
  397. (arguments
  398. `(#:tests? #f ; no tests
  399. #:make-flags (list ,(string-append "CC=" (cc-for-target))
  400. (string-append "PREFIX=" %output))
  401. #:phases
  402. (modify-phases %standard-phases
  403. (delete 'configure)))) ; no configure
  404. (home-page "https://tools.suckless.org/sic/")
  405. (synopsis "Simple IRC client")
  406. (description
  407. "sic is a simple IRC client, even more minimalistic than ii.")
  408. (license license:expat)))
  409. (define-public kirc
  410. (package
  411. (name "kirc")
  412. (version "0.2.7")
  413. (source (origin
  414. (method git-fetch)
  415. (uri (git-reference
  416. (url "https://github.com/mcpcpc/kirc")
  417. (commit version)))
  418. (file-name (git-file-name name version))
  419. (sha256
  420. (base32 "0phx00lr7ya8rx1hskv1wdwbq2vlihiqhnplqdvk1r3m23is7al9"))))
  421. (build-system gnu-build-system)
  422. (arguments
  423. `(#:tests? #f ; no tests
  424. #:make-flags
  425. (list (string-append "CC=" ,(cc-for-target))
  426. (string-append "PREFIX=" %output))
  427. #:phases
  428. (modify-phases %standard-phases
  429. (delete 'configure)))) ; No ./configure script
  430. (synopsis "IRC client written in POSIX C99")
  431. (description "Kirc is an Internet Relay Chat (IRC) client. It includes
  432. support for Simple Authentication and Security Layer (SASL), the
  433. client-to-client (CTCP) protocol, simple chat history logging, synchronous
  434. message handling, multi-channel joining at server connection, full support for
  435. all RFC 2812 commands, and customized color scheme definitions.")
  436. (home-page "http://kirc.io/index.html")
  437. (license license:expat)))
  438. (define-public limnoria
  439. (package
  440. (name "limnoria")
  441. (version "2019.11.22")
  442. (source
  443. (origin
  444. (method url-fetch)
  445. (uri (pypi-uri "limnoria" version))
  446. (sha256
  447. (base32 "0853xk1ps3v6lkmfx50wv56vynnzpl84v66hxnhl8i34zl36kk3c"))))
  448. (build-system python-build-system)
  449. (inputs
  450. `(("python-pytz" ,python-pytz)
  451. ("python-chardet" ,python-chardet)
  452. ("python-dateutil" ,python-dateutil)
  453. ("python-gnupg" ,python-gnupg)
  454. ("python-feedparser" ,python-feedparser)
  455. ("python-sqlalchemy" ,python-sqlalchemy)
  456. ("python-socksipy-branch" ,python-socksipy-branch)
  457. ("python-ecdsa" ,python-ecdsa)))
  458. (native-inputs
  459. `(("python-mock" ,python-mock)))
  460. ;; Despite the existence of a test folder there is no test phase.
  461. ;; We need to package https://github.com/ProgVal/irctest and write
  462. ;; our own testphase.
  463. (arguments
  464. `(#:tests? #f))
  465. (home-page "https://github.com/ProgVal/Limnoria")
  466. (synopsis "Modified version of Supybot (an IRC bot and framework)")
  467. (description
  468. "Modified version of Supybot with Python 3 and IRCv3 support,
  469. embedded web server, translations (fr, fi, it, hu, de), and many
  470. other enhancements and bug fixes.")
  471. (license license:bsd-3)))
  472. (define-public epic5
  473. (package
  474. (name "epic5")
  475. (version "2.0.1")
  476. (source (origin
  477. (method url-fetch)
  478. (uri (string-append "http://ftp.epicsol.org/pub/"
  479. "epic/EPIC5-PRODUCTION/"
  480. name "-" version ".tar.xz"))
  481. (sha256
  482. (base32
  483. "1ap73d5f4vccxjaaq249zh981z85106vvqmxfm4plvy76b40y9jm"))))
  484. (build-system gnu-build-system)
  485. (arguments
  486. `(#:test-target "test"
  487. #:phases
  488. (modify-phases %standard-phases
  489. (add-after 'unpack 'patch-perl
  490. (lambda _
  491. (substitute* "regress/crash-irc"
  492. (("perl5") (which "perl")))
  493. #t))
  494. (add-after 'unpack 'patch-bsdinstall
  495. ;; If we just remove /bin/ some part of the bsdinstall breaks.
  496. ;; Furthermore bsdinstalls has a reference to /etc/chmod here, which
  497. ;; means if we leave /etc/ in, install fails.
  498. (lambda _
  499. (substitute* "bsdinstall"
  500. (("/bin/strip") "strip")
  501. (("/bin/cp") "cp")
  502. (("/bin/chmod") "chmod")
  503. (("/bin/chgrp") "chgrp")
  504. (("/bin/mkdir") "mkdir")
  505. (("/bin/rm") "rm")
  506. (("/bin/mv") "mv")
  507. (("/etc/") ""))
  508. #t))
  509. (replace 'configure
  510. (lambda* (#:key outputs #:allow-other-keys)
  511. ;; The tarball uses a very old version of autconf. It does not
  512. ;; understand extra flags like `--enable-fast-install', so
  513. ;; we need to invoke it with just what it understands.
  514. (let ((out (assoc-ref outputs "out")))
  515. ;; 'configure' doesn't understand '--host'.
  516. ,@(if (%current-target-system)
  517. `((setenv "CHOST" ,(%current-target-system)))
  518. '())
  519. (setenv "CONFIG_SHELL" (which "bash"))
  520. (setenv "SHELL" (which "bash"))
  521. (invoke "./configure"
  522. (string-append "--prefix=" out)
  523. "--with-ipv6" "--with-libarchive"
  524. ;; We use libressl because openssl does not come
  525. ;; with the lib/libssl.a which is needed for epic5.
  526. ;; XXX: No matter which implementation is chosen,
  527. ;; epic5 fails to connect to tls ports of roundrobin
  528. ;; irc networks. This however is believed to be an
  529. ;; protocol issue at epic5 related to ircd.
  530. (string-append "--with-ssl="
  531. (assoc-ref %build-inputs "libressl"))
  532. (string-append "--with-tcl="
  533. (assoc-ref %build-inputs "tcl")
  534. "/lib/tclConfig.sh"))))))))
  535. (inputs
  536. `(("libressl" ,libressl)
  537. ("ncurses" ,ncurses)
  538. ("libarchive" ,libarchive) ; CHANGELOG: "Support for loading zip files"
  539. ("perl" ,perl)
  540. ("tcl" ,tcl)
  541. ("ruby" ,ruby)))
  542. (native-inputs
  543. `(("pkg-config" ,pkg-config)))
  544. (home-page "http://epicsol.org")
  545. (synopsis "Epic5 IRC Client")
  546. (description
  547. "EPIC is a IRC client that has been under active development for
  548. over 20 years. It is stable and mature, and offers an excellent ircII
  549. interface for those who are accustomed to the ircII way of doing things.")
  550. (license (list license:bsd-3
  551. license:isc
  552. license:bsd-4
  553. ;; The epic license is equal to the standard three-clause
  554. ;; BSD license except that you are not permitted to remove the
  555. ;; "Redistribution is permitted" clause of the license if you
  556. ;; distribute binaries.
  557. (license:non-copyleft "http://epicsol.org/copyright")))))
  558. (define-public inspircd
  559. (package
  560. (name "inspircd")
  561. (version "3.8.1")
  562. (source
  563. (origin
  564. (method git-fetch)
  565. (uri (git-reference
  566. (url "https://github.com/inspircd/inspircd")
  567. (commit (string-append "v" version))))
  568. (file-name (git-file-name name version))
  569. (sha256
  570. (base32 "1i30649dw84iscxa5as81g96f393mn1i883aq4za5ypdinr5x65g"))))
  571. (build-system gnu-build-system)
  572. (arguments
  573. `(#:configure-flags (map (lambda (module)
  574. (string-append "--enable-extras=" module))
  575. '("m_argon2.cpp"
  576. "m_geo_maxmind.cpp"
  577. "m_ldap.cpp"
  578. "m_mysql.cpp"
  579. "m_pgsql.cpp"
  580. "m_regex_pcre.cpp"
  581. "m_regex_posix.cpp"
  582. "m_regex_stdlib.cpp"
  583. "m_regex_re2.cpp"
  584. "m_regex_tre.cpp"
  585. "m_sqlite3.cpp"
  586. "m_ssl_gnutls.cpp"
  587. "m_ssl_openssl.cpp"
  588. "m_ssl_mbedtls.cpp"
  589. "m_sslrehashsignal.cpp"))
  590. #:tests? #f ; Figure out later.
  591. #:phases
  592. (modify-phases %standard-phases
  593. (add-before 'configure 'module-configure
  594. (lambda* (#:key configure-flags #:allow-other-keys)
  595. (apply invoke "./configure"
  596. configure-flags)
  597. #t))
  598. (replace 'configure
  599. (lambda* (#:key outputs #:allow-other-keys)
  600. (let* ((out (assoc-ref outputs "out"))
  601. (out-lib (string-append out "/lib/"))
  602. (out-bin (string-append out "/bin/"))
  603. (out-etc (string-append out "/etc/"))
  604. (name "inspircd"))
  605. (invoke "./configure"
  606. (string-append "--prefix=" out-lib name)
  607. (string-append "--binary-dir=" out-bin)
  608. (string-append "--module-dir=" out-lib name "/modules/")
  609. (string-append "--config-dir=" out-etc name)))
  610. #t)))))
  611. (native-inputs
  612. `(("pkg-config" ,pkg-config)))
  613. (inputs
  614. `(("argon2" ,argon2)
  615. ("gnutls" ,gnutls)
  616. ("libmaxminddb" ,libmaxminddb)
  617. ("mbedtls-apache" ,mbedtls-apache)
  618. ("mysql" ,mysql)
  619. ("openldap" ,openldap)
  620. ("openssl" ,openssl)
  621. ("pcre" ,pcre "bin")
  622. ("perl" ,perl)
  623. ("postgresql" ,postgresql)
  624. ("re2" ,re2)
  625. ("sqlite" ,sqlite)
  626. ("tre" ,tre)))
  627. (synopsis "Modular IRC server written in C++")
  628. (description "InspIRCd is a modular Internet Relay Chat
  629. server written in C++ for Unix-like operating systems.")
  630. (home-page "https://www.inspircd.org/")
  631. (license license:gpl2)))