gnu-pw-mgr.scm 2.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
  3. ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
  4. ;;; Copyright © 2016, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
  5. ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages gnu-pw-mgr)
  22. #:use-module (guix packages)
  23. #:use-module (guix licenses)
  24. #:use-module (guix download)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages base)
  28. #:use-module (gnu packages autogen))
  29. (define-public gnu-pw-mgr
  30. (package
  31. (name "gnu-pw-mgr")
  32. (version "2.7.4")
  33. (source
  34. (origin
  35. (method url-fetch)
  36. (uri (string-append "mirror://gnu/gnu-pw-mgr/gnu-pw-mgr-"
  37. version ".tar.xz"))
  38. (sha256
  39. (base32 "0fhwvsmsqpw0vnivarfg63l8pgwqfv7d5wi6l80jpb41dj6qpjz8"))))
  40. (build-system gnu-build-system)
  41. (arguments
  42. '(#:phases
  43. (modify-phases %standard-phases
  44. (add-after 'patch-source-shebangs 'patch-more-shebangs
  45. (lambda _
  46. (substitute* "tests/dom.test"
  47. (("/usr/bin/printf") (which "printf")))
  48. #t))
  49. (add-before 'check 'pre-check
  50. (lambda _
  51. ;; In the build environment, there is no /dev/tty.
  52. (substitute* "tests/base.test"
  53. (("/dev/tty") "/dev/null"))
  54. #t)))))
  55. (native-inputs
  56. `(("which" ,which)))
  57. (home-page "https://www.gnu.org/software/gnu-pw-mgr/")
  58. (synopsis "Retrieve login credentials without recording passwords")
  59. (description
  60. "This program is designed to make it easy to reconstruct difficult
  61. passwords when they are needed while limiting the risk of attack. The
  62. user of this program inputs a self-defined transformation of a web
  63. site URL and obtains the password and user name hint for that web
  64. site.")
  65. (license gpl3+)))